Department of Engineering

IT Services

The ABAQUS FAQ


13. ABAQUS/Viewer - General

Q13.1 : Is it possible to use the same set of commands repeatedly for post processing different analyses?

Yes. The commands you type in during a session of ABAQUS/Viewer is written to a file called abaqus.rpy. This is Python script. Make a copy of this file (say) analysis.py. Then this file can be edited and used in the next session by choosing Run script from the menu : after starting ABAQUS/Viewer. It is also possible to edit and then re-use it.


Q13.2 : Is it possible to cut open and develop a cylindrical mesh and produce contour plots on the developed flat surface?

No. It is not possible to do this with ABAQUS/Viewer. However it is possible with FEMGV. See answer to the question Q23.4.


Q13.3 : Is it possible to use the displacements in terms of local co-ordinates in post processing an analysis with an axisymmetric mesh and non-axisymmetric loading?

Yes. It is possible to do using Python script to modify the *.odb file to have the additional data (of the calculated displacements (radial and tangential) written to it.
This is illustrated in the section 8.9.6 Computations with components of a FieldValue Object in the ABAQUS Scripting manual for the example problem esf4sxdg.


Q13.4 : Is it possible to choose your own layout for multiplots other than the 1,4,9 frames per page option provided by ABAQUS/Plot?

Yes it is possible. However with a bit of effort one could choose ones own layout and then produce a hardcopy of it. create a new viewport and change its size and position.
For example one can have 2 viewports either in the portrait mode (one above the other, vertical) or the landscape mode (side by side, horizontal).


Q13.5 : Is it possible to take a section along a line of nodes and plot the stress distribution for a selected eigenmode in a frequency analysis?

No. It is not possible to do this with ABAQUS/Viewer. However it is possible with FEMGV. See answer to the question Q23.6.


Q13.6 : Is it possible to produce a contour plot of the stress distribution for a selected eigenmode in a frequency analysis?

No it is not possible to produce a contour plot of stress or any other output parameter for any of the eigenmodes in a frequency analysis. However this is possible with FEMGV and PATRAN.

Q13.7 : Is it possible to produce a plot of the applied boundary conditions?

If the applied boundary conditions were specified using the ABAQUS/CAE program it will be able to display the applied boundary conditions.
Under certain circumstances one can import a model. File -> Import -> Model and select a ABAQUS input file. Then select the module load -> BC Manager and this may display the boundary conditions.

Q13.8 : Is it possible to produce a plot of the applied loading?

If the applied loading were specified using the ABAQUS/CAE program it will be able to display this loading.
One could also try the approach for the BC. Import the input file into CAE and selecting the load module and then the Load manager.

Q13.9 : Is it possible to draw only a subset of the mesh?

Any element sets and node sets that have been created can be selected.
In the Visualisation module ie when using ABAQUS/Viewer choose Tools and Display Group ==> Create..
In the new form Items lists categories to choose from : Instances, Nodes, Elements, Surfaces .. Make a selection and choose again from the options available in Select Methods. If for example a previously defined element set has been selected then use the Replace option to switch the rest off from view.
Once you have completed the required task select ALL ELEMENTS and Add option to restore the entire mesh to be visible again.
REBAR to display the position of reinforcements modelled using REBAR.
SURFACE can be used to specify surface names and surface set names.

Q13.10 : After viewing a subset of the mesh what is the command to restore the view of the whole mesh?

 Select ALL.
 


Q13.11 : Is it possible to find the location a particular node?

Use the Create Display Group icon in the Visualisation module.
In the Visualisation module ie when using ABAQUS/Viewer choose Tools and Display Group ==> Create..
In the new form Items lists categories to choose from : Instances, Nodes, Elements, Surfaces .. Select Nodes and choose Node labels from Select Methods. Now enter the Node number in the box on the RHS. Click on the button marked Highlight which is immediately below, This would highlight the node using a red circle. ----------------------------------------------------------------------------------------------
If for example a previously defined element set has been selected then use the Replace option to switch the rest off from view.
Once you have completed the required task select ALL ELEMENTS and Add option to restore the entire mesh to be visible again. ----------------------------------------------------------------------------------------------

Q13.12 : Is it possible to find the nodes associated with a particular element?

Yes. You can use the same method to locate a node above (see answer to question

Q13.11)

but instead search for the element. Once the element has been identified and highlighted use the Query option. For this choose Tools and Query...
In the Query Form select Probe values for Visualisation Module Queries and then click on Apply. This will bring up the Probe Value form. Set the Probe to Element. Then tick the Nodes from the table below. Then click on the Element for which you require the nodes associated with it. You will also notice that as you move the mouse around element numbers are displayed as the mouse traverses the element. Another useful way to find the element number without having to switch on the numbers for all elements either for the whole mesh or group.
When you click on a particular element information which have been ticked i.e. requested is listed in a table. Repeat the process if you require information about other elements. The information accumulated in this way can be written to a text file. Click on the Write to File button and type in a appropriate file name and customise the format of the output.
This method can be used to probe for various output parameters, For example Avon Mies stress. The variable is selected by clicking on the button marked Field Value... and making the selection from the available output table. Again if the selected output parameter is ticked the value will get entered in the table. Repeat this procedure as required.

Q13.13 : When using the dynamic drawing capabilities of ABAQUS/Viewer using the mouse the mesh has disappeared from view. How can I restore the mesh view?

Click on the Auto Fit icon.

Q13.14 : How can I find which variable I can use in which type of plot and from which file?

Consult the chapter on Output Variable Identifiers in the ABAQUS/Standard Manual (Chapter 4).
The variables are printed under separate tables depending on whether it is an element integration point variable, element section variable or nodal variable or some other type of variable. Some variables are analysis dependent. The first task is to locate the variable in one of these tables.
Then look for the filled circle under the heading under the column marked Field and History under .odb. If found under the Field heading then that variable can be processed as a field variable. Contours can be drawn. or path plot of the variable (which could be a scalar quantity or a vector component) in question can be obtained. Similarly look under History for a producing plots of variation through the analysis for the selected variable. For example the plots of a stress or strain component at a given integration point of an element through the analysis or time. The same applies to a displacement at and node, applied force or a reaction at node fixed in a given direction.
A stress-strain plot or a force-displacement plot can be derived by generating the history plots separately for each output variable.
Combining the plots created in the above section the Force-Displacement plot can be created as follows :
From the main menu bar
  1. select Tools -> XY Data -> Manager.
  2. In the XY Data Manager dialog box click on Create....
  3. In the Create XY Data dialog box toggle on Operate on XY data and then click on Continue.... The Operate on XY Data dialog box appears. This contains the following lines : The XY data field on the left has a box for entering an expression. Below that a list of existing X-Y data objects (this should have the 2 plots created in the above section). The operator's field on the right contains a list of all the possible operations you can perform on the data object.
  4. From the operators field click on combine(x,x). combine ( ) appears in the expression box.
  5. Double click on the XYData yDisp-9 and this will appear within the brackets.
  6. Type a comma ", " and then double click on the XYData yForce-9 The expression box should look like : combine ( " yDisp-9 " , " yForce-9 " )
  7. Then click on Save As... button and name the plot as Force-Disp-Nde9. Click on OK.
  8. Then Click on Plot Expression button and this should display the Force-Displacement plot.

Q13.15 : How do I plot the surface normals for a pair of surfaces in a contact analysis?

First of all create a surface set which consists of the pair of surfaces in contact. Then use the DETAIL and DRAW commands :
 *surface set, name=blsurf 
 >blank_t, punch
 > CR 

 Here CR represents the RETURN key 

 *zoom, reset 
 *detail, surface=blsurf 
 set,vector length=0.002 
 *set, vector tip scale=0.003 
 *draw, normals 
 
This example is taken from the Chapter on Contact in the Getting started with ABAQUS/Standard book.

Q13.16 : Is it possible to colour the different components differently in a complex mesh?

Click on the Color Code Display icon. This will bring up the a dialog box. For the entry Color Code by scroll down and select Part Instances.
It will display the default colours for the parts and instances. To change the colour of any instance click on the colour for that instance.
In this example click on White.
Then the current colour (White) will be displayed in the bottom Right hand corner of the dialog box. It will have the label Edit Color. Click on this and from the colour palette select the colour you want and then click on OK. Click OK in the Color code dialog box.

Q13.17 : How do I change the background colour of the viewport?

Choose View ---> Graphics Option. In the dialog box notice the toggle buttons Solid and Gradient. Gradient will be active. Also notice the colours marked top and bottom. The default is Dark Blue at the top gradually changing to Silver Gray at the bottom. To change the colour to be uniform click on Solid and then click on the top button and choose the colour from colour pallette. Click OK and both dialog boxes.
© Cambridge University Engineering Dept
Information provided by abaqus-support
Last updated: 18 December 2011