Department of Engineering

IT Services

The ABAQUS FAQ


16. ABAQUS/Viewer - XY Plots

Q16.1 : How does one produce a stress vs strain plot for an integration point in a non-linear analysis?

**
*Output, history, frequency=1
*node output, nset=_G5
  CF2,U2
*element output, elset=_G5
E22, S22
**
The above statements included in the ABAQUS input file will write history output for the element set _G5 through the analysis for the normal strain (E22) and stress (S22) in the Y direction.
  • From the main menu bar select Result --> History Output.
  • In the History Output dialog box Select Stress : S22 at Element 9 Int Pt 1 from the list Output Variable.
  • Click on Save As... button. Enter yStrs-9 in the name box in the Save XYData As form. Then click on OK.
    Notice the note : XYData are only saved for the current ABAQUS session.
  • Click on Plot in the original dialog box.
  • Repeat these steps for the Output Variable with the description Strain : E22 at Element 9 Int Pt 1. Save this as yStrs-9.
Combining the plots created in the above section the Stress-Strain plot can be created as follows :
From the main menu bar
  • select Tools --> XY Data --> Manager.
  • In the XY Data Manager dialog box click on Create....
  • In the Create XY Data dialog box toggle on Operate on XY data and then click on Continue.... The Operate on XY Data dialog box appears. This contains the following lines :
    The XY data field on the left has a box for entering an expression.
    Below that a list of existing X-Y data objects (this should have the 2 plots
    created in the above section).
    
    The operators's field on the right contains a list of all the possible operations you can perform on the data object.
  • From the operators field click on combine(x,x). combine ( ) appears in the expression box.
  • Double click on the XYData yStrn-9 and this will appear within the brackets.
  • Type a comma ``,'' and then double click on the XYData yStrs-9. The expression box should look like : combine ( `` yStrn-9'' , `` yStrs-9'' )
  • Then click on Save As... button and name the plot as Strs-Strn-Elm9. Click on OK.
  • Then Click on Plot Expression button and this should display the Stress-Strain plot.



Q16.2 : Is it possible to read in results from elsewhere (experimental, analytical) and use it to compare it with ABAQUS results?

Yes an ascii file containing a table of rows and column of numbers can be read into ABAQUS/Post. Use the command
 read curve, name=userdata, file=results.dat, xcol=1 ycol=4 
In the above example the results will be read from a file called results.dat and the values in the first column will be used as the x values and the values in the 4th column will be used as the y values. The values in the first 3 columns will be ignored. Needless to say that each line should have at least 4 values. The created curve will be given the name userdata. This can then be used in subsequent plotting using the display curve command.


Q16.3 : Is it possible to write out the data from a XY plot into a file for use elsewhere, example : Matlab?

Yes it is possible. This section deals with how to write out the results from an X-Y Curve. Example the force displacement plot results created in the previous section. From the main menu bar
  • select Report --> XY ... .
  • In the Report XY Data dialog box toggle on $\Diamond$ XY Plot in the Current Viewport. That plot will be highlighted.
  • Click on the Setup tab and the name of the file to which the results will be written to is displayed as abaqus.rpt. This is the default fiel name. If the current results are to be appended to the existing contents make sure the toggle Append to File is ON.
  • It is also possible to control the format of th results from the settings in this dialogue box.
  • Once you have altered the settings to suit your requirement click on OK.
Use a text editor to check the contents of the file. It should be straightforward to import this into a spreadsheet and produce plots comparing either with available experimental or theoretical results.


Q16.4 : I want to create a force vs displacement plot at a node which is subjected to external point load. How do I do it?

** 
** LOADS
** 
** Name: pt-load   Type: Concentrated force
*Cload
_G5, 2, -200.E6
**

..........

**
*Output, history, frequency=1
*node output, nset=_G5
  CF2, U2
*element output, elset=_G5
E22, S22
**

Here the node set _G5 consists of the the node which is subjected to external point loads and for which the plot is required. CF represents such point loads.
  • From the main menu bar select Result --> History Ouput.
  • In the History Ouput dialog box Select Spatial displacement : U2 at node 9 from the list Output Variable.
  • Click on Save As... button. Enter yDisp-9 in the name box in the Save XYData As form. Then click on OK. Notice the note : XYData are only saved for the current ABAQUS session.
  • Click on Plot in the original dialog box.
  • Repeat these steps for the Output Variable with the description Point loads: CF2 at Node 9. Save this as yForce-9.
Combining the plots created in the above section the Force-Displacement plot can be created as follows : From the main menu bar
  • select Tools --> XY Data --> Manager.
  • In the XY Data Manager dialog box click on Create....
  • In the Create XY Data dialog box toggle on Operate on XY data and then click on Continue.... The Operate on XY Data dialog box appears. This contains the following lines : The XY data field on the left has a box for entering an expression. Below that a list of existing X-Y data objects (this should have the 2 plots created in the above section). The operators' field on the right contains a list of all the possible operations you can perform on the data object.
  • From the operators field click on combine(x,x). combine ( ) appears in the expression box.
  • Double click on the XYData yDisp-9 and this will appear within the brackets.
  • Type a comma ``,'' and then double click on the XYData yForce-9. The expression box should look like : combine ( `` yDisp-9'' , `` yForce-9'' )
  • Then click on Save As... button and name the plot as Force-Disp-Nde9. Click on OK.
  • Then Click on Plot Expression button and this should display the Force-Displacement plot.



**
*Output, history, frequency=1
*node output, nset=_G5
  CF2,U2
*element output, elset=_G5
E22, S22
**



Q16.5 :I want to create a force vs displacement plot at a node which has a prescribed non-zero displacement. How do I do it?

In the ABAQUS input file include the following statements :
**
*Output, history, frequency=1
*node output, nset=_G6
 RF2,U2
*element output, elset=_G5
E22, S22
**

Here the node set _G6 is assumed to include the node which is given a prescribed non-zero displacement and for which the plot is required. RF represents the reaction force.
The steps involved are exactly the same as plotting Force vs Displacement plot see the answer to question Question 16.4.
The only difference is in creating this plot instead of the Force at a node the Reaction curve is chosen from the list of History plots.


Q16.6 : I want to create a pressure at an element face vs nodal displacement plot where the element in question is subjected to external pressure loading. How do I do it?

In the ABAQUS input file include the following statements :
*NODE FILE, NSET=NDWF,FREQUENCY=n
 U
*EL FILE, FREQUENCY=n
 LOADS

Here the node set NDWF is assumed to include the node which is associated with the element side subjected to pressure loading and for which the plot is required. LOAD represents the pressure applied to element faces.
Then in ABAQUS/Post use the following command.
 results, file=platen 
 read curve, name=press15, element=15, variable=LP3 
 read curve, name=disp21, node=21, var=U2 
 define curve, operation=combine, name=prsdsp 
 > disp21, press15 
 >  
 display curve 
 > prsdsp 
 >  

Here the element face 3 is subjected to the pressure load.

Q16.7 : I want to create a plot of the sum of the reactions at a set of nodes given a prescribed displacement against the displacement at the nodes. How do I do it?

See the answer to Question 11.11.

Q16.8 : How do I find the names of the curves created so far during a session of ABAQUS/Viewer?

This section deals with how to write out the results from an X-Y Curve. Example the force displacement plot results created in the previous section. From the main menu bar
  • select Report --> XY ... .
  • In the Report XY Data dialog box toggle on $\Diamond$ XY Plot in the Current Viewport. That plot will be highlighted.
  • Click on the Setup tab and the name of the file to which the results will be written to is displayed as abaqus.rpt. This is the default fiel name. If the current results are to be appended to the existing contents make sure the toggle Append to File is ON.
  • It is also possible to control the format of th results from the settings in this dialogue box.
  • Once you have altered the settings to suit your requirement click on OK.
Use a text editor to check the contents of the file. It should be straightforward to import this into a spreadsheet and produce plots comparing either with available experimental or theoretical results.
© Cambridge University Engineering Dept
Information provided by abaqus-support
Last updated: 18 December 2011