Department of Engineering

IT Services

The ABAQUS FAQ


4. ABAQUS - Mesh

Q4.1 : I have created a mesh in two parts separately and have ended up with two sets of node numbers along a common edge. Is there any alternative to editing the *.inp file to replace one set of node numbers by the other set in the element-nodal connectivity list ie element entries?

Yes. Use the TIE option available under MPC (Multi Point Constraint) to tie the respective nodes as illustrated in the figure below :
*MPC
TIE,  100, 200
TIE,  101, 201
         ......
TIE,  104, 204


This would then treat these pair of nodes as identical ie. they will have the same nodal variables. This can also be useful in situations where the mesh used in an axisymmetric analysis is generated from a single surface wrapped around (rather than using the axisymmetric elements available in ABAQUS). See figure below. Then the TIE option could be used along line joining the 2 edges (and the 2 sets of nodes).

If there are several such nodes these could be grouped together into sets and the TIE option specified with a single data line. Here the corresponding nodes should appear in the correct order.

*NSET, NSET=TOP
 100,  101,  102,  103,  104
*NSET, NSET=BOT
 200,  201,  202,  203,  204
*MPC
 TIE, TOP, BOT



Q4.2 : I have created a mesh but the scale used is wrong. Is it possible to scale the mesh with ABAQUS?

Use the FORTRAN program given below to scale the X, Y and Z by factors xf, yf anf zf automatically. It will prompt for the ABAQUS input file name. The output file name will be created by appending "new" to the file name.
The program has been tested with ifort in the Linux system, f90 in the HP System and also with Force 2.0 in the Windows PC XP system.
Fortran Program to scale X, Y and Z co-ordinates.

Q4.3 : have created a geometry in a solid modeller but the scale used is wrong. Is it possible to scale the geometry in ABAQUS?

Yes it is possible to scale the Geometry when it is read into the CAE program. Select the appropriate input using File --> Import --> Part
Change the File type to the appropriate depending on the format. Select the file and click on OK. In the form that pops up click on the Scale TAB and set the toggle key for Multiply all lengths and enter an appropriate scale factor value.

Q4.4 : I have a mesh but with one dimension significantly larger than the other 2 dimensions. Is it possible to scale down this dimension for viewing of the mesh with ABAQUS/CAE?

No it is not possible to scale down for viewing in ABAQUS/CAE. However one could import the part and write out a ABAQUS input file and then use the Fortran program listed for Q4.3. Then scale down the dimension in question.
Then read in the input file using File --> Import --> Model.

Q4.5 : I have the results of a mesh but one dimension is significantly larger than the other 2 dimensions. Is it possible to scale down this dimension for viewing of the mesh with ABAQUS/Viewer?

Yes this is possible. In the Visualization module click on the Common Contour Plot Options icon.
In the dialogue box which pops up select the Other tab and check the box marked scale. Use a scale factor to reduce the dimension only in the length direction and this only affects as it is only a viewing scale.

Q4.6 : How do I change the element type being created?

In the Mesh Module choose Mesh -> Element Type and in the dialog box which appears the default element type will listed in the bottom. Make the necessary changes as to choice of Order, Reduced integration and for some element types select Incompatible Mode if using the lower order quadrilateral or 3-D solid to model that involves bending.

Q4.7 : I am trying to mesh a rectangular block region but getting tetrahedra elements whereas I would like to use HEX elements?

In the Mesh Module choose Mesh -> Controls and in the dialog box ensure the toggle buttons Hex for and Structured for Technique have been selected. Click on OK and then use Mesh -> Part to mesh it.

Q4.8 : It is some times tedious having to match the number of seeds on opposite faces/edges in order to create HEX elements in rectangular blocks. Is there a simple alternative?

Instead of assigning seeds individually to element edges select the whole part and assign global seeds, if possible.

Q4.9 : Is it possible to change the default Green colour used for the wireframe/shaded view of the mesh?

Yes its possible to change the colour Green. Click on the Common Plot option icon (the first one first row and the one on the left to the left of the viewport).

In the dialog box which opens choose the Color &/ style tab. There will be 3 lines of colours. The first one controls the colour for the wireframe of the mesh. Click on this colour and from the colour palette which appears choose the colour and click on OK.





The original view is as shown :
Click on OK and this should change the appearance.


Q4.10 : Is it possible to change the default shaded view of the mesh to make it translucent?

Yes its possible to make the shaded view translucent. Click on the Common Plot option icon (the first one first row and the one on the left to the left of the viewport).



In the dialog box which opens choose the Other tab. Choose the tab Translucency. Click on the box marked Apply translucency and the slider bar appears in the box below. The slider controls the amount of translucency. Completely to the Right makes it Opaque. The model becomes translucent as the slider is moved to the left. Click on the Apply button after the slider has been moved to effect the change.
The extreme left position makes it into a wireframe (This means the model is transparent). Click on OK and this should change the appearance.



Q4.11 : Is it possible to change the default Black colour used for element edges in a shaded view of the mesh?

Yes its possible to change the colour Black. Click on the Common Plot option icon (the first one first row and the one on the left to the left of the viewport).

In the dialog box which opens choose the Color & style tab. There will be 3 lines of colours. The second one controls the colour of the edges of the elements in the mesh. Click on this colour and from the colour palette which appears choose the colour and click on OK. Click on OK and this should change the appearance.
See the second figure for the one before the previous question, where the Black colour has been replaced with Red.

Q4.12 :Is it possible to change the line thickness used for the element edges in a wireframe/shaded view of the mesh?

Yes its possible to change the line thickness. Click on the Common Plot option icon (the first one first row and the one on the left to the left of the viewport).

In the dialog box which opens choose the Color & style tab. There will be 2 boxes at the bottom of this dialog box. The second one controls the line thickness of the edges of the elements in the mesh. Click on the scroll bar next to this line and choose a different line thickness.
Click on OK and this should change the appearance.



Q4.13 : Is it possible to change the line style used for the element edges in a wireframe/shaded view of the mesh?

Yes its possible to change the line style used for drawing the element edges. Click on the Common Plot option icon (the first one first row and the one on the left to the left of the viewport).

In the dialog box which opens choose the Color & style tab. At the bottom there are 2 boxes with lines. The first one controls the line style of the edges of the elements in the mesh. Click on the scroll bar next to this line and choose a different line style.
Click on OK and this should change the appearance.
© Cambridge University Engineering Dept
Information provided by abaqus-support
Last updated: 18 December 2011