Getting Started with Pro/ENGINEER® Wildfire™ 3.0

A Tutorial-based Guide to Workflow

March 2006
Copyright © 2005 Parametric Technology Corporation. All Rights Reserved.
User and training documentation from Parametric Technology Corporation (PTC) is subject to the copyright laws of the United States and other countries and is provided under a license agreement that restricts copying, disclosure, and use of such documentation. PTC hereby grants to the licensed user the right to make copies in printed form of this documentation if provided on software media, but only for internal/personal use and in accordance with the license agreement under which the applicable software is licensed. Any copy made shall include the PTC copyright notice and any other proprietary notice provided by PTC. This documentation may not be disclosed, transferred, modified, or reduced to any form, including electronic media, or transmitted or made publicly available by any means without the prior written consent of PTC and no authorization is granted to make copies for such purposes.

Information described herein is furnished for general information only, is subject to change without notice, and should not be construed as a warranty or commitment by PTC. PTC assumes no responsibility or liability for any errors or inaccuracies that may appear in this document.

The software described in this document is provided under written license agreement, contains valuable trade secrets and proprietary information, and is protected by the copyright laws of the United States and other countries. It may not be copied or distributed in any form or medium, disclosed to third parties, or used in any manner not provided for in the software licenses agreement except with written prior approval from PTC. UNAUTHORIZED USE OF SOFTWARE OR ITS DOCUMENTATION CAN RESULT IN CIVIL DAMAGES AND CRIMINAL PROSECUTION.

Registered Trademarks of Parametric Technology Corporation or a Subsidiary

Trademarks of Parametric Technology Corporation or a Subsidiary
**Patents of Parametric Technology Corporation or a Subsidiary**

Registration numbers and issue dates follow. Additionally, equivalent patents may be issued or pending outside of the United States. Contact PTC for further information.

<table>
<thead>
<tr>
<th>Patent Number</th>
<th>Issue Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>GB2366639B</td>
<td>13-October-2004</td>
</tr>
<tr>
<td>GB2363208</td>
<td>25-August-2004</td>
</tr>
<tr>
<td>(EP/DE/GB)0812447</td>
<td>26-May-2004</td>
</tr>
<tr>
<td>GB2365567</td>
<td>10-March-2004</td>
</tr>
<tr>
<td>(GB)2388003B</td>
<td>21-January-2004</td>
</tr>
<tr>
<td>6,665,569 B1</td>
<td>16-December-2003</td>
</tr>
<tr>
<td>GB2353115</td>
<td>10-December-2003</td>
</tr>
<tr>
<td>6,625,607 B1</td>
<td>23-September-2003</td>
</tr>
<tr>
<td>6,580,428 B1</td>
<td>17-June-2003</td>
</tr>
<tr>
<td>GB2354684B</td>
<td>02-July-2003</td>
</tr>
<tr>
<td>GB2384125</td>
<td>15-October-2003</td>
</tr>
<tr>
<td>GB2354096</td>
<td>12-November-2003</td>
</tr>
<tr>
<td>GB2354924</td>
<td>24-September-2003</td>
</tr>
<tr>
<td>6,608,623 B1</td>
<td>19-August-2003</td>
</tr>
</tbody>
</table>

**Third-Party Trademarks**

Adobe, Acrobat, Distiller, and the Acrobat logo are trademarks of Adobe Systems Incorporated. Advanced ClusterProven, ClusterProven, and the ClusterProven design are trademarks or registered trademarks of International Business Machines Corporation in the United States and other countries and are used under license. IBM Corporation does not warrant and is not responsible for the operation of this software product. AIX is a registered trademark of IBM Corporation. Allegro, Cadence, and Concept are registered trademarks of Cadence Design Systems, Inc. Apple, Mac, Mac OS, and Panther are trademarks or registered trademarks of Apple Computer, Inc. AutoCAD and Autodesk Inventor are registered trademarks of Autodesk, Inc. Baan is a registered trademark of Baan Company. CADAM and CATIA are registered trademarks of Dassault Systemes. COACH is a trademark of CADTRAIN, Inc. CYA, iArchive, HOTbackup, and Virtual StandBy are trademarks or registered trademarks of CYA Technologies, Inc. DOORS is a registered trademark of Telelogic AB. FLEXlm and FLEXnet are registered trademarks of Macrovision Corporation. Geomagic is a registered trademark of Raindrop Geomagic, Inc. EVERSYNC, GROOVE, GROOVEFEST, GROOVE.NET, GROOVE NETWORKS, iGROOVE, PEERWARE, and the interlocking circles logo are trademarks of Groove Networks, Inc. Helix is a trademark of Microcadam, Inc. HOOPS is a trademark of Tech Soft America, Inc. HP-UX is a registered trademark of Hewlett-Packard Company. I-DEAS, Metaphase, Parasolid, SHERPA, Solid Edge, TeamCenter, UG-NX, and Unigraphics are trademarks or registered trademarks of UGS Corp. InstallShield is a registered trademark and service mark of InstallShield Software Corporation in the United States and/or other countries. Intel is a registered trademark of Intel Corporation. IRIX is a registered trademark of Silicon Graphics, Inc. I-Run and ISOGEN are registered trademarks of Alias Ltd. LINUX is a registered trademark of Linus Torvalds. MainWin and Mainsoft are trademarks of Mainsoft Corporation. MatrixOne is a trademark of MatrixOne, Inc. Mentor Graphics and Board Station are registered trademarks and 3D Design, AMPLE, and Design Manager are trademarks of Mentor Graphics Corporation. MEDUSA and STEFNO are trademarks of CAD Schroer GmbH. Microsoft, Microsoft Project, Windows, the Windows logo, Windows NT, Windows XP, Visual Basic, and the Visual Basic logo are registered trademarks of Microsoft Corporation in the United States and/or other countries. Moldflow is a registered trademark of Moldflow Corporation. Netscape and the Netscape N and Ship's Wheel logos are registered trademarks of Netscape Communications Corporation in the United States and/or other countries. Oracle is a registered trademark of Oracle Corporation. OrbixWeb is a registered trademark of IONA Technologies PLC. PDGS is a registered trademark of Ford Motor Company. RAND is a trademark of RAND Worldwide. Rational Rose is a registered trademark of Rational Software Corporation. RetrievalWare is a registered trademark of Convera Corporation. RosettaNet is a trademark and Partner Interface Process and PIP are registered trademarks.
of RosettaNet, a nonprofit organization. SAP and R/3 are registered trademarks of SAP AG Germany. SolidWorks is a registered trademark of SolidWorks Corporation. All SPARC trademarks are used under license and are trademarks or registered trademarks of SPARC International, Inc. in the United States and in other countries. Products bearing SPARC trademarks are based upon an architecture developed by Sun Microsystems, Inc. Sun, Sun Microsystems, the Sun logo, Solaris, UltraSPARC, Java and all Java based marks, and "The Network is the Computer" are trademarks or registered trademarks of Sun Microsystems, Inc. in the United States and in other countries. 3Dconnexion is a registered trademark of Logitech International S.A. TIBCO is a registered trademark and TIBCO ActiveEnterprise, TIBCO Designer, TIBCO Enterprise Message Service, TIBCO Rendezvous, TIBCO TurboXML, and TIBCO BusinessWorks are the trademarks or registered trademarks of TIBCO Software Inc. in the United States and other countries. WebEx is a trademark of WebEx Communications, Inc.

Licensed Third-Party Technology Information
Certain PTC software products contain licensed third-party technology:
Rational Rose 2000E is copyrighted software of Rational Software Corporation.
RetrievalWare is copyrighted software of Convera Corporation.
VisTools library is copyrighted software of Visual Kinematics, Inc. (VKI) containing confidential trade secret information belonging to VKI.
HOOPS graphics system is a proprietary software product of, and is copyrighted by, Tech Soft America, Inc.
I-Run and ISOGEN are copyrighted software of Alias Ltd.
Xdriver is copyrighted software of 3Dconnexion, Inc, a Logitech International S.A. company.
G-POST is copyrighted software and a registered trademark of Intercim.
VERICUT is copyrighted software and a registered trademark of CGTech.
FLEXnet Publisher is copyrighted software of Macrovision Corporation.
Pro/PLASTIC ADVISOR is powered by Moldflow technology.
MainWin Dedicated Libraries are copyrighted software of Mainsoft Corporation.
DFORMD.DLL is copyrighted software from Compaq Computer Corporation and may not be distributed.
Visual Basic for Applications and Internet Explorer is copyrighted software of Microsoft Corporation.
Parasolid is © UGS Corp.
TECHNOMATIX is copyrighted software and contains proprietary information of Technomatix Technologies Ltd.
TIBCO ActiveEnterprise, TIBCO Designer, TIBCO Enterprise Message Service, TIBCO Rendezvous, TIBCO TurboXML, and TIBCO BusinessWorks are provided by TIBCO Software Inc.
Technology "Powered by Groove" is provided by Groove Networks, Inc.
Technology "Powered by WebEx" is provided by WebEx Communications, Inc.
Oracle 8i run-time, Oracle 9i run-time, and Oracle 10g run-time are Copyright © 2002-2004 Oracle Corporation. Oracle programs provided herein are subject to a restricted use license and can only be used in conjunction with the PTC software they are provided with.
Adobe Acrobat Reader and Adobe Distiller are copyrighted software of Adobe Systems Inc. and are subject to the Adobe End-User License Agreement as provided by Adobe with those products.
METIS, developed by George Karypis and Vipin Kumar at the University of Minnesota, can be researched at http://www.cs.umn.edu/~karypis/metis. METIS is © 1997 Regents of the University of
Minnesota.
Pop-up calendar components Copyright © 1998 Netscape Communications Corporation. All Rights Reserved.
Apache Server, Tomcat, Xalan, Xerces, and Jakarta are technologies developed by, and are copyrighted software of, the Apache Software Foundation (http://www.apache.org) – their use is subject to the terms and limitations at: http://www.apache.org.
UnZip (© 1990-2001 Info-ZIP, All Rights Reserved) is provided "AS IS" and WITHOUT WARRANTY OF ANY KIND. For the complete Info-ZIP license see http://www.info-zip.org/doc/LICENSE.
The Java™ Telnet Applet (StatusPeer.java, TelnetIO.java, TelnetWrapper.java, TimedOutException.java), Copyright © 1996, 97 Mattias L. Jugel, Marcus Meißner, is redistributed under the GNU General Public License. This license is from the original copyright holder and the Applet is provided WITHOUT WARRANTY OF ANY KIND. You may obtain a copy of the source code for the Applet at http://www.mud.de/se/jta (for a charge of no more than the cost of physically performing the source distribution), by sending e-mail to leo@mud.de or marcus@mud.de—you are allowed to choose either distribution method. Said source code is likewise provided under the GNU General Public License.
GTK+ - The GIMP Toolkit is licensed under the GNU Library General Public License (LGPL). You may obtain a copy of the source code at http://www.gtk.org, which is likewise provided under the GNU LGPL.
zlib software Copyright © 1995-2002 Jean-loup Gailly and Mark Adler.
OmniORB is distributed under the terms and conditions of the GNU General Public License and GNU Library General Public License.
Java Port copyright 1998 by Aaron M. Renn (arenn@urbanophile.com), is redistributed under the GNU LGPL. You may obtain a copy of the source code at http://www.urbanophile.com/arenn/hacking/download.html. The source code is likewise provided under the GNU LGPL.
CUP Parser Generator Copyright ©1996-1999 by Scott Hudson, Frank Flannery, C. Scott Ananian–used by permission. The authors and their employers disclaim all warranties with regard to this software, including all implied warranties of merchantability and fitness. In no event shall the authors or their employers be liable for any special, indirect or consequential damages, or any damages whatsoever resulting from loss of use, data or profits, whether in an action of contract, negligence or other tortious action arising out of or in connection with the use or performance of this software.
This product may include software developed by the OpenSSL Project for use in the OpenSSL Toolkit. (http://www.openssl.org): Copyright © 1998-2003 The OpenSSL Project. All rights reserved. This product may include cryptographic software written by Eric Young (eay@cryptsoft.com).
ImageMagick software is Copyright © 1999-2005 ImageMagick Studio LLC, a nonprofit organization dedicated to making software imaging solutions freely available. ImageMagick is freely available without charge and provided pursuant to the following license agreement:
Gecko and Mozilla components are subject to the Mozilla Public License Version 1.1 at http://www.mozilla.org/MPL. Software distributed under the Mozilla Public License (MPL) is distributed on an "AS IS" basis, WITHOUT WARRANTY OF ANY KIND, either expressed or implied. See the MPL for the specific language governing rights and limitations.
Mozilla Japanese localization components are subject to the Netscape Public License Version 1.1 (at http://www.mozilla.org/NPL). Software distributed under the Netscape Public License (NPL) is distributed on an "AS IS" basis, WITHOUT WARRANTY OF ANY KIND, either expressed or implied (see the NPL for the rights and limitations that are governing different languages). The Original Code is Mozilla Communicator client code, released March 31, 1998 and the Initial Developer of the Original Code is
Netscape Communications Corporation. Portions created by Netscape are Copyright © 1998 Netscape Communications Corporation. All Rights Reserved. Contributors: Kazu Yamamoto (kazu@mozilla.gr.jp), Ryoichi Furukawa (furu@mozilla.gr.jp), Tsukasa Maruyama (mal@mozilla.gr.jp), Teiji Matsuba (matsuba@dream.com).

iCal4j is Copyright © 2005, Ben Fortuna, All rights reserved. Redistribution and use of iCal4j in source and binary forms, with or without modification, are permitted provided that the following conditions are met: (i) Redistributions of source code must retain the above copyright notice, this list of conditions, and the following disclaimer; (ii) Redistributions in binary form must reproduce the above copyright notice, this list of conditions, and the following disclaimer in the documentation and/or other materials provided with the distribution; and (iii) Neither the name of Ben Fortuna nor the names of any other contributors may be used to endorse or promote products derived from this software without specific prior written permission. iCal4j SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Software may contain the Independent JPEG Group's JPEG software. This software is Copyright © 1991-1998, Thomas G. Lane. All Rights Reserved. This software is based in part on the work of the Independent JPEG Group.

Software may contain libpng, Copyright © 2004 Glenn Randers-Pehrson, which is distributed according to the disclaimer and license (as well as the list of Contributing Authors) at http://www.libpng.org/pub/png/src/libpng LICENSE.txt.

UNITED STATES GOVERNMENT RESTRICTED RIGHTS LEGEND
This document and the software described herein are Commercial Computer Documentation and Software, pursuant to FAR 12.212(a)-(b) (OCT’95) or DFARS 227.7202-1(a) and 227.7202-3(a) (JUN’95), and are provided to the US Government under a limited commercial license only. For procurements predating the above clauses, use, duplication, or disclosure by the Government is subject to the restrictions set forth in subparagraph (c)(1)(ii) of the Rights in Technical Data and Computer Software Clause at DFARS 252.227-7013 (OCT’88) or Commercial Computer Software-Restricted Rights at FAR 52.227-19(c)(1)-(2) (JUN’87), as applicable.

Parametric Technology Corporation, 140 Kendrick Street, Needham, MA 02494 USA
Contents

Introduction
  Intended Audience xiii
  Scope and Purpose xiv
  Maximizing the Learning Experience xiv
  Additional Documentation xiv
  Where Can You Go from Here? xv
  Comments xv

Chapter 1  Pro/ENGINEER Concepts
  Parametric Associativity and the Design Intent 1-1
  End-to-End Associativity 1-2
  Pro/E Basic Design Modes 1-2
    Part Mode: The Dashboard and Sketcher 1-3
    Assembly Mode 1-3
    Drawing Mode 1-4

Chapter 2  Learning the Pro/ENGINEER Interface
  Navigating Pro/ENGINEER 2-1
  Multiple Windows and Files "In Session" 2-2
  Managing Files 2-3
    The Working Directory 2-3
    Opening Files 2-3
    Creating Files 2-4
  Saving, Backing Up, and File Iterations 2-4
<table>
<thead>
<tr>
<th>Chapter 3</th>
<th>Part Design Basics</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Datums, Axes, and Coordinate Systems 3-1</td>
</tr>
<tr>
<td></td>
<td>Defining Parts in Sketcher 3-3</td>
</tr>
<tr>
<td></td>
<td>The Sketcher Principle 3-3</td>
</tr>
<tr>
<td></td>
<td>Sketcher Tools 3-4</td>
</tr>
<tr>
<td></td>
<td>Sketching Plane and Sketcher References 3-4</td>
</tr>
<tr>
<td></td>
<td>Adding or Editing Dimensions 3-4</td>
</tr>
<tr>
<td></td>
<td>Sketcher Geometric Constraints 3-5</td>
</tr>
<tr>
<td></td>
<td>Going from Section to 3D 3-6</td>
</tr>
<tr>
<td></td>
<td>Redefining Features 3-7</td>
</tr>
<tr>
<td></td>
<td>Making a Block: The Sketcher Setup Sequence 3-7</td>
</tr>
<tr>
<td></td>
<td>Creating a Section in Sketcher 3-8</td>
</tr>
<tr>
<td></td>
<td>Summary 3-9</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 4</th>
<th>Modeling the Cell Phone</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Part 1: Lens 4-2</td>
</tr>
<tr>
<td></td>
<td>Sketch the Lens Protrusion 4-3</td>
</tr>
<tr>
<td></td>
<td>Add Centerlines 4-4</td>
</tr>
<tr>
<td></td>
<td>Mirror Section Geometry 4-5</td>
</tr>
<tr>
<td></td>
<td>Modify Lens Dimensions 4-6</td>
</tr>
</tbody>
</table>
Save the Section 4-6
Exit Sketcher and Enter 3D Mode 4-7
Round the Lens Corners 4-8
Add Color to the Part 4-9
Save and Close the Part 4-9
Summary 4-9
Part 2: Earpiece 4-10
Create the Earpiece Protrusion 4-11
Create the First Hole 4-12
Create the Radial Pattern 4-13
Summary 4-14
Part 3: Microphone 4-15
Create the Rectangular Box 4-16
Create the First Cut 4-17
Create the Slots 4-19
Define the Horizontal and Vertical Centers 4-19
Sketch the Slot Section 4-21
Summary 4-22
Part 4: PC Board 4-23
Create the PC Board Protrusion 4-24
Create the Chamfers and Round 4-25
Add the Edge Chamfers 4-25
Add the Full Round 4-25
Place the Holes 4-26
Create the Second Hole 4-27
Copy and Mirror the Holes 4-27
Create a Datum Curve for the Keypad Reference 4-28
Summary 4-29
Part 5: Antenna 4-30
Sketch the Revolved Protrusion 4-31
Add a Round to the Top 4-33
Add the Revolved Cut 4-33
Make the Shaft Extrusion 4-35
Summary 4-35
Part 6: Keypad 4-36
Sketch the Keypad Protrusion 4-37
Chapter 5  Assembling the Cell Phone

Assembly Constraints 5-1
Place the Base Component 5-3
Assemble Components to the Base Component 5-4
   Lens Part 5-4
   Earpiece Part 5-6
   Microphone Part 5-7
   PC Board Part 5-10
   Keypad Part 5-12
      Assemble the Keypad 5-12
      Create a Datum Plane for the PC Board Part 5-13
      Add the Final Assembly Constraint 5-14
   Front Cover Part 5-15
      Move the Keypad to Confirm the Cutouts 5-15
   Back Cover Part 5-16
   Antenna Part 5-17
Create an Exploded View of the Assembly 5-18
   Modifying the Exploded Component Positions 5-18
Modify the Assembly 5-20
   Redefine Assembly Placement Constraints 5-20
   Suppress and Resume Parts 5-20
   Modify Part Dimension Values 5-21
Summary 5-21
# Chapter 6  Creating Drawings in Pro/ENGINEER

- Understanding Dimensions and Associativity 6-2
  - Detail Items 6-3
- Adding Models vs. Adding Views 6-3
  - Placing General Views and Projection Views 6-4
  - Creating Detailed Views 6-4
- Scaling Drawings and Views 6-5
- Using Formats and Templates 6-6
- Creating a New Drawing File 6-6
  - Modify the view 6-7
  - Add the Detailed View 6-8
  - Show Dimensions 6-9
  - Insert Added Dimensions 6-11
  - Clean Up the Dimensions 6-11
  - Edit Witness Lines and Arrows 6-12
- Finishing Sheet One 6-13
  - Create an Exploded Assembly View 6-13
  - Create a Bill of Materials 6-14
    - Create the Table 6-14
    - Enter Text Headings 6-15
    - Define a Repeat Region 6-16
    - Add BOM Parameters 6-16
  - Show BOM Balloons 6-17

# Chapter 7  Getting Productive

- Using Layers 7-1
  - The Layer Tree 7-1
  - Using Family Tables 7-2
- Managing the Pro/ENGINEER Environment 7-3
  - Configuration Options 7-3
    - Startup Search Sequence 7-4
    - Changing Configuration Options 7-4
    - Using the Options Dialog Box 7-5
    - Application Effective Icons 7-6
    - Editing Options and Values 7-6
Chapter 8
Getting Support

Pro/ENGINEER Help Center 8-1
Pro/ENGINEER Resource Center 8-2
PTC Technical Support 8-2
PTC Training Services 8-2
Pro/ENGINEER User Community 8-3

Glossary  Glossary-1

Index  Index-1
Getting Started with Pro/ENGINEER Wildfire is a tutorial-based introduction to creating parts, assemblies and drawings in Pro/ENGINEER. If you follow the complete series of procedures, you will learn how Pro/ENGINEER passes 3D design information to and from every design stage, from solid part creation, to part assembly, to the output of mechanical drawings.

These procedures also introduce basic techniques of using Pro/ENGINEER in each design phase. Familiarity with all phases of Pro/E design will help you to understand your particular role within a team effort.

Intended Audience

Individuals or teachers and students in a classroom setting can use this versatile guide. Its intended audience is broad and includes:

- New and experienced designers with little or no CAD/CAM software experience.
- Designers who have some experience in working with Pro/ENGINEER, but who would like to review the basics or learn more about how best to use the Pro/ENGINEER core functionality.
- Designers new to Pro/ENGINEER who have worked with other CAD/CAM applications. The philosophy and methods enabling you to capture your design ideas in Pro/ENGINEER follow a very different paradigm from other CAD/CAM applications.
- Managers who would like to become familiar with the tools used by their design team.
Scope and Purpose

This guide is not intended to be a complete summary of basic Pro/ENGINEER techniques. The goal of the exercises is to direct you through the end-to-end design process with as few detours as possible. Many intermediate and advanced solid part creation and assembly techniques are not mentioned. Even some basic techniques are bypassed in favor of presenting the whole workflow to a new user in a manageable way. Most of the emphasis is on solid part creation, especially the use of Sketcher mode as a design tool.

Maximizing the Learning Experience

Before you start creating the parts in chapter 4, review chapters 1, 2, and 3 to get a feel for what you’ll need to know about file management, the user interface, and the basic creation tools.

The procedures in chapter 4 take you through creating and assembling eight parts that represent the components of a cell phone. The parts start out simply and progress in complexity as you gain experience using the program. Once a technique is explained in detail, it may reappear in subsequent exercises in less detail. The more time you put into learning the techniques in one chapter, the less difficult the exercises will be in the subsequent chapters.

Completed part, assembly, and drawing files are provided with the guide. If your practice time is short, you can use these files to begin anywhere in the workflow. Using the precreated parts, you can go straight to work in the assembly or drawing modes, for example.

However, to maximize the learning experience, you should complete all three phases in sequence: part creation, assembly, and drawing. If time permits, especially for the earlier, simpler parts, you should complete the part, then see if you can recreate the part without the instructions.

Remember, these exercises hardly scratch the surface of Pro/ENGINEER capability. They are designed to give you a basic introduction to associative model creation and an overview of the end-to-end design workflow. After you complete the exercises, you will find it easier to learn more advanced aspects of Pro/ENGINEER.

Additional Documentation

As you learn to use Pro/ENGINEER, some additional documentation may be helpful:

- The Pro/ENGINEER Help Center, available from Help > Help Center on the Pro/E main menu, includes Help Topics and links to other tools to get you up to speed.
• The Pro/ENGINEER Wildfire 3.0 Resource Center, which opens automatically in the Pro/E browser, provides a quick reference card for the user interface in addition to overviews, tours, tutorials, tips and techniques and other resources.

• The PTC Customer Service Guide includes worldwide phone numbers for PTC contacts.

Where Can You Go from Here?

After you finish this guide, you are ready to begin basic modeling in Pro/ENGINEER. PTC also recommends that you take the Introduction to Pro/ENGINEER training class offered by PTC Training Services. Classes are offered at the PTC headquarters in Needham, Massachusetts, and at various other locations in the USA and elsewhere.

For information on available Pro/ENGINEER training classes and schedules, as well as computer- and Web-based training, go to the Education section of the PTC Web site at:

http://www.ptc.com/services/edserv/index.htm

Comments

PTC welcomes your suggestions and comments on its documentation. You can send comments to the following e-mail address:

doc-webhelp@ptc.com

Please include the name of the application and its release number with your comments. For online books, provide the book title.
Becoming a Pro/ENGINEER user means learning to think in terms of how the components of a design interact, and to think ahead to how those interactions may change. At the simplest level, these components may be the discrete geometric shapes, called features, that comprise a solid part: extrusions, holes, or chamfers, for example. At a higher level they may be the individual parts of your assembly, joined together in an interdependent way. At all levels, this component interaction toward a common purpose is called the design intent. This chapter describes how the principle of design intent is passed through all phases of the design, from conception to final documentation.

**Parametric Associativity and the Design Intent**

Suppose you want an extrusion centered on a rectangular surface. You could place the extrusion by measuring half the sides of the rectangle and using dimensions to locate its x-y position. However, your design intent is to have the extrusion centered, even if the length or width of the surface changes. Pro/ENGINEER gives you the tools to create models based on this kind of information.

In this instance, you could constrain the extrusion so it is centered between the four referenced edges. The x- and y-coordinates of the extrusion will always equal half of the length and width of the rectangular surface. Pro/ENGINEER calculates and updates the extrusion's position no matter what the dimensions of the rectangle are.

You can use these and other processes to define simple geometry, or you can use them with more complex calculations like mass, volume, or center of gravity. The establishment of parametric relationships between design entities can save an enormous amount of time and effort when engineering changes are required. The more associative information that you build into the model, the more you can quickly experiment with new solutions in the design as they occur to you. You can also adapt existing
designs to meet new requirements and create new products from them, rather than starting a design from scratch for a product that is essentially similar to an existing one.

Opportunities to create these relationships exist at every level of Pro/E, from the simplest part to the most advanced assembly. Often they are built into the workflow. The biggest challenge is to start thinking parametrically. You must constantly ask "How could this change, and what could change with it?", and then learn to create parametric relationships that can make adjustments automatically when the changes occur.

End-to-End Associativity

Pro/ENGINEER not only lets you design individual parts quickly, it also records their assembly relationships and produces finished mechanical drawings. You can easily access and edit dimensions and parametric associations at any stage of the workflow.

The dimensions that show on the plot are derived from the 3D model dimensions and remain dynamically linked to the source 3D files. The link is bidirectional: if you edit the 2D drawing, the 3D model dimensions change accordingly.

Pro/E Basic Design Modes

There are three basic Pro/ENGINEER design steps from conception to completion:

- Part creation
- Assembly creation
- Drawing creation

Each design step is treated as a separate Pro/ENGINEER mode, with its own characteristics, file extensions, and relations with the other modes. Remember that all information—dimensions, tolerances, and relational formulas—are passed from one mode to the next bidirectionally. This means that if you change your design at any mode level, the change is automatically reflected at all mode levels. If you plan ahead and use the associative features correctly, you can save significant time in the design and engineering process.
Part Mode: The Dashboard and Sketcher

In Part Mode, you create part files (.prt), the separate components that are joined together in an assembly file (.asm). Part mode lets you create and edit the features—the extrusions, cuts, blends, and rounds—that comprise each part being modeled.

Most features start with a two dimensional outline, or section. When the section is defined, you assign a third dimension value to it in order to make it a 3D shape. You create the 2D section in a tool called Sketcher. As the name implies, Sketcher lets you roughly draw the section with lines, angles, or arcs, and then input the precise dimensional values later.

You use an interface called the dashboard to create and edit 3D feature geometry. The dashboard presents feature-specific fields for input as you switch from feature to feature. Once a 3D feature is created, it can be edited directly in the graphics window.

Assembly Mode

After you have created the parts, you create an empty assembly file for the model, then assemble the individual parts within it, assigning the positions the parts will occupy in the final product. You can also define exploded views to better examine or display part relationships.
In a slightly more advanced scenario, you would start the model as an assembly and create each part (and part file) from what is called a “skeleton part”. This is the key to top-down design, where an edit to one part can automatically affect the parts to which it is joined. You can also associate one part to another part in an ordinary assembly using assembly relations—these will retain associativity between dimensions as they change.

In addition, with model analysis tools, you can measure an assembly’s mass properties and volume to determine its overall weight, center of gravity, and inertia. Determining interference between components throughout the entire assembly is also possible.

**Drawing Mode**

Drawing mode lets you create finished, precise mechanical drawings of the design, based directly on the dimensions recorded in the 3D part and assembly files. In fact, it is not necessary to add dimensions to objects as you may have done in other programs. Instead, in Pro/ENGINEER you selectively show and hide dimensions that have been passed from the 3D models.

Any information objects—dimensions, notes, surface notes, geometric tolerances, cross sections, and so on—that have been created for the 3D model can be passed to the drawing mode. When these objects are passed from the 3D model, they remain associated, and may be edited to affect the 3D model from within the drawing.
Dimensioned drawing views of the antenna tip
Learning the Pro/ENGINEER Interface

This chapter introduces the Pro/ENGINEER interface tools: the menus, the dashboards, the selection tools and the viewing controls. As you go through this chapter, experiment with a copy of one of the sample part files (.prt) shipped with Pro/ENGINEER.

Navigating Pro/ENGINEER

After you start Pro/ENGINEER, the main window opens on your desktop. The Navigator panel opens on the left. This sliding panel is home to several navigation tools and links to parts libraries, internet sites, or other workstations on your network. This guide will focus on using the Model Tree and Layer Tree pane.

The Model Tree is a list of every feature in a part file, including datums and coordinate systems. When you are in a part file, the Model Tree shows the part file name at the root and each feature in the part below it. For an assembly file, the Model Tree shows the assembly file at the root and the included part files below it.

You can select Tools > Customize Screen whenever a file is open to customize the menus by adding and removing sets of options, macros (called mapkeys), or individual commands. When you activate any changes to a menu, they apply to menus in all open windows.
Using the Model Tree in the Navigator

The items in the Model Tree are linked directly to the design database. As you select items in the tree, the features they represent are highlighted and selected in the graphics window. At first you’ll use the Model Tree as a selection aid. As you gain more experience, you’ll use the options shown in the previous illustration for tracking and editing, or to right-click features during an operation and access operations from the shortcut menu.

You can customize the Model Tree (click Tools > Customize) so it spans the space above the graphics area, or add columns (click Settings > Tree Columns) to display status and parameter information. You can then edit the columns directly.

Multiple Windows and Files "In Session"

Although you may have more than one window open, you can work in only one window at a time. The window in which you are working is called the active window. To switch between windows, select from the list of open windows under the Windows menu. If you switch windows by any other method, use Window > Activate to activate the window.

Pro/ENGINEER differentiates between a file being “open” in the sense of being visible in a window, and “in session” where the file is in memory but may or may not be visible in a window. Opening an assembly, for example, brings all of the associated part files into session, because even though they are not open, the assembly references them continuously in memory.
There are also two steps to closing files. Click **File > Close Window** to close the window of a file that is still being referenced in memory. To remove a file from memory, click **File > Erase**. This does not erase the file from disk, but it does close it completely.

You can use **File > Erase > Not Displayed** to list files in memory you want to close. However, if a file is being referenced, by an open drawing or assembly file, for example, you will not be permitted to erase it from memory until you erase the referencing file.

### Managing Files

This section covers the file management, default directory, and automatic backup functionalities. Understanding the file backup and iteration conventions will help you keep your database directories orderly and current.

### The Working Directory

The directory from which you start the program is set automatically as the default working directory. Files created automatically, and files you save without directing them elsewhere, are stored in the working directory by default.

**Note:**

Set the working directory (**File > Set Working Directory**) at the beginning of each session so that all files are stored where you want them.

### Opening Files

When you click **File > Open**, Pro/ENGINEER references the working directory. If you have other files open in session, but not displayed, you can click **In Session** from the **Look In** list to open them. You can add frequently accessed files or folders to a **Favorites** directory. Use the **Preview** button on the **File Open** dialog box to show a graphic representation of a selected file before you open it.
Creating Files

When you use **File > New** to start a new file, you are prompted to select a file type, and a subtype if one is necessary.

Options in the New dialog box

When you click **OK**, the new file opens and the default datum planes appear in the main window. The menus and options are configured for the selected type.

Saving, Backing Up, and File Iterations

Use **File > Save** to save changes. Use **Save a Copy** to save the file to a different name. Whenever you use the **Save** command, a new version of the file is created and a numerical file extension is appended to note the version, for example *front_cover prt.1, front_cover prt.2*, and so on. These iterations are created so you will always have a previous
version to return to in case something fails in the current file. When you use **File > Open** to open a file, the file browser displays the latest versions without the iteration numbers.

To show version numbers in the **Open** dialog box, click the **Commands and Settings** icon and then click **All Versions** from the menu. You can then open whichever iteration you want.

To save a file to a different name, format, or location use **File > Save a Copy**. Unlike a conventional Windows **Save As** command, **Save a Copy** leaves the original file open and active after the save operation.

If you don't want to store the iterations in your working directory you can use **File > Backup** to specify an alternate directory for the iterations. The first iteration in a backup directory starts at 1, regardless of the number of iterations in the working directory.

**Deleting Files**

Use **File > Delete** to remove files from the disk permanently. You can clear old versions only, leaving the latest version intact, or you can clear all versions.

Use **File > Delete > Old Versions** to clear the directory of all but the most recent version.

**Model Manipulation**

As you work, you'll constantly manipulate your model using spin, pan, and zoom from the buttons on your mouse. With practice, this will become automatic. You will also learn which visual elements you need to show or hide and which display mode, orientation or magnification, you will need to best accomplish any task. Experienced users change view settings from operation to operation and from minute to minute.

**Spin, Pan, and Zoom**

The middle mouse button is the key to model manipulation as you move the mouse:

- **Spin**—Press and hold the middle mouse button
- **Pan**—Press and hold the middle mouse button + SHIFT
- **Zoom**—Press and hold the middle mouse button + CTRL + vertical drag, or spin the mouse wheel

Another useful shortcut is CTRL+d. This returns the part to a default orientation in the center of the graphics window.
Viewing control icons

1. Redraw current view  5. Zoom Out
2. Spin center        6. Recenter
3. Orient mode       7. Orientation dialog box
4. Zoom In area      8. Saved View list

Spin Modes

When you spin the part, you can use the default part axis to spin the view, or use a spin center that you place by clicking anywhere on the part. When the default spin center is displayed, the model spins around it when you drag the middle mouse button. If you turn the default spin center off, you can use the same drag motion to put the spin center anywhere you put your pointer. You can see the two spin modes at work in the illustration below. On the left, the spin center icon has been selected. The spin center is displayed and is used to pivot the model. On the right, the spin center icon has not been selected, and the spin center is located at the point where the user clicked the top edge of the model.

Changing the spin center

Zoom Mode

Use the **Zoom** icon on the main toolbar to drag a rectangle around an area you want to magnify. Middle-click to cancel **Zoom** mode.
Using Orient Mode

Additional specialized controls are available in Orient mode. To enter, click View > Orientation > Orient Mode. The pointer changes to a black movement spin center and a triangular or square vector handle is constantly visible. Right-click and choose one of the following controls from the Orient mode shortcut menu:

- **Dynamic**—The usual spin, pan, and zoom controls.
- **Anchored**—Movement is anchored around a specific point. Click once to determine the anchor point, then move the mouse as usual.
- **Delayed**—The view changes after the vector handle is moved and released. This avoids constant repaint for large assemblies.
- **Velocity**—Movement continues as long as the mouse button is pressed, even though the mouse drag has stopped.

Right-click and choose Exit Orient Mode to exit Orient mode completely.

Saved Views

A view is a combination of zoom factor and 3D orientation. Every model has certain standard views stored within it by default: Front, Left, Top, or Bottom, for example. The view called Default fits the model in the window in a 3D orientation.

**Note:**
If you use a certain view frequently, you can use View > View Manager > New to name and save it, and then access it any time during the session. Use the Saved View icon to quickly change to a saved view.

Dashboards

With the dashboard, you can use a logical sequence of setups and parameters to define new geometry features or redefine existing shapes. Task-specific dashboards appear at the bottom of the graphics window whenever you create or edit a feature in a part.

The dashboard guides you through creating geometry intuitively from left to right. The lower half of the dashboard groups the required inputs in the proper sequence. The upper half lets you fine-tune the variable properties. The next illustration shows the Hole dashboard active and defining a coaxial hole.
Solid Display Options

As your model becomes larger and more complex, you will switch from solid to wireframe display to help in selection and to improve computer performance. The two main display modes are shaded (solid) and lined. There are three types of lined display. Each shows the outlines of the model in increased detail.

<table>
<thead>
<tr>
<th>Shaded—Shows the model as a solid.</th>
<th>Hidden line—Shows hidden lines in ghosted tones.</th>
</tr>
</thead>
<tbody>
<tr>
<td>No hidden line—Does not show lines behind forward surfaces.</td>
<td>Wireframe—Shows front and back lines equally.</td>
</tr>
</tbody>
</table>

Wireframe and shaded displays
Datum Display

You can globally display or hide datum planes, datum points, axes points, and coordinate systems as needed at any time during an operation. You can hide an individual datum by selecting it in the Model Tree and using the Hide command on the right mouse button shortcut menu. Datums clutter the work area and can cost in redraw performance, so it is good practice to hide most datum objects until you need to see them for action or reference.

Selection Filters

MCAD designs can get complex quickly, and it can be difficult to accurately select an object. Pro/ENGINEER gives you an object filter to limit the object types that you can select in crowded areas. The filter works together with preselection highlighting. As you pass the pointer over the design, objects under the pointer highlight as eligible for selection. To simplify selection further, the filter automatically sets to eligible objects when you are prompted to select during an operation.

When you are prompted to select a specific entity type, the filter offers selections valid only for that type.

When the filter is on the default smart setting, all objects are eligible in a hierarchy. For example, you can select a feature and click again to "drill down" to its component edges or surfaces, as shown in the next illustration. Preselection highlighting is optional. Use Edit > Select > Preferences to turn it off.

Preselection Highlighting
Selection Lists

An alternate way to isolate an item for selection is to pick it from a list. The list is generated from all items that are under the pointer at a given time. To show the list, place the pointer over the area containing the item you want to select, and choose Pick From List from the right mouse button shortcut menu. The Pick From List dialog box opens. To select the item, highlight it in the list and click OK.

Ordering and Suppressing Features

Two of the most useful functions of the Model Tree are the ability to control the order of features and to suppress or resume them in the model. The order of features is the sequence in which features appear in the Model Tree. When you add a feature it is appended to the bottom of the Model Tree. At the simplest level, ordering is an organizational tool. You can drag the feature up the tree to place it with a parent or other related features, even if the feature was created after the parent. You cannot order a child feature before a parent feature. At another level, reordering existing features can change the appearance of the model.

Suppressing a feature temporarily removes it from the model, both physically and visibly. For display simplification only, you can use the Hide command on selected features from the Model Tree. However, you might want to temporarily suppress a feature, for example, in order to try another one in its place. Or, the feature could be causing problems that you must adjust for elsewhere.

Note

If suppressed features do not appear on the Model Tree, click the Model Tree Settings tab, and then click Tree Filters. Now select Suppressed Features under Display. When they are shown, you can select them, right-click, and choose Resume from the shortcut menu to return them to the model.
In the previous chapter you reviewed the Pro/ENGINEER user interface and selection methods. This chapter introduces the elementary tools and principles of solid geometry creation in Pro/ENGINEER. After a brief discussion of 3D datum planes and axes used to locate solid features, you’ll learn how to start solids as 2D outlines, or sections, in Sketcher. You’ll then see how to add the z-dimension to create 3D objects.

It will be helpful to have a new blank part file started in Pro/ENGINEER that you can experiment with as you go through this chapter. At the end of this chapter, you’ll find a step-by-step sequence describing how to create a 3D block. Be sure to read this chapter carefully before you start the exercises.

Datums, Axes, and Coordinate Systems

When you start a new part, three datum planes and a coordinate system are added for you. The datum planes are automatically named Front, Top, and Right. The coordinate system indicates the x-, y-, and z-axes. The positive z-axis is perpendicular to the front datum plane. If you orient the datums so the Front plane is flat to the screen, the z-axis is perpendicular to the screen.

Datums are points of reference in space that Pro/E uses to calculate distances. Datums can be actual points, planes, or curves, but they have no value for thickness. You will create and place them frequently for a variety of uses in both Part and Assembly modes.

Like solid features, datums are added to the Model Tree as you create them. They are named numerically by default, for example DTM1, DTM2 (for datum planes) or PNT1, PNT2, (for datum points). You can rename them to better describe their purpose after they are added.
Datum points and coordinate systems are similar in that they are both points either fixed or offset from a surface or vertex. You can use datum points separately or combine them into a patterned array that behaves as one feature. These arrays can be saved as ASCII files and reused in other designs.

Coordinate systems are points that define an x-, y-, and z-direction. Each part that you create is based on a coordinate system, and you may use coordinate systems within parts or assemblies to define the direction of other components. Coordinate systems are used, for example, in cabling connector parts to define the direction that an autorouted wire or cable will exit the connector.

You can add datums at any time from the main menu, using Insert > Model Datum, or you can click the datum creation toolbar buttons on the right side of the graphics window.

To redefine datums, you can select them from the Model Tree, then right-click and choose Edit Definition from the right mouse button shortcut menu. You can also add datums “on the fly” or in the middle of other processes. Datums that you add to create specific features remain with the feature’s section, and are not displayed in the 3D model.
Defining Parts in Sketcher

The Sketcher is best described as a submode of Part mode, a 2D drafting board within the 3D environment. You will use it to create most of the geometric shapes you use in a part. The associative details, such as geometric constraints or relations between dimensions, that you build into a sketch, or section, act as a foundation for all other additions and edits to follow. The more you can foresee areas of potential change to the design, the more associative detail you can build in to handle the effects of the changes. If you don’t build in the required intelligence to handle future edits, you will have to spend time fixing problems as they arise. Learning to use the Sketcher correctly and effectively is crucial to learning to use Pro/ENGINEER.

The Sketcher Principle

In Pro/ENGINEER, 3D objects begin as 2D outlines. After the 2D outline is defined with x and y dimensions, it is given a z dimension, or depth, to make it three-dimensional. You literally "sketch" an imprecise or exaggerated 2D profile of the part you want to create. Sketcher adds weak dimensions, complete with arrows and witness lines, as you draw. When the sketch is finished, you enter the precise lengths, angles, and radii (strong dimensions) as needed. The section is then regenerated to the real values. Geometry may be constrained to grow or shrink with the size of related lines. There is no need to count grid lines or use on-screen rulers, as you would with a simpler drafting program.

2D section in the Sketcher tool, and the resulting solid

You may need to add other dimensions. Use a combination of geometric constraints (described later) and dimensions to define a section with as few rules as possible. As you apply dimensions or constraints, the new ones may conflict with existing ones, or a constraint may already exist. When this happens, the conflicting dimensions or constraints are listed in
a dialog box. You can delete the ones you don’t need or want to replace, ensuring that your sketch is not overdimensioned and that constraints do not conflict.

**Sketcher Tools**

The basis of Sketcher geometry tools are the line, circle, and arc creation functions common to most drawing programs. These are arranged on a toolbar to the side of the graphics window. Fly-out menus from the side of an icon mean there are more varieties of the same function to be used. If you move the pointer over an icon, a Tooltip explains its function.

**Sketching Plane and Sketcher References**

One of the first things you identify in setting up a sketch is the sketching plane. This is the surface on which you will draw. A sketching plane may be an existing part surface, or it may be a datum plane. The selected plane or surface is rotated flat to the screen in Sketcher. You can use the usual rotation commands to rotate the sketch in 3D space for inspection, but usually sections are laid out flat, as though on a 2D drafting table.

When the sketching plane is established, Sketcher needs existing planes and edges from which to dimension the new section. By default, Sketcher automatically selects two reference planes or edges, a horizontal and a vertical, to start a sketch. As you add to the sketch, you may need to add more references.

In Sketcher, use the **Sketch > References** dialog box to add existing edges as references. Added edges are marked by a colored, dotted line.

**Adding or Editing Dimensions**

When your sketched outline is finished, it will be dimensioned with default weak dimensions. As pointed out before, these are the dimensions that Sketcher adds automatically when you draw. They are displayed as gray lines. Because you are just sketching, they will not be the exact placements or values that you need. To enter strong values for a single dimension in Sketcher, click the weak dimension value itself and type directly into the text box. The dimension is then converted to a strong dimension, shown in normal line width, and the line or angle is adjusted to the new value.

If Sketcher hasn’t automatically given you a dimension or angle you want, you can use the **Add Dimension** icon on the Sketcher toolbar to add one, and then enter a value for it.
Most users sketch the outline of the section, and then modify all the dimensions at one time. Click **Edit > Select All** in Sketcher, then click the **Modify Dimensions** icon to use the dialog box to cycle through all the dimensions sequentially.

### Sketcher Geometric Constraints

Constraints work with dimensions to define a section. A constraint states that one line has a definite geometric relationship to another. For example, if you wanted a line in your new section to be parallel to and equal in length to an existing line, you could add those two constraints to the line in the section, rather than entering new dimensions.

Constraints are represented on the screen by small symbols on the constrained line. In the next figure, the radius of the right circle is constrained to be the same as the radius of the left circle. The two center points are constrained to be equidistant from a centerline. Thus, you only need to dimension the original, left circle. The right one will mirror it automatically.
Constraint symbols in Sketcher

Use the Constraint palette to apply geometric constraints in the Sketcher tool.

“R” constraint symbols indicate radii of two circles are equal.

“>” constraint symbols indicate center points are equidistant from centerline.

Going from Section to 3D

When a section gains depth, or a z-dimension, it becomes a 3D geometric entity called an extrusion. The extrusion may add or remove material. In other words it may be a solid, or it may be a cut. For an example of a solid, imagine a 2D circle extruding outward to create a cylinder.

An extrusion created as a cut removes material from any solid it passes through. For example, a bolt hole through a plate may be a circular section placed on the surface of the plate as a cut, and extruded through the plate. An extrusion must be defined as a solid or cut when created (otherwise it stays a 2D sketch), although the sketch may be used for both a solid or a cut. Depth can be added directly to a section, or the section can be revolved, where the depth of the cut or solid is added in degrees around an axis, as shown in the next figure.

Left: Extruded protrusion. Right: Revolved protrusion
Redefining Features

You will frequently redefine features as your model design evolves. Just select the feature in the graphics window or in the Model Tree, then right-click and choose Edit Definition from the shortcut menu.

Features created in Sketcher mode do not necessarily need to be redefined in Sketcher mode. You can select a feature and use commands in 3D mode to change the value of any dimension defined in Sketcher mode. This is called “direct modeling” and is the recommended way to edit models as they progress.

Making a Block: The Sketcher Setup Sequence

In this exercise you will walk through creating a simple solid in Sketcher step by step. Have Pro/ENGINEER running with a new empty part file open and the datums displayed.

1. Click the Sketch tool button on the Feature toolbar. The Sketch dialog box opens. The Plane collector box is highlighted in yellow. The highlight means it is active, waiting for a sketching plane.

2. Click the Front datum plane in the graphics window. The datum plane name appears in the Plane collector area and the highlight moves to the Reference collector. The Right datum plane appears as the default reference.

3. Click Sketch to accept the default sketch placement. The Front datum plane rotates flat to the screen, and the Sketcher drawing tools appear on the right-side toolbar.
Creating a Section in Sketcher

Now sketch a rectangle. Notice how Pro/ENGINEER automatically adds dimensions and constraints.

1. Click the Rectangle tool in the Sketcher toolbar, and drag a rectangle to fit into the upper-right quadrant. It doesn't matter now what the zoom factor is or how long the sides are. As you drag the rectangle, you'll see the $H$ and $V$ (horizontal and vertical) constraints are active by default for a rectangle.

As you stretch the rectangle, watch for small $L$ symbols to appear near the sides. These are length constraint symbols, showing that the lengths of the marked sides are equal. When these are visible, click to complete the rectangle, then middle-click to exit the tool.

**Note**
The numeral next to the $L$ symbol shows which referenced sides are of equal length. If two or more lengths were equal within the section, they would be marked $L2$.

**Rectangle section position and dimensions**

Now you should have a square with one side showing a dimension with witness lines, as shown in the previous figure. Double-click the dimension itself to edit it, enter 10 in the text box, and press Enter. The section rescales itself. All the constraints and dimensions required for a square of 10 units are present. You can now complete the section.

2. Click the Check icon at the bottom of the Sketcher toolbar to finish the section and return to 3D mode.
3. Click **Insert > Extrude** so you can use your sketch as the basis of the solid part. The rectangle appears in 3D with a yellow arrow pointing up to indicate the extrude direction. Use the middle mouse button to rotate the view and inspect the direction.

*Adding depth to the extruded section*

4. Double-click the depth handle text box and enter 5, then press Enter, or enter the value directly in the dashboard text box and press Enter. (You can also drag the depth handle directly on the model to the desired value.) The shape is regenerated to the new dimension.

5. Click the Check icon on the dashboard to complete the feature and return to the work area. The solid is complete.

**Note**

*Undo* and *Redo* commands are available for many (but not all) actions in Pro/ENGINEER. When you work with a feature tool, actions can be undone and redone using **Edit > Undo (Redo)**, or **CTRL+Z (CTRL+Y)**. After a feature is created and saved, and the tool is closed, it can be undone as a single item.

The configuration option `general_undo_stack_limit` controls the number of times you can undo or redo actions. The default and maximum setting is 50.

**Summary**

At this point you have reviewed many of the major tools and operations that characterize Pro/ENGINEER. For more complete information, access the Pro/ENGINEER Wildfire 3.0 Resource Center, available through the Pro/ENGINEER Help Center.
In previous chapters you’ve become familiar with the interface controls and some of the basic concepts needed to get started in Pro/ENGINEER. In this chapter you’ll start the hands-on process of building the eight parts that make up the cell phone model. Before you start the exercises, you should be familiar with the selection tools, the zoom and pan controls, and the basics of using Sketcher. All of these items are covered in the previous chapters.

The instructions for each part begin with a table that lists the techniques used for that part. The first time a technique is introduced, you are given detailed instructions. If the technique is used again in another part, you are only given any additional instructions you’ll need to use it in that instance. If you need to review how to use a technique, use the table to find the previous section that covers it in detail.

When you have created all the parts, you will proceed to add them to an assembly and output some detailed mechanical drawings.
Part 1: Lens

In this procedure, you will create a simple solid extrusion that represents the lens of the cell phone. It is centered on horizontal and vertical axes formed by the intersection of two of the datum planes. You’ll learn how to quickly mirror drafted lines in Sketcher, so that mirrored halves are constructed and constrained to always be proportional. You’ll also learn how to add round features to edges. Finally, you’ll learn how to save a sketcher for reuse in another part.

<table>
<thead>
<tr>
<th>Technique or Feature</th>
<th>Where Introduced</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert Extrusion</td>
<td>New</td>
</tr>
<tr>
<td>Enter Dashboard and Sketcher</td>
<td>New</td>
</tr>
<tr>
<td>Mirror Feature</td>
<td>New</td>
</tr>
<tr>
<td>Sketcher Section Creation</td>
<td>New</td>
</tr>
<tr>
<td>Rounded Features</td>
<td>New</td>
</tr>
</tbody>
</table>
Sketch the Lens Protrusion

To begin, click File > New. The **New** dialog box opens. Click **Part** in the Type area of the dialog box and enter the word **lens** as the part name. Remember to create a working directory if you haven't already done so.

1. Click the Sketch tool on the Feature toolbar. The **Sketch** dialog box opens.

2. Click the Front datum plane in the graphics window or in the Model Tree to select it as the sketching plane. An arrow indicates the view direction. Leave the orientation and view direction set at the default. The Right datum is automatically referenced in the dialog box.

3. Click **Sketch** in the Sketch dialog box to start Sketcher. The background changes color, and perpendicular lines bisect the sketching plane in the x-and y-direction. The Sketcher toolbar appears to the right of the graphics window. Use these Sketcher tools to sketch the lens and other parts.

   **Note**

   At any point, use the datum display icons on the main toolbar to turn off datum display and clear up the work area. You should see only the horizontal and vertical reference lines.

4. Click the Sketch Orientation icon on the main toolbar to orient the sketching plane flat to the screen. The sketching window should now look like the figure below:

   **Sketching plane oriented flat to screen**
Add Centerlines

Before you draw, you’ll add centerlines to the vertical and horizontal axes formed by the Top and Right datum planes. You can use these centerlines to mirror shapes and dimensions and to quickly center geometry by snapping lines to them.

1. On the Sketcher toolbar, click the Centerline tool \[ \] from the Line flyout menu. \[ \]|\[ \]

2. Let the cursor snap to one of the axis lines and click the left mouse button. A yellow centerline appears, attached to the cursor. Move the cursor to rotate the centerline to coincide with the axis line, and click to place it. Place a centerline on both the vertical and horizontal datum plane references. Middle-click to exit the tool.

Sketching plane with centerlines added

3. Click the Arc tool \[ \] to sketch the lower curve. Click in the lower left quadrant, below the horizontal centerline, to begin, and move the cursor to the right. (You don’t need precise dimensions. You can enter exact dimensions when the outline is finished.)

   Remember, you can use Edit > Undo (Ctrl+Z) multiple times to undo any mistakes.

4. As you move the pointer to the right, you will see facing constraint symbols at the start point and at the cursor, indicating that they are horizontal. (You don’t see the arc itself yet.) When the vertical centerline approximately bisects the distance between the start point and the cursor, click the endpoint of the arc. The active arc appears, attached to the cursor. The center point of the arc snaps along the vertical axis, moving vertically as the arc is bent.
Click to place the arc at an approximate radius (you’ll enter the real values later). Middle-click to exit the Arc tool. You’ll see the arc entered, with the “weak” dimensions in gray. They will become “strong” dimensions when you enter the true values for them.

*Lower half of the lens section with weak dimensions*

5. Now click the Solid Line tool in the line flyout. Sketch two vertical lines, one from each arc endpoint to the horizontal centerline. Middle-click to stop sketching the first line, then click the left mouse button again to start sketching the next line. Notice the “V” constraint symbols, showing you the line is vertical. Middle-click to exit the Line tool. This is the lower half of the lens.

**Mirror Section Geometry**

Now you’ll use the Mirror function to create the identical upper section of the lens.

1. Click the Selection icon.
2. Drag a selection rectangle around the lower section. All of its lines should be highlighted as selected.
3. Click **Edit > Mirror** from the main toolbar.
4. Click the horizontal centerline to place the mirror image of the bottom lens section. The complete lens section is now centered on the horizontal and vertical axes. The mirrored lines are associative—if you resize one, its mirror will resize accordingly.
Modify Lens Dimensions

Now you will enter the true dimensions for the lens.

1. Click the Selection icon and drag a rectangle around the entire section to select it, including all the dimensions. (You could also use Edit > Select > All.)

2. Click the Modify Dimensions tool . The Modify Dimensions dialog box opens, showing value fields for all three dimensions.

3. First, clear the Regenerate check box. If you leave the check box checked, each dimension will regenerate as you edit it. In this case, it is faster to change all the dimensions in the section, and then regenerate it.

4. Click one of the dimension values in the dialog box, and notice that its corresponding dimension is highlighted in the section. Enter the real dimensions for the lens section: 1.69 for the arc radius, 0.84 for the height, and 1.32 for the width. Remember to press Enter after entering each value.

   Now, select the Regenerate check box and click . The section regenerates and the view is zoomed to the new scale.

   ![Finished lens section with final dimensions](image)

Save the Section

Now you’ll save the lens section to a file. This is not usually necessary; the section for each feature is stored in the part. You are saving this section for future use. When you create the lens opening cut in the front cover (the final part in the series), you’ll import this section to establish the outline for the cut, rather than drawing and dimensioning another section.

1. Click File > Save a Copy.
2. Enter the name lens in the **New name** text box in the **Save** dialog box.

3. Click **OK**. (The extension .sec is appended automatically.)

**Exit Sketcher and Enter 3D Mode**

You are finished defining the section. Now you’ll turn the sketch into a solid feature.

1. Click the Check icon ✓ in the **Sketcher** toolbar to accept the sketch. Click **Insert > Extrude**. The Extrude dashboard opens. Click the lens sketch in the graphics window to activate it. A small drag handle appears on the part axis and the depth dimension is shown. Hold down the middle mouse button to rotate the model slightly to see the handle more clearly.

2. Drag the handle and enter a depth of 0.05 into the dimension box directly, or enter the value in the dashboard.

*Completed section, with depth handle*

3. Click the Check icon in the dashboard to accept the feature. When the feature is accepted, you can see it added to the Model Tree.

*The finished lens protrusion*
Round the Lens Corners

Now you will add a round to each of the outer edges. If you select and round one corner at a time, each round is added to the Model Tree as a separate feature. However, if you hold down the Ctrl key, select all four edges, and then add the round, the rounds are added as one feature, and all share the same degree value. This is the preferable method if you want all the corner rounds to be the same radius. You can then update them all in one edit, rather than selecting and editing each one in sequence.

1. Select the first edge, then rotate the lens to select the second one. Hold down the Ctrl key when selecting the second and additional edges, releasing the Ctrl only to rotate and zoom in on the lens.

2. When all four corner edges are selected, click the Round tool from the Feature Creation toolbar. The Round dashboard opens.

3. Drag the handle to resize it or click the dimension to enter 0.08, the correct value for the round. Middle-click or click the Check icon in the dashboard to complete the feature. Once again, the feature is added in the Model Tree.

**Note**

Always save your model after adding each new feature.
Add Color to the Part

When you add color, each part is more easily recognizable as a distinct object, especially in larger assemblies. If no color palette file is available, you can create and save one. Always assign colors that will make it easy to differentiate between parts of the assembly.

Click View > Color and Appearance to assign a color to the part from the color palette.

Save and Close the Part

Save the part, then click File > Close Window. Now click File > Erase > Not Displayed to close lens.prt and erase it from active memory.

Summary

Now you’ve created and saved a simple part file, and you’ve learned some of the basic Sketcher techniques. You might try to do all of these operations again from memory in a test file, just to practice the sequence of events.

In the next part you’ll learn how to place a hole feature and create a circular pattern of holes based on the original hole. You’ll repeat some of the same techniques. If you get stuck, refer to the table before each part for the location of the detailed instructions.
To create this part, you’ll use some of the same extrusion techniques you used in the lens part. The only difference in this part is that the extrusion is round. You’ll learn how to insert a hole into a solid, then learn how to use the hole to create a pattern of identical features from it.

There are several types of patterns and they are extremely useful for repetitive features. This particular pattern, the radial pattern, is commonly used for bolt hole circles. All the patterned features are associated with a “parent” feature, also called the pattern leader. When the parent is edited, all the “children” or associated features, update accordingly.

<table>
<thead>
<tr>
<th>Technique or Feature</th>
<th>Where Introduced</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert Protrusion</td>
<td>Part 1: Lens</td>
</tr>
<tr>
<td>Chamfers</td>
<td>New</td>
</tr>
<tr>
<td>Holes</td>
<td>New</td>
</tr>
<tr>
<td>Hole Patterns</td>
<td>New</td>
</tr>
</tbody>
</table>
Create the Earpiece Protrusion

To begin, create a new part called `earpiece` using the Extrude tool. Use the following guidelines and techniques from the previous section to create the chamfered protrusion to the following specifications. Then follow the instructions to add a hole and repeat it in a radial pattern.

3D circle with strong dimensions

Guidelines:

- Use the Front datum as the sketching plane, as you did for the lens.
- Use the Circle tool in the Sketcher toolbar to draw a circle and let the cursor snap to the intersection of the horizontal and vertical reference lines.
- In Sketcher, enter a diameter dimension of 0.31. In the Extrude dashboard, enter a thickness of 0.06.
- The chamfer dimension is 0.01. (The chamfer is a separate feature from the round extrusion, created with the Chamfer tool. Don’t try to create it from within the Extrude dashboard.)
Create the First Hole

Use the Hole tool to specify the dimensions and the location of the pattern leader hole.

There are various ways to position a hole on a solid. In this example, you’ll use a radial hole, which is defined by 1) a surface to lie on, 2) an axis to be offset from, and 3) a plane to use as a zero degree reference for rotating about the axis from which it is offset. You’ll use the extrusion surface, the extrusion center axis and the Top datum plane as these references.

1. Click Insert > Hole. The Hole dashboard opens.

2. Click the front surface of the earpiece. The hole is placed in preview outline. Several handles extrude from the outline. Two of them define the ends of the axis line. One defines the diameter. The remaining two are the reference handles.

3. In the dashboard, you can enter the diameter, 0.03, and the depth, 0.05.

4. Click the Placement panel on the dashboard, and set the hole type to Radial. Leave the panel open.

5. To place the first radial reference, drag one of the reference handles to the extrusion’s axis. (Be sure axes are displayed.) The handle should snap to the axis and show as a white square with a black dot if it is referencing the axis properly. The axis will also appear in the Placement panel as a secondary reference.
6. To place the second reference, drag the second reference handle to the Top datum plane. The datum should highlight, and the handle should snap to it and show as a dot in the square. The datum plane should appear in the Placement panel as a secondary reference.

7. With the two handles placed, enter 0.1 for the axial distance value in the Placement panel. This places the hole 0.1 from the axis. Enter 0 for the datum plane’s angular value. This centers the hole on the datum plane.

8. Click to close the Placement panel, then click the Check icon in the dashboard to accept the feature.

The radial hole referenced

Create the Radial Pattern

Now you’ll create a radial pattern based on the first hole. It is easier to understand patterning if you think of it as repeating dimensions rather than repeating features, although it is the feature that is repeated. In the setup process for patterning you are asked to identify dimensions that indicate the direction in which you want to repeat the pattern and to specify how many instances, including the original, that you want.

1. Select the hole in the Model Tree. From the right mouse button shortcut menu, click Pattern. The Pattern dashboard opens. The dimensions for the hole feature are activated.
2. You need a total of six items around the hole’s radial dimension, which is now set to 0. You express the pattern as follows: “Increase the selected dimension by 60 degrees. Do it 6 times.”

On your model, double-click the 0 dimension, and enter 60. Press Enter. If you open the Dimensions panel, you will see the dimension in the Direction 1 list, with 60 as the increment value. Close the Dimension panel.

3. Now specify how many times to perform this increment. In the text box for the first direction in the dashboard, enter 6 and press Enter.

4. Click the Check icon on the dashboard to accept the feature. The pattern is added to the Model Tree in place of the original hole, which is now part of the pattern.

5. Save and close earpiece.prt.

**Finished pattern**

The pattern is parametric and associative, in that if you change the diameter, or any other dimension of the leader feature, the patterned features will update to the new value. If you add a feature to the leader feature, for example a round on the edge of the hole, you can pass the new feature on to the patterned holes.

**Summary**

You’ve now created the second part and have learned how to repeat selected dimensions to create a pattern as a feature. In the next exercise you’ll learn some more advanced methods for applying parametric constraints in Sketcher and how to use an extrusion to specify an area of material to remove.
The microphone is a rectangular box with a cut and two slots extruded into it. The two slots are parametrically associated to share dimensions and position from the center. In this part, you'll learn how to use an extrusion to remove material from a solid. You'll also learn how to use geometric constraints in Sketcher not only to measure geometry accurately, but to build in associativity between features in the process.

<table>
<thead>
<tr>
<th>Technique or Feature</th>
<th>Where Introduced</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert Extrusion</td>
<td>Part 1: Lens</td>
</tr>
<tr>
<td>Remove Material</td>
<td>New</td>
</tr>
<tr>
<td>Select by Loop</td>
<td>New</td>
</tr>
<tr>
<td>Place a Construction Line</td>
<td>New</td>
</tr>
<tr>
<td>Use Sketcher Point Constraint</td>
<td>New</td>
</tr>
</tbody>
</table>
Create the Rectangular Box

To begin, create a new part and name it microphone. This time, we’ll use an internal sketch for the extrusion. Click Insert > Extrude, and then open the dashboard Placement panel and click Define to start Sketcher.

Using the Front datum plane as the sketching plane, create a rectangular section in the upper-right quadrant of the work area as defined by the intersecting datum panes. Dimension the section and enter the depth as shown in the next figure.

*Sketcher drawing with strong dimensions*

![Sketcher drawing with strong dimensions](image-url)
Create the First Cut

A quick way to specify an area from which to remove material is to use the outer edge of the first section to define an offset for a new section inside it.

1. Click **Insert > Extrude** from the main menu. Select the top surface of the first extrusion as the sketching plane.

2. Click the **Offset Entity from an Edge** tool on the Sketcher toolbar. The **Type** dialog box opens, showing different types of offset references.

3. Click **Loop** in the **Type** dialog box. Be sure not to close the dialog box.

4. Select one of the edges of the section to loop all the edges as the reference entity. A directional arrow points outward from the selected edge. You are prompted for the offset value.

5. Because you want to define an offset inside the loop, enter an offset value of **-0.06**.
6. Close the **Type** dialog box and click the Check icon on the **Sketcher** toolbar to accept the section and return to the dashboard.

7. In the dashboard, set the properties for a cut:
   a. Click the Remove Material icon.
   b. Check the extrusion direction, and click the direction arrow if the extrusion extends out of the solid.
   c. Set the depth to 0.03.

8. Click the Check icon on the dashboard to accept the feature.

You have made the first cut in the extrusion. The feature is added to the Model Tree. You’ll now make two mirrored slots in the bottom of this cut.
Create the Slots

The design intent for the slots is to have them identical, centered horizontally and vertically, and offset equally from the microphone center. They must also be associated so that an edit to one is reflected in the other. There are many ways to sketch these shapes—this procedure is just one of them. Basically, you will use construction lines to mark the center of the rectangle. You will then create the slot on the left side using the same mirror technique you used to create the lens. When the first slot is created, you will mirror it to the opposite side.

You must first locate the center of the section you created. You could simply calculate half the width and half the height, and place the point at the intersection, but the point would be determined by exact measurements and would not update if the height or the width dimensions changed. You want to locate the center point in such a way that it is parametrically associated with the boundaries of the rectangle section. Here is how to use Sketcher constraints to do this.

Define the Horizontal and Vertical Centers

1. Click Insert > Extrude. Enter Sketcher from the dashboard Placement panel using the bottom surface of the first cut as the sketching plane.

2. Click Sketch > References to open the References dialog box. Click on each of the outer edges of the first extrusion to add them as references. Highlighted reference lines appear on all sides of the rectangle. Close the References dialog box.

Setting up the slot section

Select the “floor” of the cut as the sketching plane.
3. Now use the Line tool on the Sketcher toolbar to place a line from corner to corner diagonally across the outer rectangle. The line ends will snap to the corners. Middle-click to exit the tool when the line is finished.

4. Because the line will not be part of the section, select it and click Construction from the right mouse button shortcut menu. This toggles the line into a construction line, used for reference only.

5. Click the Create Point tool on the Sketcher toolbar to place a Sketcher point on the construction line. As you move the point to the center of the line, an M symbol appears when it reaches the center. This is also the center of the rectangle. With the M symbols showing, click to place the point. The center is now permanently located because the point is constrained to the center of the line.

6. Click the Centerline tool, and snap horizontal and vertical centerlines on the center point. The first cut should now be bisected in both directions. You have now found the center of the rectangle and used it to define the horizontal and vertical center. Because the Sketcher reference point is constrained to be in the middle of the diagonal line, it will update its position if either the width or the height of the first protrusion changes.

Using a Sketcher point to locate the center of the extrusion

Place a Sketcher point on the diagonal reference line.

Snap horizontal and vertical centerlines to the Sketcher point.
Sketch the Slot Section

Create the top half of the new cut above the horizontal centerline, and then mirror it to create the bottom half, as follows:

1. Zoom in to the left half of the cut. Draw two vertical, parallel lines up from the horizontal axis. Notice the constraint symbols for vertical, \( V \), and equal length, \( L1 \).

Creating the slot section

2. Click the Arc tool and join the top points with an arc. Place the arc when the two \( T \) symbols appear, indicating tangency to the lines. (See the previous figure.)

3. Click the Selection arrow in the Sketcher toolbar and drag a selection rectangle around all the lines and the arc.

4. Click the Mirror tool on the Sketcher toolbar. Click the horizontal centerline. The lines are mirrored to form the first cut.

5. Use the Add or Modify Dimension tools to add the final dimensions to the section as shown in the next figure. The arc centers are 0.13 from the outer edge of the first extrusion, and 0.10 apart. The arc is 0.04 in diameter.
Final dimensions for the first slot

Edge of the first extrusion.

6. Hold down Ctrl to multiple-select the section. Click the Mirror tool again, and then click the vertical axis. The slot is copied across the vertical axis.

7. Click to finish the section. You are returned to the dashboard. As you did with the first cut, click the Remove Material icon and set the extrusion direction into the solid. Set the depth to 0.03. Click the Check icon on the dashboard to accept the feature. Save the completed part.

Summary

To demonstrate the associativity of the slots, select the internal sketch of the slot cut feature in the Model Tree and choose Edit from the right mouse button shortcut menu. The dimensions are shown for the original slot. If you enter a different dimension for the height, 0.12 for example, you’ll see both slots update to the new height.
Part 4: PC Board

The printed circuit board is another simple part with a full round, two chamfers, and four holes. You will learn how to create two holes in Sketcher as one feature, and then mirror the feature in 3D mode. You will create a datum curve as a reference for the placement of the keypad.

<table>
<thead>
<tr>
<th>Technique or Feature</th>
<th>Where Introduced</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert Extrusion</td>
<td>Part 1: Lens</td>
</tr>
<tr>
<td>Full Round Feature</td>
<td>New</td>
</tr>
<tr>
<td>Chamfer Feature</td>
<td>Part 1: Lens</td>
</tr>
<tr>
<td>Holes</td>
<td>Part 2: Earpiece</td>
</tr>
<tr>
<td>Copy and Mirror in 3D</td>
<td>New</td>
</tr>
<tr>
<td>Create a Sketcher Datum Curve</td>
<td>New</td>
</tr>
</tbody>
</table>
Create the PC Board Protrusion

Create a part called `pc_board`. Click **Insert > Extrude** and sketch the board as described below:

- Use the Front datum plane as the sketching plane. In Sketcher, place a centerline down the vertical datum so that you can use Sketcher constraints to center the rectangle.
- The Top datum plane is the horizontal reference. Draw a rectangle so that the bottom is on the Top datum pane.
- When you exit Sketcher, set the depth to 0.06.

*Dimensions for PC board sketch*

![Diagram showing Sketcher symbols and dimensions]

In Sketcher, > < symbols show rectangle is centered on centerline.

- Right datum
- Top datum

Create the two chamfers as a single feature.

- 45 x .14
Create the Chamfers and Round

Now, add the round and chamfers as features. Remember, you could create the round and chamfers in Sketcher, but it is better to create as many aspects of a part as possible as discrete, adjustable features.

Add the Edge Chamfers

1. Hold down Ctrl to multiple select the two lower thin edges. Click Insert > Chamfer > Edge Chamfer. The Chamfer dashboard opens.
2. In the Chamfer list, click $45 \times D$. This gives you a 45-degree angle chamfer with an assigned dimension.
3. Enter 0.14 for the dimension in the D text box.
4. Click the Check icon on the dashboard to accept the feature and exit the dashboard.

Add the Full Round

To round the corners you will use a full round rather than two 90-degree rounds. A full round will update with any changes to the width of the parent protrusion.

1. Click Insert > Round. The Round dashboard opens.
2. To select the edge opposite the chamfers for the round, rotate the model and select the edge.
3. Rotate the model, hold down Ctrl, and select the second edge. Both edges should be highlighted.
5. Click the Full Round button to add the full round to the PC board. Click the Check icon in the dashboard to accept the feature.

Rounding the top
Place the Holes

1. Use **Insert > Hole** to create the hole features as shown on the PC board model for this part. When the Hole dashboard opens, enter the settings from the table below. For the primary reference, click the surface near where you want to place the first hole. This surface appears in the Placement panel’s primary collector.

**Values for the first hole in the PC board**

<table>
<thead>
<tr>
<th>Hole Type</th>
<th>Straight</th>
</tr>
</thead>
<tbody>
<tr>
<td>Diameter</td>
<td>.13</td>
</tr>
<tr>
<td>Depth</td>
<td>Thru All</td>
</tr>
<tr>
<td>Primary reference</td>
<td>Surface (XXX)</td>
</tr>
<tr>
<td>Secondary reference 1</td>
<td>Right datum</td>
</tr>
<tr>
<td>Secondary reference 2</td>
<td>Top datum</td>
</tr>
</tbody>
</table>

2. Drag the reference handles to the Right and Top datum planes as shown in the next figure. Use the Placement panel to enter the exact distance values, or double-click a dimension to enter them directly on the model.

3. Set the depth to **Thru All** from the depth settings list on the dashboard.

4. Accept the feature.

*Placing the first hole on the PC board*

Drag the reference handles to the Right and Top datum planes. A black dot indicates that they have snapped into place.
Create the Second Hole

Click Insert > Hole again to place the second hole. Use the same datum planes, Top and Right, and enter a distance of 4.15 from the Top datum, and 0.4 as the distance from the Right datum. Now enter the following references in the Placement panel collectors.

Values for the second hole in the PC Board

<table>
<thead>
<tr>
<th>Hole Type</th>
<th>Straight</th>
</tr>
</thead>
<tbody>
<tr>
<td>Diameter</td>
<td>.13</td>
</tr>
<tr>
<td>Depth</td>
<td>Thru All</td>
</tr>
<tr>
<td>Primary reference</td>
<td>Surface (XXX)</td>
</tr>
<tr>
<td>Secondary reference 1</td>
<td>Right datum</td>
</tr>
<tr>
<td>Secondary reference 2</td>
<td>Top datum</td>
</tr>
</tbody>
</table>

Copy and Mirror the Holes

Now that you have two holes on one side, you can quickly copy and mirror them onto the other side of the PC board.

1. From the Model Tree, select the two hole features you just created. Click Mirror on the main toolbar. The Mirror dashboard appears.

2. Select the Right datum plane as the mirror plane and accept the feature. The new copied group is added to the Model Tree.

Note

The mirrored copy is dependent on the first hole by default.

Mirrored holes
Create a Datum Curve for the Keypad Reference

A datum curve is a type of datum that is created by defining a series of points connected by an arc. A sketched datum curve is similar, except it is actually drawn onto the model using the section drawing tools in Sketcher. It does not define geometry as a section does, but it can be added for any number of reasons: as a reference for assembly, other features, or as a notational device. Here you’ll use a flat datum curve to show the PC board designer the intended position of the keypad.

1. Click Insert > Model Datum > Sketch. The Sketch dialog box opens.
2. Select the front surface of the PC board as the sketching plane, and then click Sketch in the dialog box. Sketcher opens.
3. Click Sketch > References to open the References dialog box. Select the side edges as references, and then close the dialog box.
4. Draw a rectangle across the middle of the PC board section and dimension it using the dimensions from the next figure (height = 2, 0.4 from the Top datum).

*Dimensions for the datum curve feature*

![Dimensions Diagram]

5. Click the Check icon to complete the section. The datum curve is added as a simple outline. To crosshatch it, right-click the datum curve in the Model Tree and click Edit Definition from the shortcut menu. Click Sketch > Sketch Setup to open the Sketch dialog box. Click the Properties tab and check the X hatch checkbox to turn on crosshatching. Accept the section. The datum curve is now crosshatched.
6. Save and close pc_board.prt.
Summary

So far, you’ve learned to create simple extrusions to define solids and cuts, and to create patterns. You have created a datum curve as a reference for the placement of the keypad. As you create the antenna, you’ll use a variation of the extrusion technique, a revolved protrusion, and learn some new Sketcher techniques.
Part 5: Antenna

A sketched 2D profile that is revolved around an axis, called a revolved extrusion, is used to create the antenna. The tip of the antenna is created first and a revolved cut is then added to it. The antenna shaft is created with another round extrusion from the base of the tip.

<table>
<thead>
<tr>
<th>Technique or Feature</th>
<th>Where Introduced</th>
</tr>
</thead>
<tbody>
<tr>
<td>Revolved Extrusion</td>
<td>New</td>
</tr>
<tr>
<td>Round Extrusion</td>
<td>Part 1: Lens</td>
</tr>
<tr>
<td>Revolved Cut</td>
<td>New</td>
</tr>
<tr>
<td>Insert Extrusion</td>
<td>Part 1: Lens</td>
</tr>
</tbody>
</table>
Sketch the Revolved Protrusion

Create a new part file and call it antenna.

1. Select *Insert > Revolve*. Enter Sketcher through the dashboard Placement panel, and use the Front datum as the sketching plane.

2. In Sketcher, place a centerline along the vertical axis.

3. Use the Line tool to sketch the polygon as shown in the next figure.

*Rough sketch of the antenna tip*

![Rough sketch of the antenna tip](image)

Pro/ENGINEER automatically generates weak dimensions for the section. These dimensions define the revolved section for the extrusion. However, you may devise another method that better meets your needs.

4. Use the Add Dimension tool on the Sketcher toolbar to insert a dimension for the angle of the outer wall. Click each side of the angle and then middle-click between the sides to place the dimension. The weak dimension value for the top of the shape disappears, because that dimension is now determined by the angle. Middle-click to exit the tool.
Adding strong dimensions

5. Select, and then right-click the weak height dimension and select **Strong** on the shortcut menu. The weak dimension is converted to a strong dimension, which remains when other dimensions or constraints are added.

6. Select the Add Dimension tool to add the diameter dimension. Click the outer corner of the section, the centerline below the section, and the outer corner of the section again. (See the previous figure.) Middle-click to place the dimension. This action doubles the radius of the revolve and enters it as the diameter of the base. Middle-click again to exit the tool.

   Every parametric relationship that determines the shape of the revolved extrusion has now been defined: height, base diameter, and taper. This process is known as solid definition.

*Final dimensions for the antenna tip extrusion*

- Height = 0.5
- Angle = 3.0
- Diameter = 0.25
7. Now add the real values for all the dimensions. Use **Edit > Select > All** to select everything in the sketch.

8. Click the Modify Dimensions tool. In the **Modify Dimensions** dialog box, enter the desired values for all the dimensions. Remember, you can select a dimension in Sketcher to highlight it in the dialog box.

9. Now click on the Sketcher toolbar to finish the sketch. You are brought back to the dashboard, with the revolution completed to 360 degrees. Drag the degree handle to see how the revolved solid works. It can be set to any angle up to 360. Set the revolve to 360 and accept the feature.

**Add a Round to the Top**

Select the top edge of the protrusion and use the right mouse button shortcut menu to add a round of 0.02.

**Add the Revolved Cut**

This section covers more techniques for using constraints in Sketcher. You’ll add a revolved cut to the revolved surface. This cut could have been included in the revolved protrusion’s profile, but best practice is to keep as many features as possible as separate entities.

1. To start, use **Insert > Revolve** and enter Sketcher. Use the Front datum as the sketching plane. Click Sketch, and then add the angled outline of the antenna tip as a reference (click Sketch > References to open the References dialog box). Click OK and close the dialog box.

2. Add a centerline along the axis of the protrusion.

---

Modeling the Cell Phone - Part 5: Antenna

4-33
3. Sketch the first line (line 1 in the next figure) into the solid from the revolved surface. Notice that the constraint defaults to \(H\), or horizontal to the top. Since the line should be perpendicular to the revolved surface, quickly right-click to disable the default constraint while the \(H\) is visible. (Don’t hold down the button long enough to bring up the shortcut menu—just click the button.) You’ll see a line drawn through the default constraint symbol, indicating the default snapping constraint is turned off.

You’ll now be able to draw the line to an angle perpendicular to the revolved surface. (You’ll see the perpendicular symbol, an inverted \(T\), when the line is in position.)

4. Draw the remaining lines, disabling the default constraints as needed. Lines 1 and 3 in the next figure are perpendicular to the revolved edge. Line 2 is parallel to it.

**Sketching the cut section**

5. Use the Sketcher Point tool to place a Sketcher point at the intersection of the tip edge and the base. When the rough section is complete, a dimension is needed to locate it in reference to the tip base. Because the tip base and the bottom of the cut are not parallel, a constant dimension cannot be entered between them.

6. Use the Add Dimensions tool to add the dimension between the Sketcher point and the bottom line of the cut. For the bottom line, select the line itself, not its intersection with the tip edge. When the dimension is entered properly, the witness lines for the dimension are parallel to the bottom of the cut, not the tip base. Replace the weak dimensions with the strong ones shown in the next figure, giving them the values indicated.

**Tip**
You can toggle existing weak dimensions into strong dimensions; just select the dimension and press Ctrl+t.
7. When the sketch is finished, accept the section and return to the dashboard. Enter 360 for the revolve angle. Make sure the Remove Material icon is active. Accept the feature and return to 3D mode.

**Make the Shaft Extrusion**

The shaft is a single cylindrical extrusion centered on the revolve axis. To add it, click **Insert > Extrude**. Enter Sketcher from the dashboard and select the bottom of the tip extrusion as the sketching plane. Use the Circle tool in Sketcher to create a circular section, letting the center snap to the center of the tip feature. The circle diameter is 0.125. Enter a length of 3 in the dashboard. Make sure the extrusion points away from the tip base. If it does not, click the Direction icon to change it. Accept the feature and save and close the completed part.

**Summary**

So far, the five cell phone parts contain fewer than a dozen features. You should now have a good understanding of Sketcher operations, especially how to define the shape of solids by building in geometric constraints. The associativity among dimensions in the antenna tip illustrated this process. Remember, best practice is to create features as separate entities. Each feature then appears in the Model Tree so changes can be easily made to it.
Part 6: Keypad

In the earpiece part, you defined a radial pattern, one that created new instances of a feature at intervals around a radius. The keypad also uses a pattern, but this one defines the number of instances in the x and y directions.

Like the PC board, the keypad uses a copy and mirror operation for the upper two large buttons. This part also introduces relations, or formulas used in place of dimension values. You’ll learn how to refer to dimensions by their ID numbers rather than by their values, and how to reference dimensions by their ID numbers within a formula. The relation technique is useful in Sketcher, as well as in Part and Assembly modes, to ensure that features and parts are properly associated.

<table>
<thead>
<tr>
<th>Technique or Feature</th>
<th>Where Introduced</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert Extrusion</td>
<td>Part 1: Lens</td>
</tr>
<tr>
<td>Round Corners</td>
<td>Part 1: Lens</td>
</tr>
<tr>
<td>Pattern Feature in Two Directions</td>
<td>New</td>
</tr>
<tr>
<td>Use Relation as a Dimension Value</td>
<td>New</td>
</tr>
</tbody>
</table>
Sketch the Keypad Protrusion

To start, create a new part called keypad. Use the following guidelines to create the first extrusion with the dimensions shown in the next figure:

1. Start Sketcher from the Extrude dashboard, and use the Front datum plane as the sketching plane. Add a vertical centerline as a point of reference for the keypad rectangle constraints. The centerline will bisect the pad vertically.

2. Start in the upper-left corner and drag a rectangle across the centerline, down to the right. Stop at the Top datum. Remember, the facing arrows tell you that the lines on either side centerline are the same length.

Dimensions for the keypad protrusion

3. Select the weak dimensions and make the height 2 and the width 1.5, as shown in the previous figure.

4. Click the Check icon on the Sketcher toolbar to complete the extrusion. Enter 0.03 as the depth value, and accept the feature.

Round the Corners

1. To round the corners, rotate the model while zooming in on the corners, and use Ctrl + click to multiple-select all of the .03 edges. You can set the filter to Geometry to select the edges directly, or use the Smart filter to cycle through objects under the cursor. When you have selected the first edge, you don’t have to cycle through to select the next edge. The Smart filter puts similar objects at the start of the selection cycle based on your previous selection. Just hold down the Ctrl key and click the remaining edges to add them to the selection.
2. When all of the edges are selected, right-click and select **Round Edges** from the shortcut menu. In the dashboard, set the round value to 0.06. When you multiplte-select and round this way, all the corners are associated and an edit to one of them affects all of them.

**Add the First Button Feature**

Now you’ll add the first button feature. This will serve as the leader for the button pattern.

1. Click **Insert > Extrude** to create an elliptical extrusion on the first feature, as shown in the next figure. Use the front surface of the first extrusion as the sketching plane. In Sketcher, use the Ellipse tool on the **Circle** flyout menu. After you sketch the basic ellipse, enter the distance and radius values shown in the next figure: 0.44 from the centerline and 0.1875 from the Top datum plane. Enter the button radii as shown in the next figure.

   ![Location and dimensions for the first button](image)

   *Location and dimensions for the first button*

2. When you accept the section and return to the dashboard, give the button a value of 0.22 for the depth. Accept the feature.

**Pattern the Button**

Now you’ll pattern the button feature. Patterning easier to understand if you think of it as repeating dimensions rather than repeating features, although it is the feature that gets repeated in a pattern. You define the dimensions to be repeated in the Pattern dashboard, indicate the direction in which they will be repeated, and enter the number of copies, including the original, to be made.

1. Select the button extrusion in the Model Tree. Right-click and select **Pattern** from the shortcut menu. The Pattern dashboard opens, and you are prompted “**Select dimensions to vary in the first direction**.” Notice that the collector for the first direction is active.
2. Use the x direction as the first direction and create two more buttons to the left of the original; one centered on the first extrusion, and one 0.44 to the left of the center:
   a. Select the 0.44 dimension. Enter -0.44 in the dimension box and press Enter. A positive value would have sent the pattern to the right, away from the referenced dimension.
   b. In the text box to the left of the dimension collector, enter 3 for the number of instances, including the original, to create in the pattern.
   c. Click the Check icon on the dashboard to accept the pattern and check whether all values are entered correctly. The first part of the pattern should be added as shown in the next figure.

   *The first part of the button pattern: the X direction*

3. Now you’ll go back and enter the Y direction. (You usually enter both X and Y direction at the same time. This step is simply to check the pattern setup.) Right-click the pattern in the Model Tree and choose *Edit Definition* from the shortcut menu. The Pattern dashboard opens to the existing pattern.

4. Open the Dimensions panel. Click the second direction collector. It should become yellow and show *Select Items*.

5. Select the vertical dimension. Enter 0.35 as the increment and 4 as the number of instances. Accept the feature.
Apply Rounds to the Pattern

1. Now use Ctrl + click to select the top and bottom edges of the first button, the pattern leader, and apply a round of 0.03 to them. When the rounds are complete, they are added as one feature to the Model Tree.

2. Right-click the new round in the Model Tree, and select **Pattern** from the shortcut menu. Accept the feature. The rounds are applied to the rest of the pattern.
Extrude the Large Button

1. Click **Insert > Extrude** and use the front surface as the sketching plane.

2. Open the **References** dialog box. Select the edge of the upper-right button as a reference, as shown in the next figure. You are actually referencing the vertical surface of the button, not the edges of the rounds. To select the correct entity, place the cursor over the button edge and select **Pick from List** from the shortcut menu. A list box opens, listing all entities in the vicinity under the cursor.

3. From the list box, select any one of the surfaces listed. The edge around the entire surface will highlight, and the center of the ellipse is shown. When the surface is selected, it is added to the list in the **References** dialog box, and its color changes to orange to indicate that it is a reference. Close the dialog box.

4. Click the Centerline tool, and let the centerline snap to the referenced edge, as shown above. You’ll see a $T$ at the intersection indicating tangency between the edge and the centerline. Place another centerline along the vertical axis of the first extrusion.
Sketch the Large Button Section

Now you can add the section for the large button. The section is drawn using three straight lines and an arc closing the top. Set the strong dimensions as shown below.

1. Use the Add Dimensions tool to place a dimension between the bottom line of the large button and the center of the top right button of the pattern. For now, accept the weak value. This is the dimension you will “drive” with a relational formula.

2. Accept the section. Check whether the section is extruding in the proper direction and correct it if necessary.

3. For the depth, click **Extrude To Surface** from the depth settings list on the dashboard. You are prompted to select an existing surface to use as a reference for the button height.

4. Select the top of one of the small buttons. The height of the large buttons will now be dependent on the height of the smaller ones. Accept the feature.
Establish Distance Relations for the Buttons

The design intent is to keep the large buttons vertically spaced to the lower pattern in the same proportion as the lower pattern buttons are vertically spaced to each other. You will use a relational formula to keep the proportion exact.

In this procedure you’ll also learn how to reference dimensions by their ID numbers (for example, d56) rather than their values. To toggle the display between dimension values and ID numbers, use Info > Switch Dimensions. (Your dimension ID numbers may be different from the ones shown here.)

The dimension ID has a prefix that identifies its dimension type. A dimension in Sketcher will have an s in front of the d, noting it as a Sketcher dimension, for example, sd44. The dimensions for the elliptical buttons use the letters Rx and Ry for radius x-direction and radius y-direction. You don’t need the extra prefix letters when entering the dimension IDs in relations. The dimension Ryd8 would just be entered as d8.

The relation includes the dimension between the vertical centers of two adjacent small buttons (d273) and the button y-direction radius (d269) as shown in the next figure. It stipulates that the distance between the bottom edge of the large button and the center of the small button below it (d301) is the same as the distance between the edge of a small button and the center of the next one in the vertical direction.

That distance is the distance between two button centers, minus the radius of one button. So the expression you’ll enter is

\[
\text{Distance between large button bottom edge and center of next small button} = \\
\text{small button vertical center to center,} \\
\text{minus small button y-radius,} \\
\text{or:} \\
\text{d301} = \text{d273} - \text{d269}. \text{(You’ll use your equivalent dimension IDs.)}
\]
1. To enter the relation, click **Tools > Relations**. The **Relations** dialog box opens.

2. Click the large button extrusion and then the pattern. The dimensions should show in symbol form. If they are not in symbol form, click the Toggle Symbol icon in the toolbar to switch them.

3. Using the above figure as a guide, and substituting the symbol names as they appear on your model, enter the following into the **Relations** dialog box: \( d_{301} = d_{273} - d_{266} \).

4. Click **OK** in the dialog box. The formula now determines the value of \( d_{301} \).

To see the effect of the relation:

a. Select the button pattern in the Model Tree and click **Edit** from the shortcut menu. The dimensions for the pattern are activated.

b. Select the dimension for the distance between the small button centers and change it to a larger number.

c. Click **Edit > Regenerate**. You should see the large button move in proportion to the small buttons. Repeat the process to return the part to its original dimensions.
Round the Large Button Edges

Multiple-select the four vertical edges (corners) of the large button extrusion. From the shortcut menu, add a round of 0.11. Open the Sets slide-up panel in the dashboard and click New Set. Multiple-select part of one edge from the top and part of one edge from the bottom of the button, and then apply a round of 0.04, which is automatically applied to the entire edge.

Rounding the large button

Mirror the Large Button Section

1. In the Model Tree, select the large button feature, including the rounds.

2. Select Edit > Mirror from the main menu or the Mirror icon on the toolbar.

3. Select the Right datum plane for the mirror. Accept the feature. A mirrored copy of the selected features is added opposite the existing button. Save and close the part.

Summary

A relatively complex part using combined patterns and 3D mirroring is now complete. You have also learned how to reference dimensions by ID numbers in relational formulas.
The back cover part revisits several basic techniques you’ve used already and introduces some new ones: adding a draft angle and shelling a solid. Shelling hollows out a solid to a given wall thickness. You’ll learn how to create a new datum plane offset from the solid, and then use this technique to create the antenna brace and the screw posts on the floor of the shell.

<table>
<thead>
<tr>
<th>Technique or Feature</th>
<th>Where Introduced</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert Extrusion</td>
<td>Part 1: Lens</td>
</tr>
<tr>
<td>Round Feature</td>
<td>Part 1: Lens; Part 5: Antenna</td>
</tr>
<tr>
<td>Extruded Cut: Two Sides</td>
<td>New</td>
</tr>
<tr>
<td>Draft Feature</td>
<td>New</td>
</tr>
<tr>
<td>Shell Feature</td>
<td>New</td>
</tr>
<tr>
<td>Make Datum on the Fly</td>
<td>New</td>
</tr>
<tr>
<td>Hole Features</td>
<td>Part 2: Earpiece</td>
</tr>
<tr>
<td>Copy and Mirror in 3D</td>
<td>Part 6: Keypad</td>
</tr>
<tr>
<td>Round Feature Using Edge Chain</td>
<td>New</td>
</tr>
</tbody>
</table>
Create the Basic Extrusion

In a new part called `back_cover`, create the basic extrusion according to the dimensions in the next figure. Use the Front datum plane as the sketching plane, and add a centerline down the vertical axis, as with the keypad.

Sketch a rectangle that is centered on the centerline and rests on the Top datum plane. Dimensions are 4.75 (height) and 1.75 (width). In the dashboard, enter a value of 0.50 for the depth.

**Dimensions for the back cover extrusion**

[Diagram of back cover extrusion]

Create the First Cut

Now you’ll remove an angled slice of the solid to taper the back side of the phone and extrude the cut in two directions from a central point.

*A cut feature can extrude from both sides of the sketching plane*
1. Click **Insert > Extrude**. Use the Right datum plane as the sketching plane. Make sure the sketch orients in the top right quadrant. If not, click **Flip** in the **Sketch** dialog box.

2. Add the top and right edges as references. Sketch the cut with a single line as shown in the next figure.

   *Adding dimensions for the cut section*

3. Enter the exact dimension values: 0.25 for the distance from the edge and 9 for the degree of angle.

4. Accept the sketch. Now set up the rest of the cut properties in the dashboard. As long as you can see the extrusion direction arrow, you don’t have to move the model in any way:
   
   a. Click the Remove Material icon to make the extrusion a cut.
   
   b. Click the Direction icon if necessary so the direction arrow points away from the solid.
   
   c. In the Options panel, set the depth for both side one and side two to **To Next**.

5. Click the dashboard Preview icon and rotate the model to see the cut. Click the Check icon in the dashboard to accept the feature.
Round the Corners

1. Select the two bottom corner edges. Right-click, select Round Edges from the shortcut menu, and apply a round of 0.50. In the Sets slide-up panel, click New Set. Select the two top corner edges and apply a round of 0.75.

2. Apply a round to the juncture between the extrusion and the cut. Enter a value of 4. Accept the feature and save the part.

Rounding the cut edge

Add the Draft

The draft feature will taper the back cover on all sides by 10 degrees, from the front to the back. To define a draft, you select the surface to which to apply the draft, and then specify a hinge plane, a draft direction, and a draft angle.

1. Select one segment of the surface to be drafted. Orient the model as shown in the next figure, and then use the Smart filter to select the surface segment. By default, Pro/ENGINEER assumes that you want to draft this surface and the ones adjoining it.

Applying the draft feature

2. Click Insert > Draft. The Draft dashboard opens. Open the References slide-up panel. The Draft Hinges collector is active.
3. Click the front surface of the cover as the hinge reference. The edge of the surface is highlighted, and the draft angle handles appear. The draft direction arrow should be pointing away from the solid.

*Using the front surface as the draft neutral plane*

4. Drag the handle to 10 degrees, or enter 10 for the depth box.

5. Click **Preview** to see the finished feature, or click the Check icon to accept the feature and return to the work area.

*Using the draft handles*

*The completed draft*
Round the Back Edges

Because there are 10 sections of the back edge to select, it is faster to use an edge chain to define the edge to round. Because the back edge forms a continuous line, you can use the Shift key to select a chain of edge sections by selecting two of them.

1. With the Smart filter on, click an edge section until it highlights in bold. (Or set the filter to Geometry and select the edges directly.)

2. Hold down the Shift key and click another section of the same edge. All the adjoining edge sections are automatically selected in an edge chain, as shown in the next figure.

3. Select Round Edges from the right mouse button menu and enter a radius value of 0.15. The rounded sections are entered as one feature in the Model Tree.

4. Accept the feature, exit the dashboard, and save your model.

Shell the Extrusion

Now you are ready to use the Shell function to hollow out the solid. You only need to select the surface that you want to remove and specify a thickness for the walls of the shell.

1. Click Insert > Shell. In the Shell dashboard, enter a thickness of 0.03.

2. Rotate the model so that you can select the front surface. Accept the feature and save the part.
Add the Antenna Brace

The antenna brace is extruded into the solid from a datum plane offset above the part. When a feature is created using a datum made on the fly, the datum is automatically grouped with the feature in the Model Tree. The datum plane is hidden when the feature is finished and is only displayed when the feature is edited. Use the Thru to Next depth setting to make the extrusion conform to the cover surface.

Creating the antenna brace protrusion

1. Click Insert > Extrude and enter Sketcher from the Placement panel. Instead of selecting an existing plane for the sketch, click Insert > Model Datum > Plane. The Datum Plane properties dialog box opens.

2. Make sure the References collector of this dialog box is active, then click the Top datum plane, either in the Model Tree or in the model itself. A new plane is added, offset from the Top datum. A new plane is added, offset from the Top datum.

   **Note**
   Offset is the default datum type when you select a datum plane as a reference. You can use the list box to the right of the selection to change the reference type. To add extra references to the collector, hold down the Ctrl key when you select the references.

3. In the Offset Translation box, enter 4.85. This will place the datum plane 0.10 above the edge of the cover. Click OK to close the Datum Plane dialog box, then Resume to return to the dashboard. Now click Sketch and select the new datum plane.

4. The cover will be oriented in a top-up position, making it easier to and visualize the location of the section while drawing. If necessary, click Sketch > Sketch Setup to reopen the Sketch dialog box and make sure sure the Orientation is Left. Click Sketch.
5. Create a circle on the sketching plane, with the dimensions as shown in the next figure. The diameter is 0.29, the center is 0.22 from the Front datum, and 0.62 from the Right datum.

*Dimensions for circle protrusion*

6. Click the Check icon in the Sketcher toolbar to accept the section. Check the extrusion direction and click the direction arrow to correct if necessary.

7. Select **Through Until** as the depth type, and select the surface the extrusion will encounter. This stops the protrusion at the next surface it encounters, making it conform to an uneven surface. Click the dashboard Preview icon to see the result. Accept the feature.

### Add Hole and Rounds to Brace Feature

1. To add a hole centered on the brace axis, select the brace axis and click **Insert > Hole**. A preview hole is placed in line with the axis. (Be sure axes are displayed. To simplify selecting the axis, use **Pick from List** or set the filter to Datums.) Set the diameter to 0.13.

2. Open the Placement panel. It should show the hole type as coaxial, with the brace axis as the primary reference. Click in the secondary reference collector to activate it, and select the circular surface of the brace as the secondary reference. This positions the hole at the upper surface of the brace.

3. Select **To Next** as the depth type, so that the hole will stop at the next surface. Accept the hole feature and save the part.
Adding rounds to the brace

4. Now add the round. Select, and then right-click the top edge of the brace and use the shortcut menu to add a round of 0.03.

5. Open the Sets slide-up panel and click **New Set**. Select a tangent chain the same way you did earlier in the part, for the draft edge. With the Smart filter on, click over an edge section until the section itself is selected. Then hold down the Shift key and select any other section in the chain. The entire edge is automatically selected. Add a round of 0.02.

**Add Screw Post Extrusions**

In this exercise, you’ll finish the cover by creating an extrusion feature consisting of two posts used to screw the halves of the cell phone cover together. You’ll put a standard-spec type of hole into the posts, and add rounds to the posts’ intersections with the shell. When these features are finished, you’ll copy and mirror them to the opposite side of the shell.

*Screw posts*
Because the posts sit below the surface of the shell profile, you will make a datum plane offset below the rim of the shell to use as a sketching plane. The posts will extrude from the new plane down to the floor of the shell, the same way the antenna brace joined to the shell.

1. Select **Insert > Extrude**. With the plane collector active in the **Sketch** dialog box, click **Insert > Model Datum > Plane** from the main menu. Set up an offset datum plane the same way you did for the antenna brace, but offset the datum from the lip surface of the cover by -0.06. A negative value places the datum below the rim. Click **OK**.

2. Click **Sketch** in the **Sketch** dialog box. If the part does not appear in the correct orientation, reopen the **Sketch** dialog box and click the Flip and Orientation buttons to orient it correctly, then click **Sketch**.

### Placing the offset datum plane

3. Draw a circle for the bottom post section first. Scale is not important—draw a large circle so you can see what you’re doing, and dimension it down later. Click to complete the first circle, and then move the cursor toward the upper part of the cover, and draw the second circle.

4. As you draw the second circle away from the center, an “R” constraint symbol appears at the new circle when its radius matches that of the first one. Complete the circle when the R symbol is visible. The second circle is now constrained to share the same radius value.

   **Note**
   You can also apply this constraint to the two circles after the fact, using **Sketch > Constrain**.

5. Add the strong dimensions, and then enter a diameter value of 0.19. Accept the sketch. Make sure the extrusion direction is pointing inward, and set depth type to **Thru To Next**. Accept the feature.
Add Holes to the Screw Posts

Now add countersunk holes to the posts. You’ll add one hole, then copy it to the other post. When you finally mirror the posts and holes to the other side of the shell, they will all be associative.

The first hole is through the back of the shell. It is counter bored, so the countersink occurs near the top of the post, as shown in the next figure. Be sure axes are displayed—they are used as references for the holes.

1. Select Insert > Hole. Select the axis with which to place the lower-post hole. A preview hole is placed concentric to the axis.

2. Click the Placement panel. The hole should show as coaxial, with the hole’s axis as the primary reference. If it is not, click to activate the primary reference collector and select the axis. Now select the large flat surface on the back of the shell as the secondary reference. The hole is now properly referenced.
3. Select **Standard Hole**, a screw size of 2-56, **Countersink** and **Counterbore**, and a drill depth of **Thru All**. Click the Shape panel and enter the information as shown. Accept the feature.

### Countersunk hole setup values

![Countersunk hole setup values](image)

**Copy the Hole Feature**

You will want the four holes that you will eventually create to be associative, that is, that they all update when a change is made to the parent. The best way to do this is to copy the parent feature to another location, in this case, the second post. After the hole is copied to the second post, you will mirror the posts, holes, and the rounds you will make at the bases to the other side of the Right datum plane. You will then have four drilled posts, all associative.
When you copy a feature, you proceed through a series of prompts in the Menu Manager that let you change dimensions or references for the copied feature. In this case, you’ll just be copying the hole along the same plane, to a different axis:

1. Click **Edit > Feature Operations**. Click **Copy** in the Menu Manager.

2. Highlight **New Refs** in the **Copy Feature** submenu, (you will be supplying a new reference) **Select** (you will select a feature to copy from the current part), and **Dependent** (the copy will take and retain dimensions from the parent), and then **Done**. You are prompted to select the feature to copy.

3. Select the hole from the Model Tree, and then **OK** in the **Select** box and **Done** in the Menu Manager. The Menu Manager opens to the **Group Elements** menu, with the **VAR DIMS** line highlighted. The dimensions of the hole are numbered and highlighted. If you wanted to vary the copy, you would use this menu. Because you want the copy to be exact, click **Done**. The **WHICH REF** menu opens. The surface reference for the parent hole is highlighted in the part.

4. Because you are going to use this reference for the copy, click **Same**. The second reference for the parent hole, the axis, is now highlighted.

5. Leaving **Alternate** selected, click the axis for the second post. Click **Done**. The hole is copied, and added to the Model Tree as a copied group. Click **Done**.

6. Multiple-select the base joint of each post and apply a round of 0.03. Accept the feature.

*Round at the base of a post*
Mirror the Screw Posts

Finally, copy and mirror the screw posts to the other side of the shell using the same process as copying the holes in the PC board.

1. In the Model Tree, select the:
   a. Protrusion with the two posts
   b. Original hole
   c. Group for the copied hole
   d. Round feature at the post’s bases (The rounds should be one feature.)

2. Click the Mirror icon on the toolbar and the Right datum plane as the mirror plane.

3. The copied features are mirrored and added as a group to the Model Tree. Save and close back_cover.prt.

Holes and screw posts mirrored

Summary

You have created a part using a shell, a draft, rounds, and holes as features, and learned how to use some fairly simple geometry to create a detailed and complex form. The final part is a more elaborate exercise that uses many of the same techniques.
The front cover is similar to the back cover in that it is a shelled protrusion with screw posts extruding from the interior surface. It includes cuts to accept the lens and mounting shelves for the earpiece and the microphone parts.

The front cover also requires cuts to accommodate the buttons of the keypad. In this case, the easiest way to create the holes in the front cover is to do it at the assembly level. When the keypad and the front cover are part of an assembly, you can create all the required cuts by removing material where interference exists between the two parts. The cutouts are passed back to the part and remain stored with it.

<table>
<thead>
<tr>
<th>Technique or Feature</th>
<th>Where Introduced</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert Protrusion, Rounds</td>
<td>Part 1: Lens</td>
</tr>
<tr>
<td>Extruded Cut: Two Sides</td>
<td>Part 7: Back Cover</td>
</tr>
<tr>
<td>Draft Feature</td>
<td>Part 7: Back Cover</td>
</tr>
<tr>
<td>Shell Feature</td>
<td>Part 7: Back Cover</td>
</tr>
<tr>
<td>Make Datum on the Fly</td>
<td>Part 7: Back Cover</td>
</tr>
<tr>
<td>Hole Features</td>
<td>Part 2: Earpiece</td>
</tr>
<tr>
<td>Copy and Mirror in 3D</td>
<td>Part 6: Keypad; Part 7: Back Cover</td>
</tr>
<tr>
<td>Rounds using Edge Chain</td>
<td>Part 7: Back Cover</td>
</tr>
<tr>
<td>Import Saved Section</td>
<td>New</td>
</tr>
</tbody>
</table>
Create the Front Cover Protrusion

Create a new part called `front_cover`. Create the first protrusion in the same way that you created the first protrusion for the back cover. Use the Front datum as the sketching plane, and accept the defaults for orientation. In Sketcher, place a centerline on the vertical axis and sketch the rectangular protrusion as shown in the next figure. Make sure that the “> <” symbols show that the rectangle is centered horizontally on the centerline. When you accept the sketch and return to the dashboard, set the depth at 0.195.

**Dimensions for the front cover protrusion**

![Diagram showing the dimensions of the front cover protrusion](image)

Add Construction Datum Planes

Next, you’ll add two construction datum planes. The first one will be through the upper surface of the first protrusion. The second will be offset by 2 units along the protrusion from the first one.

1. To add the first datum plane, click **Insert > Model Datum > Plane**. Select the surface opposite the Top datum as a reference. The new datum appears in preview.

2. Click the direction arrow on the preview datum so that it points toward the solid. Because the datum will be flush with the surface, leave the Translation value set at zero. Click **OK** in the **Datum Plane** dialog box.

3. To add the second datum plane, click **Insert > Model Datum > Plane** again. Click the datum you just added as the reference for the new datum. Enter a translation value of 2.

4. Click **OK** in the **Datum Plane** dialog box. The new datum is added, offset into the protrusion 2 units from the first.
Adding construction datum planes

Round the Front Cover Corners

1. Use the Ctrl key to select the top two corner edges. (It will be easier to select the edges if you turn off datum display.)

2. Right-click and select **Round Edges** from the shortcut menu to add a round of 0.75. In the **Sets** slide-up panel, click **New Set**. Select the bottom two corner edges and apply a round of 0.50. Accept the feature.

*Dimensions for rounded corners*
Lift the Lens Housing Extrusion

In this procedure, you’ll create a new extrusion from the front surface of the first one, and you’ll learn how to use some of the edges that already exist to define the new section.

1. To start, click Insert > Extrude and select the front surface of the first extrusion as the sketching plane. This is the surface that is offset from the Front datum. Click Sketch.

2. Open the References dialog box, add the offset construction datum to the references, and click Close. (Make sure that datums are displayed. Once the datum is referenced, you can turn the datum display off to unclutter the drawing area.)

Setting up to sketch the lens housing extrusion

3. Select Sketch > Edge > Use to define the extrusion using existing edges. When the Type dialog box opens, click Chain, but don’t close the dialog box.

4. At the prompt, click both sides of the existing extrusion. Pro/E selects the two lines and one of the arcs between them, the upper or lower. Use the Choose dialog box to make sure the upper arc is selected (click Next to change the selection), and click Accept. Click OK and then click Close in the Type dialog box. The chain is marked by the S-shaped chain symbol.

Note
You could have selected the edges individually, but when you establish a chain, the whole shape updates when any changes are made to the underlying geometry.
5. Place a Center-and-Endpoints arc so that the center point is aligned with the vertical center, and constrain it so the arc is tangent to the construction datum plane reference line.

*Finished arc centered and tangent to the construction datum*

6. Now trim the unnecessary lines below the arc points. Use the Dynamic Trim tool to erase the lines below the arc you added.

7. Enter 1.94 for the arc radius. Because the section’s edges are defined by the underlying edges, and the arc’s center is in line with the centerline, the angle value is enough to define the dimensions of this section.

8. Click in the Sketcher toolbar to accept the section. Enter a depth of 0.13. Check the direction and accept the feature.
Add the Earpiece Cut

Now you’ll make a cut to round the top of the cover for the earpiece. The section for this cut is similar to one you made previously in the back cover.

1. Click **Insert > Extrude**. Use the Right datum plane (bisecting the cover) as a sketching plane. Add the front edge and the first datum plane you created as references.

2. Use a simple arc to define the section as shown in the next figure. Make sure the automatic tangent constraint symbol (T) appears. If not, use the Constrain tool to add it.

3. If the 0.20 dimension is not automatically added as a weak dimension, use the Add Dimensions tool to insert it.

**Dimensions for the earpiece cut section**

4. Enter a value of 1.00 for the arc. Accept the sketch.

5. Click the Remove Material icon to make the extrusion a cut. Make sure the cut direction arrow is pointing away from the solid. In the **Options** panel, set Side 1 and Side 2 to **Through All**. Preview the cut and then accept it.
Create the Draft Feature

Now you’ll apply a draft to the side surfaces in the same way that you did to the back cover part.

1. Select one of the side surfaces of the solid. Click Insert > Draft. The Draft dashboard opens.

2. With the Draft Hinges collector active, click the back surface of the cover. The draft angle indicator and handles should appear on the model.

3. Drag the handle out to 10 degrees, or enter 10 in the dashboard value box.

4. Click Preview to see the finished feature, or accept the feature and return to the work area.

Handles and direction indicator for the draft angle

Apply Round Edges

1. Select the edges between the face and the upper extrusion and apply rounds. The lower radius is 0.77. The upper radius is 0.25. When these two rounds have been applied, the upper edge of the phone is an unbroken line.

2. Select any section of the cover edge, hold down Shift and select another section. The entire edge is chosen. Apply a rounded edge of 0.15 from the shortcut menu.
Shell the Solid
With the rounds complete, you are ready to apply the shell feature. Use the same procedure you applied to the back cover. Enter 0.03 for the shell thickness.

Cover after the shell process

Create Lens and Earpiece Cuts
The following set of procedures completes the interior of the phone. You’ll create an opening for the lens, and mounting forms with small holes for the microphone and the earpiece. Finally, you’ll create the screw posts to join with the ones in the back cover.

Make the Lens Shelf and Opening Cuts
The first cut is the shelf on which the lens mounts. Its dimensions are the same as the lens itself. When the lens was created in the first exercise, the section was saved as lens.sec. This saved section is used for the cut.
1. Click the Saved View List icon to orient the cover to the Front view. (This isn’t absolutely necessary but it will make following the directions easier.)

2. Select Insert > Extrude. Select the surface that will take the lens opening cut as the sketching plane. Click Sketch.

3. Select Sketch > Data from File > File System. In the browser, select the lens .sec file. Click on the approximate area to place the sketch. The section is imported and set into the graphics window. The Scale Rotate dialog box opens.
4. Make sure that the scale is set to 1. Click the Check icon in the dialog box to accept the section. The section is placed with weak dimensions defining the distances from the reference lines.

5. Select Sketch > Dimension > Normal. Add a dimension of 0.15 between the bottom arc of the lens section and the lower arc of the lifted extrusion.

6. Now align the centers of the section and the cover. Select Sketch > Constrain. In the Constraints dialog box, select the Colinear constraint. Click the centerline of the section, and then the centerline of the cell phone cover. The two centerlines are aligned concentrically. Close the Constraints dialog box. Now enter the strong dimensions as shown in the next figure and accept the section.

7. Click the Remove Material icon. Click the direction arrow so it points into the cover. This cut does not go completely through the face; set the depth to Specified Value and enter a depth of 0.02. Accept the feature.

*Imported section in place*
Create the Lens Cutout

As demonstrated previously, you can use an existing edge as the basis for the dimensions of another edge. This is the obvious technique for creating the cutout for the lens.

1. Select Insert > Extrude. Select the floor of the lens cut as the sketching plane.

2. Click the Offset From an Edge tool from the Use Edge flyout menu. In the Type dialog box, click Loop. (Don’t close the dialog box.)

3. Select the shelf outline. The loop is defined from all the connected lines of the shelf outline. The direction of offset is shown by a yellow arrow, and you are prompted for an offset value. Because you want the offset inside the shelf outline, enter a value of -0.03. Close the Type dialog box. The outline for the cutout section is created as an offset.

4. Accept the section. Set the depth as Thru All. Click the Remove Material icon to create the cut. Make sure the direction arrow points into the cover. Accept and save the feature.

Offset edges for the lens cut section
Round the Opening Corners

Select all four inside corners of the shelf cut, and add rounds of 0.08 to them, as shown in the next figure.

Round the lens housing corners

Note

The lens part has the same rounds, added as separate features to the lens extrusion. There are many methods in Pro/ENGINEER, beyond the scope of this tutorial, to insure that adjoining parts not only match in size and dimensions, but are also associative. They include creating new parts from within the assembly, or using a skeleton part as a reference for all associated parts.

Create the Earpiece Cuts

You will now use a section consisting of five holes (one at the center and the other four positioned evenly in a circle around it) to arrange the earpiece cuts as geometrically aligned holes.

1. Select Insert > Extrude, and select the flat area surrounding the lens cutout as the sketching plane. This way the holes will enter the shell at 90 degrees to the face, not to the plane of the curved surface they go through. Add the topmost edge of the cover as a reference line.
2. Next, place a horizontal centerline 0.40 below the referenced line. Use the Add Dimensions tool to dimension the centerline from the top reference.

Dimensioning the horizontal centerline

3. Place a circle to use as a construction line for the outer holes. Select the Circle tool, and center a circle where the vertical and horizontal references meet. Set the circle’s diameter at 0.12.

4. Select the circle and click Construction on the right mouse button shortcut menu to toggle it to a construction line.

5. Now define the cuts. Select the Circle tool again and draw a circle centered on the intersection of the vertical and horizontal axes. Middle-click to exit, and set the diameter of the circle to 0.04.

6. Click the Circle tool again and draw four more circles where the centerlines intersect the construction line circle. See the next figure. When the R constraint symbol appears, the radius of the new circle is the same as the radius of the center circle.
7. After the cuts are defined, accept the section. Click the Remove Material icon to create the cut. Set the depth to **Thru All**. Make sure the direction arrow points into the cover. Accept the feature.

**Create the Earpiece Holder and Shelf**

The earpiece holder is a thin extrusion. A thin extrusion is hollow, which precludes combining a solid and a cut to define a shape, for example, a cylinder. You give the thin extrusion a wall thickness value when you define the section.

Once again you are placing a feature through a surface that is not level, in this case, the curved upper surface of the cover. The solution is to extrude it down to the floor of the cover from an offset datum plane, as shown in the next figure. The depth setting of **Thru to Next** will make the collar conform to the surface when the two intersect.

You’ll create this datum when you are prompted to select the sketching plane. You could create the datum before you start the feature, but when you create it in the dashboard environment it “belongs” to the feature, and is grouped with the feature in the Model Tree.

You have already created a datum like this in the back cover, so use the following guidelines to add the new offset datum plane and create the earpiece holder section.

1. Select **Insert > Extrude**. Click **Insert > Model Datum > Plane** to create a datum to be used as the sketching plane. Use the upper surface of the shell for the offset reference and offset the new datum plane by $-0.10$ from the reference surface.
2. Zoom in on the ear hole pattern feature. Use the Concentric Circle tool to draw a circle. Select the center ear hole. Drag the new circle outward. It is concentric with the center ear hole. Set the circle diameter to 0.28. This will be the inside diameter. Accept the section.

3. Set up the thin extrusion:
   a. Set the depth to To Next.
   b. Make sure the direction arrow points from the datum toward the cover.
   c. Click the Thicken Sketch icon. Enter a value of 0.03. This is determines the wall thickness.
   d. Click the Direction icon (to the right of the value field) to be sure the sketch dimension is the inside diameter. The icon toggles the thickness to the inside of the section, the outside of the section, or the center of the section. Watch the preview as you toggle, the feature will be at its largest when the section is used as the inside diameter. Accept the feature.
The cut for the shelf in the earpiece holder is simply an extruded cut feature that uses the top surface of the holder as the sketching plane. The cut section is a concentric circle within the holder section, centered on the same axis as the holder.

1. Use the Concentric Circle tool in the Sketcher toolbar to create the cut with a diameter of 0.32 and a height of 0.05.

2. Create a round at the seam between the holder and the shell with a radius of 0.03.

Sketching the shelf cut
Make the Microphone Cut and Holder

Now, at the lower end of the shell, you’ll create features to house the microphone.

1. First, create the cut for the microphone hole. Select the floor surface of the shell as the sketching plane. Use the lowest edge of the cell phone shell as a reference.

2. Place a centerline along the Right datum, down the center of the shell. Draw one side of the slot. Use a tangent constraint between the arc and the straight edge. Mirror the sketch along the centerline, using the dimensions shown.

3. Complete the feature: remove material and check the direction. Set the depth to **Thru All**.

4. Accept the feature. Place a round (0.02) on the front edge of the slot.

**Cut feature section for the microphone hole**

![Diagram of microphone cut and holder](image)

Make the Microphone Housing

This is a rectangular, thin extrusion with a wall thickness of 0.03. It is also extruded down into the shell from an offset datum created on the fly as a sketching plane.

1. Create the datum plane in the same way as the earpiece holder, but offset it by -0.03 from the upper surface of the shell. After the datum plane is created, it automatically appears in the sketching plane collector.

2. Place a vertical centerline along the Right datum. Use the **References** dialog box to add one of the arcs of the cut as a horizontal reference, then snap a horizontal centerline through the center of the arc.

3. Use the Rectangle tool to create the section. Be sure you see the “> <” equidistant constraint symbols showing that the rectangle is bisected by the centerlines. Dimension as shown.
Sketching the microphone housing extrusion

4. Accept the section. Click the Thicken Sketch icon. Set the depth to Up to Next Surface. Toggle the extrusion direction until the section is at its largest. Set thickness to 0.03.

5. Accept the feature. Add a 0.01 round to the base of the protrusion.

Completed microphone housing

Add the Screw Posts and Holes

Now all that remains is to create the four screw posts. As shown in the next figure, a screw post comprises three features. The first feature is a simple round protrusion extruding down into the shell from a datum plane. Instead of adding a datum plane, use the Front datum plane for this feature.

Create two of these posts, upper and lower, as one feature, the same way that you did the posts in the back cover. Again, because the protrusion is flush with the edge of the shell, you can use the Front datum plane as the sketching plane.
The screwpost features: post, pin, and hole

1. Make the upper and lower posts as one feature on one side of the shell, the same way that you did the posts in the back cover. See the next figure for the section dimensions.

Overall dimensions for the posts section
2. Now sketch the pin feature, using the top surface of the post as the sketching plane. For this section, set the direction so the protrusion extrudes up from the top of the post.

   Use the Concentric Circle tool to draw the sections concentric with the existing posts. Remember to look for the “R” constraint symbol, showing you that the second pin you draw is the same radius as the first. Set the diameter at 0.125.

3. Set the direction outward, up from the sketching plane. Set the depth at 0.04. Accept the feature.

   *The “pins” extrude above the shell edge*

---

**Insert Holes**

1. Use the Hole tool to insert the coaxial holes in each post. The holes use the pin axis as the first reference and the pin surface as the second reference. They are standard M2.2X.45 holes with ISO threading. Screw depth is 0.21.

2. Accept the feature and add 0.02 rounds to the juncture between the posts and the shell.
Copy and Mirror the Posts

When the two posts are finished, select all the features they include, and use the Copy and Mirror procedure to add them to the opposite side of the Right datum plane, as you did for the back cover. Save and close the part.

*Post features ready to mirror*

Summary

All of the parts needed for the assembly exercises are now finished. Read the Introduction to Assembly in the next chapter and complete the exercises to create a new assembly file.
Assembling the Cell Phone

In this chapter, you will learn how to place the parts of the cell phone model into an assembly file. Assembly mode lets you assemble parts by locating them in reference to other parts, or to non-part objects like datum planes, datum points, or coordinate systems.

You’ll start assembling the cell phone parts by placing a “base component” into an empty assembly file. You will then use placement constraints to add each subsequent part and orient it to the base component. These constraints determine whether surfaces and edges are aligned, mated, or offset, and by what values or limits.

After you complete the assembly of the cell phone, you’ll learn some modification techniques to make changes to the model. You’ll see how the changes to your assembly are automatically passed back to the parts.

Assembly Constraints

Constraints in an assembly are similar to those used in Sketcher in that there must be enough of them to complete the placement of a part in relation to another part in 3D. You must establish references in two directions, define a surface or edge relationship (mate or align with an offset if required), and enter values for the references. When enough constraints are on a part in an assembly, the part is considered fully constrained. A part can be added to an assembly without it being fully constrained. In this case, the part is considered packaged.

You can interactively import, place, and constrain parts to build an assembly object by object. You can also use automatically determined placement constraints to speed up the process. The procedures on assembling the cell phone demonstrate both methods.

When you start a new assembly, you must first determine which part should be the base component. All of the subsequent components that you assemble reference this component either directly or indirectly. For this
reason you should always use a part that you are not likely to remove from the assembly. For this assembly, you’ll use the front cover as the base component.

Pro/ENGINEER provides many placement constraints to assemble your parts. You’ll see that the Automatic option selects only the best suited constraint for the particular situation. The constraints in the following table are accessible from the Component Placement dashboard:

<table>
<thead>
<tr>
<th>Constraint</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mate</td>
<td>Position two surfaces or datum planes so they face each other. Mate type may be <strong>Coincident</strong> or <strong>Offset</strong>. If the offset is set to <strong>Orient</strong>, the facing surfaces have a constantly varying offset.</td>
</tr>
<tr>
<td>Align</td>
<td>Make two surfaces or datum planes face the same direction, two axes coaxial, or two points coincident. Align may be set to <strong>Offset</strong> or <strong>Coincident</strong>. If the offset is set to <strong>Orient</strong>, the surfaces face the same direction with a constantly varying offset.</td>
</tr>
<tr>
<td>Insert</td>
<td>Insert one revolved surface into another revolved surface, making their respective axes coaxial.</td>
</tr>
<tr>
<td>Coord Sys</td>
<td>Make two datum coordinate systems coincident to each other.</td>
</tr>
<tr>
<td>Tangent</td>
<td>Control the contact of two surfaces at their point of tangency.</td>
</tr>
<tr>
<td>Pnt On Line</td>
<td>Control the contact of an edge, axis, or datum curve with a point.</td>
</tr>
<tr>
<td>Pnt On Srf</td>
<td>Constrain two surfaces to mate so that a datum point on one surface is in contact with the other surface.</td>
</tr>
<tr>
<td>Edge On Srf</td>
<td>Constrain an edge to contact a surface.</td>
</tr>
<tr>
<td>Angle</td>
<td>Fix the rotation of the aligned axes or edges.</td>
</tr>
</tbody>
</table>
Place the Base Component

The first step in creating an assembly is importing a base component and automatically aligning its part coordinate system with the assembly’s coordinate system.


2. Select Assembly under Type and enter a name for the assembly. Use the default template.

3. Click OK. The Pro/ENGINEER main window opens and displays the default assembly datum planes, all marked with the prefix ASM_.

4. Click Insert > Component > Assemble on the main menu. The Open dialog box opens.

5. Select front_cover.prt. The front cover of the cell phone model appears and the Component Placement dashboard appears.

6. Click the Default constraint set from the Automatic constraint set list to assemble the front cover in the default constraint position. This constraint aligns the part coordinate system with the assembly coordinate system. You will see the part’s Front, Right, and Top part datum planes align with their respective assembly datum planes. The STATUS line indicates that the base component is fully constrained.

7. Accept and save the assembly.
Assemble Components to the Base Component

With the base component in place, you can start adding the other parts to the assembly. When you select a reference from the assembly and a reference from the part being assembled, Pro/ENGINEER automatically selects a constraint type appropriate to the specified pair of references. How the parts are oriented relative to each other is also considered.

Lens Part

In this procedure you’ll learn how to add the lens part to the assembly using automatically assigned placement constraints.

1. Click **Insert > Component > Assemble.** Select `lens.prt` in the directory and click **Open.** The lens appears next to the base component.

2. Click the Separate Window icon next to the STATUS line in the dashboard. The part is magnified and appears in its own window to improve surface selection. All zoom and pan controls work within the separate window.

3. Select the bottom surface of the lens. An arrow appears in the lens window indicating an automatic placement constraint. In the dashboard, click the Placement panel to open it. The lens surface is listed as the component reference, and the assembly reference collector highlights in yellow.

4. Select the surface in the cutout on which the lens will sit. The cutout is listed as the assembly reference in the Placement panel. If a **Mate** constraint is not automatically assigned, choose **Mate** in the Constraint Type list to change it. Part status is Partially Constrained.

First reference set for the lens

![Diagram showing lens bottom surface and cutout surface]
5. Click **New Constraint** in the Placement panel for the next reference set, and then choose **Insert** from the **Constraint Type** list. Zoom in to select the bottom edge surface of the lens as the component reference and the bottom surface of the front cover cutout as the assembly reference. The lens is inserted in the cutout area and placement status is Fully Constrained. Click OK and save the assembly.

*Second reference set for the lens*

*Lens fully constrained to the front cover*
Earpiece Part

In this procedure, you will assemble the earpiece to the front cover. The Automatic placement option selects Insert and Mate constraints that were introduced during the lens assembly procedure. This time, you must rotate the cell phone from the default view to select areas inside of the cell phone cover. Use View > View Manager to save a view of the cell phone positioned with the earpiece housing exposed. You can easily return to the same saved view to assemble the microphone to the front cover.

Complete the following steps to assemble the earpiece to the base component:

1. Click Insert > Component > Assemble. Select earpiece.prt in the directory and then click Open. The earpiece appears next to the base component and the Component Placement dashboard appears.

2. Select the front surface of the earpiece. The Placement panel shows the earpiece surface as the component reference.

3. Next, rotate the cover and select the shelf of the earpiece housing. The Constraint Type should be Mate and the offset set to 0.

4. For the second constraint, select the side surface of the earpiece. Select the inside wall of the earpiece housing to which the earpiece will mate as the assembly reference. The Constraint Type should be Insert. The earpiece is placed in the housing and placement status is Fully Constrained.

5. Accept and save the assembly.
Microphone Part

Assembling the microphone part requires three reference sets and three constraints.

1. Using the same procedure as you did with previous parts, bring in the microphone part. The microphone appears alongside the base component and the Component Placement dashboard appears.

2. Select the front surface of the microphone for the component reference.

3. Select the floor surface of the microphone housing on the front cover for the assembly reference. **Mate** is automatically selected as the Constraint Type. Placement status is Partially Constrained.
4. For the next constraint, select one of the long sides of the microphone as the component reference, then select the corresponding microphone housing wall on the front cover for the assembly reference. Constraint Type should be **Mate**. Placement status is still Partially Constrained. An additional placement constraint is required.

5. Select one of the short sides of the microphone as the component reference, then select the corresponding microphone housing wall for the assembly reference. Constraint Type should be **Mate**. Make sure **Coincident** is selected as the Offset type. The microphone assembles into its housing, and placement status is Fully Constrained.

6. Accept and save the assembly.
Third reference set for the microphone

Microphone fully constrained to the front cover
PC Board Part

You will use Align and Insert constraints to assemble the PC board to the base component. The front surface of the PC board aligns with the post shelf and with the Right datum planes. The posts on the front cover are then inserted into the PC board’s holes to fully constrain the part.

1. Click Insert > Component > Assemble to import pc_board.prt, as you did with the previous parts.

2. Select the front of the PC board surface (with the datum curve) for the first component reference.

3. Select the shelf located around one of the screw posts on the front cover for the assembly reference. Make sure the Constraint Type is Align.

First reference set for the PC board

4. Now select the Right datum planes on both the PC board and the front cover for the references for the next constraint. The Constraint Type should be Align.

5. For the last constraint, select the outside cylindrical area of one screw post, and then the inside of the corresponding hole on the PC board. The Constraint Type should be Insert. Placement status is Fully Constrained.

6. Accept and save the assembly.
Third reference set for the PC board

Outside cylindrical area

Inside of the corresponding hole

PC board fully constrained to the front cover
Keypad Part

The keypad is the only part that is not assembled directly to the base component. In this procedure, you’ll learn how to hide the front cover so selections on the PC board are easier to make. Next, you’ll assemble the keypad to the board.

When you add a component to an assembly, you may not know where that part fits best, or you might not want to locate it relative to other geometry. You can leave such a component either partially constrained or unconstrained. An unconstrained component is called a *packaged component*.

In this procedure, you’ll assemble the component, and then close the Component Placement dashboard before the component is fully constrained. The keypad will remain packaged while you create a new assembly datum on the fly to use as a constraint reference. You’ll then use the **Edit Definition** command to fully constrain the part.

Finally, you’ll use the **Unhide** command to replace the front cover and create a cutout for the keypad buttons.

### Assemble the Keypad

1. Select `front_cover.prt` from the Model Tree. Right-click and select **Hide** from the shortcut menu. The cover is now hidden.

2. Bring in `keypad.prt` to assemble to the PC board.

3. Select the PC board surface between the datum curve boundaries for the assembly reference. Now select the back surface of the keypad for the component reference. The Constraint Type is **Mate** and Placement Status is Partially Constrained.

---

*First reference set for the keypad*

---
4. For the next constraint reference set, select the Right datum planes on the PC board and the keypad. Make sure the Constraint Type is Align and Offset is Coincident. Placement status is Partially Constrained.

5. Click the Check icon to package the assembly and close the Component Placement dashboard. In the Model Tree, a hollow rectangle indicates that the keypad part is a packaged component.

Create a Datum Plane for the PC Board Part

A reference surface is required when setting up the final constraint.

1. Right-click `pc_board.prt` in the Model Tree and then choose Activate from the shortcut menu.

2. Select Insert > Model Datum > Plane. Select the top of the datum curve (closest to the lens cutout on the PC board) for the first reference. The first datum plane reference name and Through constraint appears in the Datum Plane dialog box.

   ![Partially constrained keypad](image)

   Top of datum curve

3. For the second datum plane reference, hold down Ctrl and select the top surface of the PC board. The second datum plane reference name and default constraint appears in the dialog box.

4. Because you want the datum plane perpendicular to the PC board surface, select the second datum plane reference name in the Datum Plane dialog box and choose Normal from the list, and then click OK.
Add the Final Assembly Constraint

1. In the Model Tree, right-click the assembly and choose *Activate* from the shortcut menu. Right-click `keypad.prt` and choose *Edit Definition* from the shortcut menu. The Component Placement dashboard appears. Click *New Constraint* in the Placement panel to add the final constraint.

2. Select the newly-created datum plane on the PC board, and then the top edge of the keypad. Click *OK*. Make sure the Constraint Type is *Align* and Placement Status is Fully Constrained, then click the Check icon and save the assembly.

*Third reference set for the keypad*

*Keypad fully constrained to the PC board*
Front Cover Part

Now that the keypad is fully constrained to the PC board, you can unhide the front cover. An interference occurs after you unhide the front cover, because the height of the keyboard’s buttons exceeds the cell phone cover thickness. Although the buttons appear to protrude through the front cover, you must cut out the keypad button holes. Using the assembly to cut the holes lets you modify the front cover using the dimensions of the keypad, without opening either part. The holes will be passed back to the cover part as an assembly feature.

Right-click \texttt{front\_cover.prt} from the Model Tree and choose \textbf{Unhide} from the shortcut menu.

1. Click \textbf{Edit} > \textbf{Component Operations} > \textbf{Cut Out}.
2. Select the front cover as the part from which to cut out and then click \textbf{OK}.
3. Select the keypad as the design reference for the cutout and then click \textbf{OK}.
4. In the Options menu, click \textbf{Reference} and then \textbf{Done/Return}. The cutout of holes for the keypad buttons is completed.

\textbf{Move the Keypad to Confirm the Cutouts}

Use \textbf{Edit Definition} to move the keypad away from the assembly and confirm that the cutouts have been made.

1. Right-click \texttt{keypad.prt} in the Model Tree and click \textbf{Edit Definition} from the shortcut menu.
2. In the Placement panel, select the last \textbf{Align} constraint and clear the \textbf{Constraint Enabled} check box.
3. Open the Move panel. Make sure \textbf{Translate} is selected in the Motion Type list and \textbf{Relative in View Plane} is selected. Click on the keypad to slide it away from the assembly.
4. To replace the keypad, recheck the \textbf{Constraint Enabled} check box and click \textbf{OK}.
Back Cover Part

In this procedure, you’ll assemble the back cover to the front cover. Because you must select multiple datum planes in this process, click the Settings button on the Model Tree to show the datums so they can be easily located and selected.

1. Click the Settings button above the Model Tree, and then select Tree Filters. The Model Tree Items dialog box opens.

2. Select the Features check box on the Display list, then click OK. All the part features are listed along with the part in the Model Tree.

3. Use Insert > Component > Assemble to bring in back_cover.prt to the cell phone assembly. The Component Placement dashboard appears.

4. Select the Right assembly and back cover datums from the Model Tree as the first Align Coincident constraint set.

5. Continue to add constraint sets to match the assembly Front and Top datums to their respective part datums until Placement Status is Fully Constrained.

6. Click the Check icon. Save the assembly.
Antenna Part

The last part to be assembled is the antenna. It is inserted into the hole on the back cover.

1. Bring in antenna.prt to the cell phone assembly.
2. Select the bottom surface of the antenna tip as the component reference and the top surface of the antenna brace as the assembly reference. Make sure the Constraint Type is **Mate Coincident**.

*First reference set for the antenna*

3. For the next constraint, select the datum axis for both the antenna and hole into which the antenna will be inserted. An **Align** constraint is chosen automatically. Placement Status is Fully Constrained.

4. The cell phone is now completely assembled. Click the Check icon and save the assembly.

*Second reference set for the antenna*
Create an Exploded View of the Assembly

An exploded view displays part relationships in an assembly. Exploded views do not affect assembly constraints or final part positioning. When a model is exploded, the parts are separated on a random basis and may need to be rearranged. Use View > Explode > Edit Position to change the exploded view.

1. Open the completely assembled cell phone model file.

2. Click View > Explode > Explode View. The assembly explodes to default positions.

Modifying the Exploded Component Positions

To move the exploded components to new default positions, complete the following steps:

1. Click View > View Manager. The View Manager dialog box opens.

2. Click the Explode tab, the Properties button, and then the Edit Position icon. The Explode Position dialog box opens.

3. Select Plane Normal from the Motion Reference list.

The Explode Position dialog box

![Explode Position dialog box]
Note
A surface or a datum plane is used to specify a motion reference when placing components. In the *Explode Position* dialog box, the **Motion References** options restrict component movement in various ways, while the **View Plane** option allows components to move freely within the display area.

4. Select a plane on your cell phone model to use as the motion reference, and then select a component to move on the exploded assembly model.

5. Use the mouse to move and place the component. Middle-click to cancel the movement operation. Repeat to move other components.

6. To save the new explode state, click the **List** button, and then the **Edit** tab. Choose **Save** from the list and close the View Manager.

7. In the View Manager, click the Explode/Unexplode icon to return to the assembled view. Close the View Manager.

*Exploded and unexploded views of the assembly*
Modify the Assembly

Now that the model is assembled, you may want to modify some or all of its features. You can make changes from within Assembly mode instead of entering Part mode for each of the components.

This section describes ways to make changes to your design from the assembly level. You can create, delete, suppress, and modify part features from Assembly mode. When you modify a component in Assembly mode, the changes automatically update in Part and Drawing modes.

Redefine Assembly Placement Constraints

Now you can modify placement constraints for the antenna so it extends further from the cell phone body.

1. Right-click antenna.prt from the Model Tree and choose Edit Definition from the shortcut menu.

2. Enter 2.0 for the Mate offset value. The antenna is extended. Accept the change.

Suppress and Resume Parts

Suppressed parts in an assembly behave just like suppressed features in a part. Parts that are suppressed are temporarily removed from an assembly, but they can be returned to the model with the Resume command.

Features may be suppressed to save time and memory when working with large assemblies, improve regeneration and display time, or to try out different design iterations.

Note
Click the Settings button above the Model Tree, and then click Tree Filters. The Model Tree Items dialog box opens. Select the Suppressed Objects check box on the Display list, and then click OK. All suppressed items are now displayed in the Model Tree. Once the parts are displayed, they can be selected and resumed.
Modify Part Dimension Values

You can modify assembly or part dimension values from within the assembly. In this procedure you modify the dimension of the antenna tip.

1. Right-click antenna.prt on the Model Tree, choose Activate from the shortcut menu, and then double-click the antenna tip. The dimension values are displayed on the model.

2. Double-click the dimension value to be modified (0.50). Enter a new value of 1.0 and then press Enter.

3. Click \[ \text{Reset} \] or Edit > Regenerate. The antenna tip reflects the changed dimension.

Antenna tip: before and after modification

Summary

With the assembly complete, you can make the drawings for manufacturing. Pro/ENGINEER creates dimensioned drawings using the dimensions that have already been entered in the first two phases of designing the cell phone. The dimensions are viewed selectively as needed.
This chapter shows you how to bring the cell phone models and the assembly you’ve created into the Pro/ENGINEER Drawing mode to create a drawing. A mechanical drawing consists of specifically oriented representations of the object being drawn. Each of these representations is called a view. There are several types of views, each drawn and dimensioned to show a certain kind or amount of detail.

In this exercise you’ll learn how to add an assembly drawing to a bill of materials using the table function. On subsequent sheets you’ll add a few of the more widely used view types to detail some of the parts. The object of these exercises is not to create a full drawing of all eight parts. Instead you are introduced to the basic workflow of the process of creating drawings.

First, review the information on dimensions and views in the next section, then follow the exercises to create the drawing files.
Understanding Dimensions and Associativity

Applying dimensions to drawing views in Pro/ENGINEER uses a different process from that of other programs. The difference is the Pro/ENGINEER associativity factor—instead of using the drafting program to add a dimension to a view where you need it, you choose to selectively show a dimension that has already been passed, along with the view, from the 3D model. This dimension is actively linked to the 3D model. As a result, you can directly edit the 3D model through the dimension in the drawing. When shown in the drawing, these dimensions are called *driving* dimensions, because they can be used to drive the shape of the model through the drawing.

Of course, there will be instances where you need additional dimensions to show the same value for the same object, for example, a view repeated on another drawing sheet. To add these, use the **Dimensions** commands from the **Insert** menu. These inserted dimensions are called added or *driven* dimensions, because their association is only one-way, from the model to the drawing. If dimensions are changed in the model, all edited dimension values and the drawing are updated.

Displaying passed dimensions rather than adding them means your drawing will not be overdimensioned and there won’t be any conflicting values on different drawing sheets for the same objects. Once driving dimensions are shown, they can be hidden. They are never permanently deleted.

The nature of driving dimensions has consequences that a drafter must bear in mind when making drawings in Pro/ENGINEER:

- Only one driving dimension for each model dimension may exist in a drawing. A drawing may have several views of the same object, but only one driving dimension for each feature of the model can be displayed. This is to avoid overdimensioning the drawing and to avoid editing a driving dimension on one sheet but not another. You can move a driving dimension from one view to another, for example, from a general view to a detailed view where it is more appropriate. To provide dimensioning for views when driving dimensions are "used up" in other views, you use added driven dimensions.

- It is possible to unintentionally edit the model. If a driving dimension is edited, it turns white as a warning that there is a discrepancy between the drawing and the model. When you regenerate the model, the drawing accepts the new dimension. The link between model and drawing can be broken when configuration options have been set to do this, but this is not recommended.
Detail Items

Dimensions are the most important detail items passed from the 3D model, but they are not the only items available or necessary to detail a drawing. In the same way you show or hide dimensions, you can show notes, surface symbols, geometric tolerances, datum planes, and axes.

Adding Models vs. Adding Views

Before you can add a view of a model file to a drawing, the model file must be associated with the drawing file. This is called “adding the model,” not to be confused with adding a view. You can associate any number of models with the drawing, but only one model can be actively worked on at a time. The active model is the one ready to have views created for it. The active model name appears in the lower-left corner of the work area.

You add the first model when you create the new file, during the new file setup. Click File > Properties and then Drawing Models > Dwg Models > Add Model on the Menu Manager to add.

If you are working with an assembly, you can use the shortcut menu to add and activate any of the parts from the Model Tree.
Placing General Views and Projection Views

The first view you place will be a type called a general view. You can regard a general view as a parent view because its orientation and scale can be adjusted, and these properties determine the look of any projected views derived from it.

Projections (projected views) are views derived from the general view, which show alternate faces of the general view. Using projections you can quickly dimension every surface of a 3D object without repeating a dimension. Each projection view exists in either a horizontal or vertical projection channel to the right, left, above, or below the general view. Projection views are automatically aligned with the general view within their projection channels. By default, they can only be moved within the channels they occupy.

General view (center) and four projections

Note

Although alignment with the general view is the usual way to show projection views, you are not limited to this method. Double-click a projection view. The Drawing Views dialog box opens. Select Alignment and uncheck the Align this view to other view checkbox to unalign the selected projection view and place it anywhere on the drawing sheet.

Creating Detailed Views

A detailed view shows a small area of another view at a larger scale. The process puts a boundary and note around the detailed area on the parent view and creates the new detailed view to a new scale. You can add driven dimensions, or use the shortcut command Switch View to move a driving dimension from the parent view to the detail view.
Scaling Drawings and Views

Pro/ENGINEER automatically determines a scale for a new view based on the sheet size and the size of the model being placed. This scale value appears in the lower-left corner of the screen. To reset the scale, click Edit > Value, then click the scale readout and edit the value in the prompt line. (A value of 1 means the scale is one-to-one with the actual dimensions, a value of .25 means the drawing is scaled to one-quarter the actual dimensions.)

Note

If necessary, use the default_draw_scale configuration option to force a global default scale.

Only two view types may be scaled independently of the default scale setting: the general view and the detailed view. When you rescale a general view, its projections also rescale. Because a detailed view is an enlargement of a small area, you can scale a detailed view independently of its parent view as well as independently of the default scale.

When you place a general view, you choose Scale or No Scale as part of the view properties setup in the Menu Manager. If the view is placed as No Scale (the default) and you later want to change the scale, you must first modify the view type. If your drawing references several parts, you can set the scale independently for each part added to the drawing.

In other words, a default scale is set for each model added to the drawing. The scale readout in the lower-left corner refers to the active model. Any modifications values for scale, relations, and so forth, are applied to the active model.
Using Formats and Templates

Format files contain the collections of lines and text that border a drawing sheet. These serve to divide the sheet into sections and state the company name, design name, and so forth. When you associate a format file with a new drawing file, the format graphics appear on all sheets created in the drawing file. You can also change the format attached to a drawing file after the file has been created and saved.

There is a default format for each standard sheet size, installed in a default format directory. To customize a format, save a default format as a new format file, and then add text in the form of notes or graphics, such as a company logo.

Templates are a more advanced concept in Pro/ENGINEER. Templates contain all the format information and instructions on how to lay out views and projections automatically, as well as how to create tables and bills of materials. Templates are a powerful functionality that can save hours of interactive work on drawings that follow a standard flow. You may use templates in the course of creating drawings eventually, but this exercise will explain the more basic drawing functions.

Creating a New Drawing File

The finished drawing will have an exploded view of the assembly on the first page, with a bill of materials and BOM balloons calling out the parts. However, because these are the more complex elements of the drawing, you’ll add them last. First you’ll add a view of the antenna part to the drawing. Later in the tutorial you’ll add the assembly view and the BOM.

Start the new drawing file:

1. Click File > New and select Drawing from the New dialog box. Enter a name for the drawing and clear the Use default template check box. Click OK. The New Drawing dialog box opens.

2. In the Default Model field, use the Browse button to enter the antenna part file.

3. In Specify Template, click Empty with Format. Click the Browse button to go to the default system formats directory. (This is usually part of the default installation setup for Pro/ENGINEER).

4. Select the C size sheet (c.frm) and click Open, and then click OK in the New Drawing dialog box. A new blank sheet opens, with the format outlines.
Now you will add a general view and a projection to the sheet, orient the view, change the view’s properties and show dimensions.

1. Click **Insert > Drawing View > General**. You are prompted to select a center point for the drawing view. Click the center-right area of the sheet.

2. The view is placed and the **Drawing View** dialog box opens, showing all the saved 3D orientations. In the dialog box, under **Model View Names**, select **Front** from the list. Click **Apply**.

3. Under **Orientation Method**, select **Angles**. Enter 270 for the angle value and click **Apply**. The view reorients to the horizontal, with the tip pointing to the right. Click **OK** in the dialog box to close it.

**Modify the view**

When you placed the view, you accepted the default attributes for the view type. Now modify the view for a custom scale.

1. Right-click the view and click **Properties** from the shortcut menu.

2. Click **Scale** from the **Categories** list, and then choose **Custom Scale**. Enter 3.5, and then click **Apply** and **Close**. The view is drawn to the new scale.

3. Select the view again, right-click and uncheck **Lock View Movement** in the shortcut menu. Use the mouse to move the view to a new position. When the view is placed, check **Lock View Movement**. This setting applies to all of the views on the sheet, not only the selected view.

Now you’ll add the projection view to show the shaft and tip outer diameters.

1. Click **Insert > Drawing View > Projection**. Click in the space directly to the left of the general view. The projection view is added as shown in the next figure.

2. Make sure that your display is set to **No Hidden** to show only the outer diameter and shaft diameter of the tip. When you change display properties, click the Repaint icon to refresh the display.

*General view and one projection*
Add the Detailed View

Now you’ll add the detailed view. This involves a series of prompts that define the elements shown in the following figure.

Elements of a detailed view

1. Click **Insert > Drawing View > Detailed**. Click along the outline of the tip in the general view. At the spline prompt, use the mouse to click-draw a circle to enclose the detail to be enlarged. Middle-click when the circle is almost complete. A circle is added around the tip.

2. Define the note and leader location by clicking anywhere near the circle. The note is added at the selected point (it can be dragged to another position at any time).

3. Click in the upper middle of the sheet, and the detailed view is added. Drag it in any direction to redefine its position.

4. Right-click the detailed view, and then choose **Properties** from the shortcut menu. Choose **Scale** from the **Categories** list and enter a value of 9 for the custom scale, and then click **OK**.

Sketching the outline for the detailed view
Show Dimensions

There are several ways to show or hide dimensions passed from the 3D model. You can access the commands from the main **Show/Erase** dialog box or from the shortcut menu when you select either a feature or a model in the Model Tree. In this step you’ll use the **Show/Erase** dialog box. In subsequent steps you’ll use other methods.

1. To start, click **View > Show and Erase**. The **Show/Erase** dialog box opens.

**Show / Erase dialog box**

The **Show/Erase** dialog box controls the display of all information objects that can be passed from the 3D model. The **Show By** area lets you selectively show dimensions feature by feature or view by view, an ability you’ll find useful when drawings get complex. The **Options** tab is used to filter showing between **Erased** and **Never Shown**. You may have erased some dimensions on one view with the intention of showing them in another. The **Erased** command lets you show only those you erased.

2. To start showing dimensions, click the Dimensions icon in the **Type** area in the upper-left corner.

3. Click **View** in the **Show By** area.

4. Click the detailed view on the sheet. The passed dimensions are now shown on that view.
In the Show/Erase dialog box, the Preview tab activates. You can select certain dimensions to keep or to remove before you close the dialog box. (Remember, these dimensions are never really removed. They are only hidden.) By default the Sel to Remove button is active.

**Note**
The actual position of the dimensions in your file may vary from the illustration, but the same dimensions should be showing.

At this point, if the dimensions don’t look as organized on the page as you’d like, don’t worry. First you’ll work on uncluttering the detail view by moving some of the dimensions to more appropriate views. Then, you’ll select and drag the dimensions to their final plotted positions.

**Tip detailed view after showing dimensions**

5. The two diameter dimensions could be better shown on the end projection view of the shaft. Hold down the Ctrl key and click them both to select them for removal. When they are selected, middle-click to complete the selection. They are both erased. Now, you’ll show them on the end projection view.

6. Click the Options tab in the Show/Erase dialog box. Leave the Show By setting on View, and select the Erased checkbox. Zoom out so you can see the whole sheet. Click the end projection view. The two dimensions are added to the view. Middle-click to complete. Make sure the Never Shown and the Switch to Ordinate boxes are cleared. Close the Show/Erase dialog box.
Return to the detailed view of the tip. As you can see, the length dimension of the shaft would also be better on the general view. Transfer it as follows:

1. Select the dimension, then right-click and choose **Move Item to View** from the shortcut menu.
2. Now click the general view. The dimension is transferred. This is a quick way to move shown dimensions from one view to another.

### Insert Added Dimensions

Finally, before you clean up the layout of the dimensions, you will add a reference dimension. This dimension will call out a length that is not passed with the 3D antenna: its overall length, the shaft plus the tip. The reference dimension will have the suffix `REF` to show that it is not a driving dimension.

1. From the main menu click **Insert > Reference Dimension > New References**. The cursor changes to a pencil shape.
2. Click the line representing the end of the tip, and then click the end of the shaft. (You can zoom and pan without losing your selection.) Middle-click to finish. The dimension is added with the `.REF` suffix.

### Clean Up the Dimensions

Now you’re ready to arrange the dimensions as you want to print them. Review the techniques below, and then try to place each dimension on the tip detail view so it matches the finished illustration. This is not an exhaustive review of all the edits you can make to dimensions, but it does cover the basic concepts.

A selected dimension is highlighted and surrounded by drag handles that you use to drag it from one spot to another. You must move the cursor over each handle to see the direction of movement possible:

- A four-sided cross cursor means you can drag the dimension in any direction.
- A two-way arrow shows that you can drag on one plane.

When you select a dimension and drag it into position, the leader and witness lines follow with it. You will probably have to zoom in to properly pick a drag direction.
Dimension drag handles

Use drag handles to move a selected dimension

Edit Witness Lines and Arrows

You can edit witness lines the same way you edit dimensions: by selecting them and using drag handles located at either end. You can lengthen or shorten dimension lines or skew them away from their default angles. You can also use the shortcut menu to create breaks in them where they must cross other lines or leaders, and to create jogs in the witness lines to widen the dimension area.

To edit arrows, select the dimension and use the shortcut menu commands. You can change the style of the arrowheads or reverse their position on the witness line.

The next figure shows a solution for the tip dimension. Use the right mouse button shortcut commands to make the changes indicated.

One solution for detailing the tip view
Finishing Sheet One

Now you’ll return to the first sheet, and see how to place an exploded view of the cell phone assembly. Follow the guidelines below to create an exploded assembly view on a new sheet, create a bill of materials, and show the BOM balloons.

Create an Exploded Assembly View

Click Insert > Sheet. A new sheet is added, and listed in the lower right corner as 2 of 2. Click Edit > Move Sheet. In the dialog box, select Insert at Beginning and click OK. The new sheet is now Sheet One. Now you’ll add the assembly file to the drawing models.

1. Right-click the new sheet and choose Properties from the shortcut menu. The Menu Manager opens. Click Drawing Models > Add Model. Use the browser to choose the assembly file.

2. Right-click and select Insert > General View.

3. Choose DEFAULT ALL in the Select Presentation dialog box. Click the sheet, and then OK to place the view.
General view of the exploded assembly

Create a Bill of Materials

In this sequence you’ll see how to add a very basic bill of materials to the drawing. A bill of materials is the most common use of a report table in Pro/ENGINEER. The report table “reads” parameters you enter as text into the cells and automatically adds cells in additional rows to accommodate information returned from the design database.

Setting up a report table can be a complex process, but once defined you can save and reuse report tables on other drawings. This exercise demonstrates as simply as possible how report tables work in Pro/ENGINEER.

Create the Table

A table is a series of cells of a given height and width. You can enter "dumb" text into the cells, for example as a column heading. The first step in creating the BOM is to define the table.

1. Click Table > Insert > Table. You are prompted to locate the upper-left corner of the table. Click at a point where the upper-left corner would be on the sheet. A scale of numbers appears horizontally from the clicked point.
2. Click around the number 5 or 6. The width of the first column is defined, and the scale moves to the right.

3. Click the scale again to define another column width about twice as long. When you have defined this column, click the middle mouse button. The horizontal scale is replaced with a descending horizontal scale. Now you’ll define the number of rows.

4. You’ll need two rows to start, one for the column headings and one for the parameters. Click twice down the scale to create the two rows and middle-click to complete the cells. The table should look like this.

Note
You can always resize cells after you create them but in this case, as you practice, it may be easier to delete the table and start again.

Enter Text Headings
Now you’ll enter the headings for each column.

1. Double click the upper-left cell. The Note Properties dialog box opens. Use it to type Index in the text area and click OK.
2. In the same way, insert the heading Part Name in the next column. The table should look like this:

<table>
<thead>
<tr>
<th>Index</th>
<th>Part Name</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>

You created some table cells, and entered simple text into two of them. To adjust the cell size, right-click the cell and choose **Height and Width** from the shortcut menu.

Now you will set up the remaining cells to expand with information. To do this, you first designate the empty cells as repeat regions, or cells that will expand automatically to create the finished table. You then "build" the parameters you want to enter by selecting text strings from a hierarchical menu.

**Define a Repeat Region**

1. Click **Table > Repeat Region.** The Menu Manager opens.
2. Click **Add.** You are prompted to select the corners of the region.
3. Click the lower-left cell, then the lower-right cell. Both cells are highlighted. Click **OK,** then **Done** on the Menu Manager.

Now you are ready to enter the parameters for the assembly index number and matching part name.

**Add BOM Parameters**

1. Double-click the left side cell of the repeat region. Because it is now a repeat region, the **Report Symbol** menu opens by default. These are the top-level prefixes, denoting the modules for which reports may be generated. This menu lets you assemble a report parameter string by “punching down” through eligible parameters.

2. Click **rpt...,** then **index.** The cell now contains the heading **rpt. index.** Now double-click the lower-right cell and then **asm. > mbr. > name** on the **Report Symbol** menu. The assembly member name parameter you have just created is entered into the cell.

3. Click **Table > Repeat Region > Update Tables > Done.** The table is expanded to show the information as defined by the parameters.
Show BOM Balloons

BOM balloons are the finishing touch to the first sheet. First you’ll assign an existing repeat region as a BOM balloon region. Then all you need to do is choose to show the balloons, and arrange them as you want them.

1. Click Table > BOM Balloons. In the Menu Manager, choose Set Region. You are prompted to select a region in the table. Because the table has only one region, click anywhere in the table to select the region. Once the region has been selected, the rest of the Menu Manager items are available.

2. Now click Create Balloon on the Menu Manager under BOM BALLOONS. You are prompted to select the view in which to show them. Click the general view, and then Done on the Menu Manager. The BOM balloons are added to the view.

3. You can right-click the view and choose Cleanup BOM Balloons from the shortcut menu to modify the positions of all balloons. To fine-tune the layout, select and drag each balloon separately to a new location, or right-click a specific balloon and choose Edit Attachment to select a new attachment edge on the object.

Exploded view with BOM balloons
Getting Productive

Working with a model or assembly comprised of thousands of separate objects and properties can quickly become overwhelming. Pro/ENGINEER uses several functions and strategies to sort, select, and control the display of database objects. This chapter covers several tools used on a regular basis: layers, family tables, and configuration options.

Using Layers

Layers let you organize features, datum planes, parts (in an assembly), and even other layers, so you can perform operations on those items collectively. The primary use of layers is showing, hiding (blanking), or suppressing the items on a selected layer. You can also delete and reorder features by layer.

You can create as many layers as you need and associate items with more than one layer. For example, you could associate an axis common to several features with several layers.

The Layer Tree

Use the Layer Tree in the Navigation window to control layers, their associated items, and their display status. Click Show > Layer Tree to open the Layer Tree window. The window shows a tree of all layers, and each item associated with the layers. (You may have to click Settings > Layer Items to show the associated items.)

Use the Layer Tree to:

- Create, delete, and rename layers.
- Copy all items of one layer to a different layer, using the right mouse button shortcut commands for selected items.
• Add items to a layer, remove items from a layer, and switch items from one layer to another.

• View and change the display status of layers.

• Define global default layers.

• Define local (model specific) layers.

Layer Tree in the Navigator window

Using Family Tables

Family tables are collections of parts (or assemblies or features) that are basically similar, but have slight differences in one or two aspects, such as size or detail features. Using Family Tables saves time when creating multiple parts that are similar except for one or two variations.

With a model displayed, click Tools > Family Table to access the Family Table dialog box. You can store a generic set of features from an existing part and create new parts based on dimension variations. A set of screws of the same shaft diameter but different lengths is a good example. You create the head, shaft and thread features for one screw, and add it as a row on a family table. You then add five copies of the row to the table and change the length dimension cell for each one. Whenever you need to create a screw part of a certain size, you can create the entire part from its row on the family table.
When a part is used as a basis for a family table, it is known as the *generic part* or the *generic instance*. When a part associated with a family table is opened, you are prompted for the family table member name.

Family tables promote the use of standardized components. They let you represent your actual part inventory in Pro/ENGINEER. In addition, families make it easy to interchange parts and subassemblies in an assembly, because instances from the same family are automatically interchangeable with each other.

### Managing the Pro/ENGINEER Environment

You can manage the Pro/ENGINEER environment with configuration files, macros, and mapkeys. These and other techniques help improve proficiency and system performance.

### Configuration Options

Startup and default settings for most Pro/ENGINEER configurable functions are determined by the content of configuration files. Each setting is called a configuration option. The two most important configuration files are named `config.pro` and `config.win`. 

`config.pro` is a text file that stores all of the settings that define the way in which Pro/ENGINEER handles modeling and assembly operations. The `config.win` file is a binary file that stores UI configuration settings, such as toolbar visibility and Model Tree location settings.

In the text based `config.pro` file, the setting for each option is determined by a value following the option as a line in the file, for example:

```
model_grid_spacing 1.500000
```

or

```
display_planes yes
```
There are hundreds of options built into Pro/ENGINEER. To manage or edit them, Click **Tools > Options**. You can search for particular options, filter the options shown, and sort the options either alphabetically or by functional group.

**Startup Search Sequence**

Like any networked or multiuser program, Pro/ENGINEER reads configuration files automatically from several areas depending on how the system is configured. At startup, Pro/ENGINEER first reads in a system configuration file called `config.sup`, which is a read-only file that a company system administrator uses to set company-wide configuration options. Any values that are set in this file cannot be overridden by other more local `config.pro` or `config.win` files.

After loading the `.sup` file, Pro/ENGINEER searches for and reads in configuration files (`config.pro` and `config.win`) from the following directories in the following order:

- **Pro/ENGINEER installation directory**—Your system administrator may have put configuration files in this location to support company standards for windows configuration settings, formats and libraries. Any user starting Pro/ENGINEER from this directory uses the values in this file.

- **Login directory**—The home directory for your login ID. Placing your configuration files here lets you start Pro/ENGINEER from any directory without having copies of the files in each directory.

- **Startup directory**—Your current or working directory when you start Pro/ENGINEER. These are the last to be read; therefore, they override any conflicting configuration file option entries. The `config.pro` file does not, however, override any `config.sup` entries. This is where you create and save custom configuration files to apply to specific projects.

**Changing Configuration Options**

In general, configuration file options should be set before starting a Pro/ENGINEER session. If you want to change the environment during the session, it is usually more convenient to use the **Environment** dialog box, which you open by clicking **Tools > Environment**. Some options, however, can be changed only through the configuration file. In this case, you can load a new configuration file with a different name and different configurations during the session. Use the following procedure to load a different `config.pro` file.

1. Click **Tools > Options**. The **Options** dialog box opens.
2. Browse to and select the configuration file you want to load, using the icons to the right of the **Showing** box. The file name you choose appears in the **Showing** box.

3. Click **OK** or **Apply**. Pro/ENGINEER is updated according to the new configuration file settings. If there are errors in the new configuration file, error messages appear in the startup window.

   **Note**
   Some configuration file changes, such as window size or the deletion of an option, cannot be incorporated during a working session.

**Using the Options Dialog Box**

Use the **Options** dialog box to:

- Load a different configuration file (the default is `config.pro`).
- Modify values for configuration options in `config.pro` and other config files.
- Display all configuration options or filter only those options that are off-default or loaded locally.
- Determine the source configuration file for each configuration option displayed.
- Save copies of configuration files with custom settings for current sessions.

The **Showing** list box displays the last `config.pro` file read, and the left pane shows the cumulative off-default settings which have been read from any `config.pro` files found in the search path while Pro/ENGINEER is loading. The value, status, and source are shown for each option. The status is either **applied** (●) or conflicting values (crosshatched dot). Conflicting values means that two configuration files have differing values for the same option. In this case the system default setting is used until you reset the value for the current session.

The source is defined as the configuration file and path that the option and value come from. You can use the list to show only the configuration options from each of the sources.

When **Current Session** is displayed in the **Showing** box, clear the **Show only options loaded from file** check box to show all options and values referenced during the current session. When the box is checked, only those options and values loaded from `config.pro` files are displayed.
Application Effective Icons

The icon to the left of each option indicates whether a change is applied immediately, or on the next startup. The lightning icon ☢️ means immediate effect. The wand icon 💭 means the change is applied to the next object created. The screen icon 📱 means the change is applied in the next session.

Editing Options and Values

When you make edits to options or values, the edits are saved to the file currently displayed in the Showing menu when you click Apply. If Current Session is displayed, the changes are saved to a file named current_session.pro, which is automatically created in the current working directory.

To edit a value, select it in the list window. The option appears in the Option text field. The value appears in the Value field. If the value is fixed, for example Yes or No, use the list box to select the choices for the option. If the value requires an integer, enter it.

To reset a value to the system default, select the value and click Delete. When the option and value are deleted, the system returns to referencing the default values.

Navigating the Options

Use the Sort box to sort the options alphabetically or by category.

Use the Find button to open the Find Option dialog box and search for options using a text string and wildcard characters. For example, if you type ecad in the Type keyword field, the dialog box lists all options using ecad in their strings. You can also use keywords and wildcard characters to search the descriptions. You can change values for the selected configuration options from within the Find Option dialog box.

Note

You must still click Apply in the Options dialog box to save changes to the session.

Searching for a Configuration Option

You can use the Find Option dialog box to search for configuration options by typing a keyword and wildcard characters.

- If you type the word size with no wildcard character, the search returns all of the configuration options that contain the word size. This is the most convenient way to find all options that contain a certain word.
• If you type a letter and an asterisk (*), the system lists all of the configuration options that begin with the letter.

**Macros and Mapkeys**

A *mapkey* is a macro you create to record frequently used command sequences to keyboard keys. You can create mapkeys for any task you perform frequently within Pro/ENGINEER. You can also add mapkeys as icons to a toolbar or menu bar. If you are a newer user, you can borrow mapkeys from coworkers without having to remember cryptic abbreviations.

You can also nest one mapkey within another, so that one mapkey initiates another. To do so, you include the mapkey name in the sequence of commands of the mapkey that you are defining.

**To Define a Mapkey**

1. Click **Tools > Mapkeys** from the menu bar or click the appropriate icon on the toolbar (use **Customize Screen** on the **Tools** menu to place buttons on the toolbar). The **Mapkeys** dialog box opens.

2. Click **New**. The **Record Mapkey** dialog box opens. Enter the key sequence that will execute the mapkey in the **Key Sequence** box.

   **Note**
   
   To use a function key, precede its name with a dollar sign ($). For example, to map to F3, type $F3.

3. Enter a name and a description in the appropriate text boxes. On the **Pro/E** tab, select one of the following options to specify how the system handles the prompts when running the mapkey:

   – **Record keyboard input**—(default) Record the keyboard input when defining the mapkey, and use it when running the macro.

   – **Accept system defaults**—Accept the system defaults when running the macro.

   – **Pause for keyboard input**—Pause for keyboard input when running the macro.

   **Note**
   
   When you create a new mapkey that includes actions that open and make selections from dialog boxes, the mapkey does not automatically pause for user input when it is run. You must select **Pause** for the mapkey to pause for user input when opening dialog boxes.

4. Click **Record** and start recording the macro by selecting menu commands in the appropriate order.
5. Click **Pause** as required so the mapkey will pause for user input. Enter the prompt text in the **Resume Prompt** dialog box, then click **Resume** and continue recording the mapkey. When you run the macro, the system pauses, displays the prompt you entered, and allows you to **Resume** or **Cancel**.

6. When you are finished recording the macro, enter a description and a label for it and click **Close**. An icon for the new mapkey is created automatically. The icon is placed in the **Commands** box under the **Mapkeys** category on the **Commands** tab of the **Customize** dialog box.

7. Click **Tools > Customize Screen** to open the **Customize** dialog box. Select the **Commands** tab, then the **Mapkeys** category. Drag the new mapkey icon from the **Commands** box onto the Pro/ENGINEER main toolbar. When you add the newly created mapkey icon to the toolbar, the label appears on the button added to the toolbar. When you move the cursor over the button, the description appears next to the cursor and in the message area.

---

**Improving System Performance**

As you become more experienced with Pro/ENGINEER and you create larger and more complex assemblies, some techniques related to system use will prove helpful. As you add parts to an assembly, the system has more to do and general performance suffers. Frequently the problem is that you’re displaying all of the model’s graphical geography even though you are only working on a small portion of the entire assembly. In Assembly mode, system speed is apparent when you regenerate a model, place a component that contains a large number of features, or simply change your model’s view. Slow system speed is especially evident when creating large and complex assemblies.

To improve system speed and visual clarity, try one of the techniques listed below:

- Use layers to blank unnecessary components.
- Create simplified representations to remove excess geometry.
- Suppress features or components.
- Use envelopes or shrinkwraps to simplify complicated or many parts.

All of these techniques allow you to control which components of an assembly the system retrieves and displays. Additional information about layers and suppressing can be found in this guide. Refer to the Pro/ENGINEER online help topics for information about other advanced Pro/ENGINEER performance tools.
This chapter provides information about all the sources you can count on for support in working with Pro/ENGINEER. The three main areas of support are:

- Pro/ENGINEER Help Center
- Pro/ENGINEER Wildfire 3.0 Resource Center
- Technical Support
- PTC Training Services
- PTC User Community

As you become more familiar with these sources, you’ll find that they overlap in areas of expertise. A PTC online account is required to access PTC documentation from the Web. Register for a PTC online account at www.ptc.com/appserver/common/account/basic.jsp.

**Note**

The Adobe Acrobat Reader is required to read PDF files. See www.adobe.com/supportservice/custsupport/download.html to download a free Acrobat Reader.

**Pro/ENGINEER Help Center**

You can access Pro/ENGINEER context-sensitive Help and books in PDF format by clicking Help > Help Center in Pro/ENGINEER or through context sensitivity. In the Help Center, see Using the Help Center for more information.
Pro/ENGINEER Resource Center

Web-based usability tools can help when learning Pro/ENGINEER. Access the Pro/ENGINEER Wildfire 3.0 Resource Center from the Pro/ENGINEER browser, through the Pro/ENGINEER Help Center, or at www.ptc.com/community/proewf3/newtools/index.htm. The tools include the following:

- **Web Tools and Tutorials**—Step-by-step instructions and other helpful topics. Navigate to the tutorials from the Resource Center or go directly to www.ptc.com/go/wildfire/get/index.htm and click Online Tutorials.

- **Quick Reference Card**—Handy reference for toolbars, selection techniques, dynamic viewing, and more.

- **Productivity Tools**—An interactive guide to new tools to increase your productivity. Included are the selection tools, enhancements to viewing tools (Spin, Pan, and Zoom), and the Model Tree.

- **Menu Mapper**—A cross-reference of menu commands from Pro/ENGINEER 2001 and Pro/ENGINEER Wildfire to latest menu commands.

PTC Technical Support

Technical support for Pro/ENGINEER is available 24 hours a day, 7 days a week. You can contact them by phone, fax, e-mail, or FTP.

You can easily access the most current technical support contact information from within Pro/ENGINEER by clicking the Support link on the Pro/E browser homepage.

PTC Training Services

PTC Training Services offers a multitude of solutions that embrace the Precision Learning methodology. Precision Learning is a continuous cycle of Learn-Assess-Improve focused toward providing the right training to the right people and doing this at the right time using the right method.

Learning activities, whether taught by an industry-experienced PTC certified instructor or a PTC Web course, embrace a “tell me, show me, let me do” philosophy to maximize understanding and retention. Visit www.ptc.com for a wide range of instructor-led and Web courses offered by PTC Training Services (click on Services & Training > Training Services).
PTC Training Services prides itself in the flexibility of its solutions. The flexibility in delivery of PTC instructor-led courses includes:

- **Course Customization**—Courses are tailored to the individual needs of your company, eliminating any topics that are not relevant to your company’s situation.

- **On-site Training**—PTC sends the instructor to you and provides training machines through our responsive traveling laptop centers.

Assessing the impact of training is key to planning the most efficient training, and to measuring the return on your training investment. Pro/FICIENCY Evaluator lets you gain an accurate and impartial evaluation of your personal, department, and company skills.

Pro/FICIENCY Evaluator reveals any areas where skill improvement would prove beneficial to your design team. Improvement activities include Web lessons, (short, tactical how-to topics provided on the PTC customer support Web pages,) books, mentoring, and so forth.

**Pro/ENGINEER User Community**

Pro/USER provides education and communication for users of PTC software. They offer ad-hoc yearly seminars at the Pro/USER International Conference. Visit [http://www.ptcuser.org](http://www.ptcuser.org) for a list of training seminars.
assembly  A structured combination of parts and possibly other assemblies (subassemblies).

associative relationship  The relationship between objects that reference each other. When changes are made to the design in one area of the product, all of the areas are updated to reflect that change.

base component  The component in an assembly that is referenced by all of the subsequent components, either directly or indirectly.

child  An object, such as a part or a feature, that is dependent on another object for its existence. See also parent.

collector  An interface tool for collecting single or multiple references when defining geometry.

cfg.pro file  See configuration file.

configuration file  A text file that contains default settings for many Pro/ENGINEER functions. Default environment, units, files, directories, and so on, are set when Pro/ENGINEER reads this file on startup. A configuration file can reside in the startup directory to set the values for your working session only, or it can reside in the load directory to set values for all users running that version of Pro/ENGINEER. Use the Utilities > Options dialog box to view and edit configuration options.

constraint  A limitation that states that one object has a definite geometric relationship to another.

dashboard  The interface environment used when defining or editing geometric features. Each feature type employs a specific dashboard.

datum  A point of reference in space that Pro/ENGINEER uses to calculate distances. A datum can be an actual point, a plane, or a curve, but it has no actual thickness.

design intent  An overview of component interaction toward a common purpose.
detailed view   A drafting view that shows a small area of another view at a larger scale. This process places a box and a note around the detailed area on the parent view and creates the new detailed view to a new scale.

drawing file   A 2D mechanical drawing derived from a 3D model that enables measurements to be interpreted.

driven dimension   Dimensions in a drawing file derived from the 3D model. Driven dimensions reflect changes to part or assembly geometry, but you cannot modify their values from the drawing. The association is one way: from the model to the drawing. See also driving dimension.

driving dimension   Dimensions that when modified in the drawing are also modified in the 3D model from which they originated.

fully constrained   In an assembly, a part with constraints defined to another part on more than one side.

feature   An element of a designed object such as a hole, protrusion, or round.

"in session" file   A file that is in memory, but may or may not be visible in a window. For example, when you open an assembly, all associated part files are in session, although they may not all be visible as separate, open files.

Menu Manager   The floating menu bar that expands as necessary to provide prompts through options, as objects are created or modified.

mode   A Pro/ENGINEER environment in which closely related functions are performed, for example Part mode and Assembly mode.

Model Tree   A list of every feature in a part or assembly file, including datums.

packaged component   Components that are partially constrained or not constrained to other parts in an assembly.

parametric relationship   The relationship between objects that are interdependent for dimensions or shapes.

parent   An item in a model that has other items (children) dependent upon it for dimensions or shapes. If a parent is deleted, all dependent items (children) are deleted as well. See also child.

part   A component consisting of features that can be separated from or attached to an assembly.

partially constrained   In an assembly, a part with constraints to another part on only one side, or a part that is placed but unconstrained. Also called a packaged component.

projection view   A drawing view derived from one side of a solid.

relations   Associativity between dimensions that is retained as the dimensions change.
section  A 2D outline in Sketcher mode of a 3D entity. The entity may be a solid, or it may be an area where material has been removed, like a cut or a channel.

shell  A feature that hollows out a solid to a given wall thickness.

shortcut menu  A menu that appears when you select an item or screen with the right mouse button. The shortcut menu contains commands pertaining to the item or screen that was selected.

Sketcher  A 2D drawing mode within Part mode used to draft dimensioned lines and arcs to create solid parts.

strong dimension  In Sketcher, a dimension to which you have given a value. See weak dimension.

top-down design  A method of designing a product by specifying top-level design criteria and passing those criteria down from the top level of the product’s structure to all of the affected parts.

view  The position of a part or assembly in the main window.

weak dimension  In Sketcher, a dimension that Pro/Engineer adds to an angle or a line automatically. The weak dimension is an approximation, shown in grayed lines. You convert the weak dimensions to strong dimensions by entering the accurate values.

witness line  A line that indicates the start and end of a dimension.

working directory  The default directory in which files are opened and saved.
Index

A
arcs
  creating in Sketcher 4-4
arrows
  editing in a drawing 6-12
assembly
  back cover part 5-16
  base component
determining 5-1
  cut out function 5-15
earpiece part 5-6
exploded views 5-18
front cover part 5-15
keypad part 5-12
lens part 5-4
microphone part 5-7
modifying 5-20
modifying part dimensions from 5-21
overview 5-1
packaged components 5-1, 5-12
placement constraints
  list of 5-2
  overview 5-1
placing components in 5-3
starting a new 5-3

B
backup files 2-4
BOM
  creating 6-14
BOM balloons
  showing in a drawing 6-17

C
centerlines
  in Sketcher 4-4
  using in Sketcher 4-4
configuration options
  overview 7-4
constraint symbols
  appearance of 3-5
constraints
  in assembly 5-1
  overview 3-5
  placing in Sketcher 3-5
  redefining assembly constraints 5-20
construction lines
  toggling lines to construction lines 4-20
coordinate systems
  overview 3-2
  copy commands for features 4-57, 4-59
cut extrusion feature
  creating 4-47

diameter dimension
adding in sketcher 4-32
dimensions
adding in Sketcher 3-4
dimension IDs 4-43
in drawings
  driving vs. driven dimensions 6-2
  moving 6-11
  Show/Erase dialog box 6-9
  showing and erasing 6-2
modifying in Sketcher 4-6
  showing dimension IDs 4-43
display options
  line or wireframe 2-8
draft feature 4-49
drawing mode exercises 6-1
drawings
  adding a detailed view 6-8
  adding driven dimensions 6-11
  adding views 6-4, 6-7
  and associativity 6-2
  bill of materials, adding 6-14
  creating tables in 6-14
detailed views 6-4
driving vs. driven dimensions 6-2
formats and templates 6-6
projected views 6-4
scaling views 6-5
setting the active model 6-3
showing dimensions 6-9
view types 6-4
  witness lines, editing 6-12
  driving vs. driven dimensions 6-2

E
earpiece part 4-10
edge chain, selecting with 4-51
extrusion
  procedure for creating 4-3
extrusions
  from sections 3-6

F
family tables 7-2
features
  cut 4-47
draft 4-49
  ordering 2-10
  patterns 4-13
  redefining 3-7
  rounds 4-8
  shell 4-51
  thin protrusion 4-73
files
  and the working directory 2-3
  backing up 2-4
  deleting permanently 2-5
  difference between erasing and
deleing 2-3
  difference between open and ‘in
session’ 2-2
  file iterations 2-4
  opening and saving 2-3
  previewing 2-3
  front cover part 4-60

H
holes
  countersink and counterbore 4-56
  procedures 4-12, 4-56
  radial pattern for 4-13
  setting depth for 4-26
  using the hole dashboard 4-12

L
layers
  overview 7-1
  lens part procedure 4-2
loop selection method 4-17

M
macros 7-7
mapkeys 7-7
microphone part 4-15
mirror command
  in sketcher 4-5
Model tree 2-1
  ordering features in 2-10
  moving drawing views 6-7

O
offset datums, creating 4-52
ordering features 2-10
P
packaged components 5-1, 5-12
parts
  creating sections for 3-7
  defining features for 3-3
  design tools overview 3-1
  redefining features of 3-7
patterns
  in two directions 4-38
  overview 4-13
  radial 4-13
PC board part 4-23
Pick from List function 2-10
Pro/ENGINEER
  Help and books 8-1
  productivity tools for users 8-2
  Quick Reference Card 8-2
  Resource Center 8-2
  Web tools and tutorials 8-2
procedures
  adding color to a part 4-9
  assembly 5-1
    assembling to the base component 5-4
      starting a new 5-3
  back cover 4-46
  copy and mirror in 3D 4-27
  datum curves 4-28
  dimensions, modifying in Sketcher 4-6
  drawing 6-1
  earpiece 4-10
  extrusions 4-3
  front cover 4-60
  lens 4-2
  microphone 4-15
  mirroring geometry in Sketcher 4-5
  patterns
    radial 4-13
  PC board 4-23
  revolved cuts 4-33
  revolved protrusions 4-31
  rounding edges 4-8
  select by loop 4-17
  Sketcher points, inserting 4-20

R
relations
  using to drive dimensions 4-43
repeat regions in tables 6-16
revolved cut 4-33
round feature
  creating 4-8
rounding edges 4-8

S
sections
  creating in Sketcher 3-4
  extruding to 3D 3-6
  saving 4-6
selecting
  Pick from List 2-10, 4-41
  using edge chain 4-51
shell feature 4-51
Sketcher
  adding dimensions in 3-4
  basic setup sequence 3-7
  centerlines in 4-4
  construction lines 4-20
  defining references in 3-4
  mirroring 4-21
  Modify Dimensions dialog box 4-6
  overview 3-3
  section, saving to a file 4-6
  Sketcher points 4-20
  the sketching plane 3-4
  tools, overview 3-4
  Trim command 4-64
  Undo command 4-4, 4-5
  Use Edge command 4-63
  weak dimensions 4-31
  toggle to strong 4-34
startup search sequence 7-4
supressed features
  showing in the model tree 2-10
suppressing design items
  in parts 2-10

T
tables
  creating in drawing 6-14
  entering text in 6-15
  parameters, adding 6-16
  repeat regions, defining 6-16
  thin protrusion 4-73
  Trim command in Sketcher 4-64
INDEX

Getting Started with Pro/ENGINEER Wildfire tutorials 8-2

U
Undo 4-4, 4-5
Use Edge command in Sketcher 4-63

V
viewport controls
recentering the view 2-5
spin modes 2-6
views (in 3D)
saved views 2-7
standard views 2-7
views (in drawing)
detailed view 6-4
general view 6-4
moving views 6-7
placing a detailed view 6-8
placing views 6-7
projected view 6-4
scaling views 6-5
showing dimensions in 6-9

W
weak and strong dimensions
difference between 3-3
windows
the active window 2-2
witness lines
editing 6-12

Z
zoom viewport controls 2-5