Department of Engineering

Introduction for New Users

Contents
Cambridge University Engineering Department
Teaching Workstations
Tim Love (August, 2011)
This document describes how to log on to the teaching system and perform simple file manipulation. Common tasks like printing, editing, getting help, accessing the World Wide Web and using e-mail are also addressed.

Getting Started

To start with, the computer will present you with a login window. If the screen is completely black then move the mouse slightly; if this doesn't revive the screen, you'll need to switch the computer on.

  • Type your user identifier (your CRS ID - something like xy123) and press the Return key. If you don't know your user identifier ask a demonstrator or one of the operators at the office end of the DPO.
  • Type in your CUED password (not your hermes password). First year students should have chosen a password during registration at the start of term. Other students should use their old password. When you type your password it will not be echoed to the screen. If you cannot remember your password, or it does not work, ask one of the operators. Unix is case sensitive, so make sure that "Caps Lock" is not set.
  • If you've not logged in before, you might be asked a few questions. Just reply ok or yes.
  • If there are new system announcements a window will appear. Read the messages and close the window if you wish.
taskbar

Once you have logged in successfully, a desktop will appear with a taskbar along the bottom. On the left of the bar are some icons that give you access to commonly used features.

Icons and files

Your Home Folder

desktopClick on the Home icon on the desktop. The icons you initially see in this window represent files or collections of files in the part of the file system that belongs to you. Let's create something.

Creating a New File

To create a new file, choose the Create Document option from the File menu, then select Empty File. Call the file sports.

When you come to name files yourself try to use only letters and digits - no spaces or punctuation characters (except for full stops). Note that Unix distinguishes the case of characters in file names. The file Sports is not the same file as sports.

Copying Files

To copy the sports file drag it to a new location while pressing down the Ctrl key. Alternatively, select it, use Copy from the File menu, then use Paste from the same menu. The copy will be called sports (copy). Change the name by holding the right mouse-button down on it and choosing the rename option.

Deleting Files

Make another copy of sports called doomed. Drag the file onto the Wastebasket (i.e. hold the left mouse-button down on and move the mouse until the icon is over the Wastebasket icon). Files stay there until the Wastebasket is emptied. You can empty it by holding the right mouse-button down on it and choosing the final option. Do that now.

Multiple File Selection

To select several files at once (so you can throw them away all together, for example) you can drag a rectangle over them with the left mouse-button. Alternatively you can click on them one at a time with the CTRL key held down.

Folders

Creating a New Folder

Imagine that the sports file contains a list of the sports you like playing and the activities file contains a list of all the other leisure activities you enjoy. It might be nice if you could create a separate place to put sports and activities. This is what a folder is for. Folders (e.g. your home folder) can contain files and other sub-folders.

Choose the New Folder option from the File menu. Call the folder clump. Note how the icon of this folder looks different to ordinary file icons.

Double click on this new icon to open it out. You will see a folder just like your home folder, but empty. The underlying structure is that all the folders are arranged in a tree. If you click on the Up arrow of the window it will take you back to your Home folder because that is the parent folder of clump.

Moving and Copying Between Folders

Now we'll try moving the sports files into the clump directory. If you drag the sports icon onto the clump icon, your file will have moved into the folder. If you want to copy the file, leaving the original intact, then drag while pressing down the Ctrl key.

Window management

Once you've created a window, you'll want to manipulate it

  • Move - you can drag a window around using its title bar.
  • Resize - you can drag a window's corner to resize it.
  • Iconify - if you click on the _ near the top right hand corner of the folder window, it will tumble down into the task-bar at the bottom of the screen. The window can be restored by clicking on its name in the task-bar
  • Full Screen - to fill the screen with the window, click on the box near the top right hand corner of the directory window.
  • Kill - clicking on the x box kills the window. Using this risks losing your unsaved work. Try to use the program's Exit option instead.

Note that you might have to click on a window before the text that you type goes into it.

When you have lots of windows you need to be able to manage them. Near the bottom-right corner of the desktop there's a "Screens" panel . This shows you 4 scaled-down desktops that you can flick between and move windows between to give you much more screen-space.

Clicking on icons

Double-clicking on a folder opens it. Double-clicking on a program runs it. Clicking on a file usually runs the default program for files of that type. But sometimes you won't want the default. If you hold the right-button down on a file, you'll be offered some common alternatives when you select the Open With option.

Using the Emacs editor

We have a few text editors online. gedit is the default - which you should have no trouble with. The emacs text editor is required in some lab sessions. It's more powerful than gedit but less intuitive, so here's a short tutorial. Create a file called pomodoro in your home directory. Now let's put something in the file using emacs. Load it into emacs by using the right mouse-button's Open With option. In Emacs you will see the majority of the screen is used to display the file you are editing. Below this is a bar with something like

--:--   pomodoro      (Fundamental)--L1--ALL-------

Beneath this there is a single line (the mini-buffer) for messages and editor commands. Along the top of the window is a menu-bar and icons.

Type in several lines of text (pressing the Return key at the end of each line). The arrow keys, and Delete key will work though the NumPad keys won't work until you press the Num Lock key.

There is an online tutorial for advanced emacs users which is started from emacs' Help menu. It is not recommended that you do this now. Further details can be found in the Unix from the Command Line handout.

Emacs menus and shortcuts

Across the top of the emacs window is a series of menus. The File menu contains items that let you load and save files. Select the Open File... option. A prompt will appear at the bottom of the window. If you were to type the name of a file here you would be able to edit that file. We won't do this just now so go to the Minibuf menu and select Quit to cancel the operation.

Go back to the File menu and select the Save Buffer item. This saves the file you are editing to disk. You must save files to disk before you try to perform any operations on them outside the editor.

You can use the Search item in the Search sub-menu to look for particular text though a quicker, incremental search is available if you hold the Ctrl button down and type S. Try searching for something now. Use the Minibuf menu's Quit to cancel.

Make sure pomodoro is at least five lines long and pull down the Edit menu. From the Go To sub-menu pick the Goto Line item. When the prompt appears specify 5 and press the Return key. The cursor should move to the fifth line of the file. Note that the line number is shown in the status line near the bottom of the window -- L5.

To copy some text, drag the mouse cursor over it using the left mouse button. Then click with the middle mouse button where you want the text to be copied. This facility also works between most kinds of text windows.

To delete a block of text, click once with the left mouse button at one end, and twice with the right mouse button at the other (or choose the Cut item in the Edit menu). If you want to move the text elsewhere, just click on the location with the middle mouse button.

If you want to move quickly around a document that is too big to fit on one page, you can use the scrollbar on the left of the window or the Page Up and Page Down on the keyboard by the arrow keys.

If you made an editing mistake you can use the Undo option in the Edit menu repeatedly until you get back to the way you were.

The Exit Emacs item in the Files menu makes the editor offer to save any files you have changed during the current editing session, and then kills the editor program. A backup copy of each file you change is kept by the editor. These are the files with names ending in the character `~'. Don't worry if you cannot always see them in your directory window, you will only need to use them if things go badly wrong.

Many of these actions can be performed using the icons under the menu-bar. Experiment to find out what they do.

Applications

controlcenter
If you click on the greenarrow button at the bottom-left of the screen you'll get a panel from which you can explore the teaching and system programs we have. In particular there's Firefox - a web browser. You can use it for webmail too. You will need to become familiar with using the WWW. There's also LibreOffice for document preparation, Matlab (a programmable graphical calculator) and the control centre (in the System section of the applications menu) where you can configure your set-up.

Locally based programs include Help, Fast Feedback, and Survey.

- a short-cut to CUED's help-on-the-web and list of Frequently Asked Questions. Try to become familiar with using the help system - our Feedback Facility. Your chance to offer instant, anonymous feedback on teaching, computing, etc. - our under-graduate user survey.

The help page

Fast Feedback (click to zoom in)

The Survey (click to zoom in)

Terminal Window

Traditionally, Unix was run by typing commands into a terminal window. You'll need to work this way sometimes. To get a Terminal Window click on the little terminal icon at the bottom of the screen. If you want to know more about this way of working, read the Unix from the command line document.

If you are doing a practical that asks you to type a start command (`start camclay', for example) you can use the icon or type the command into a Terminal Window.

Printing

Printing is a 2 stage process. First you use the Print menu option of the program in the usual way, then you confirm by clicking on the button in the taskbar.

Logging off

To Log Out, use the logout button on the bottom-left of the screen.

To know more

To find out about other programs, customising, and the Terminal window look at part 2 of this document.